• Boot fails on LTS kernel

    I did a new install of Antergos 19.1 KDE and selected the LTS kernel during the installation process.
    Later i tried to boot with the LTS kernel and nothing works, only black screen with cursor on top left corner is flashing, i waited 3-4 minutes and nothing. I tried again 2 times and same thing. The system only works on kernel 4.20.6 by default.

  • which desktop are you on ? if gnome or kde, try to change the display manager to gdm for gnome or sddm for kde ?

  • @ringo32
    I use KDE so i applied your suggestion and installed SDDM and the LTS kernel still not booting.

  • I don’t know what other information i could bring except the system does’nt boot on the LTS kernel when chosen from the GRUB menu. It only boot successfuly from the default 4.20.6 kernel.

  • it may boot but you do not get to dm-login-screen…

    you can show logs for last boot if you boot first from LTS, then with main kernel and run this command:

    lspci > log.txt && lsusb >> log.txt && journalctl -b -1 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1

    after command is done it gives a new LINK to a pastebin with logs from failed boot and system informations… you can post here

  • @joekamprad
    So i did like you told me, i tried to boot first at 7:59am with LTS kernel (failed again) and then i booted with the default (4.20.7) kernel at 8:00am wich succeeded.

    Here is the boot repport :

  • @philipc
    If you boot with the LTS kernel and the screen gets blank, can you then press key combination Ctrl-Alt-F2 and get to the console where (command line) login is possible?

  • @manuel
    Yes i did and i enter my user name and then my password, but after the screen was still blank!

  • @philipc
    Could you show a picture about that?

  • @philipc
    If you can boot that way, then you can also give journalctl -b0 command and show the result here via e.g. pastebin.

  • @manuel
    Here’s a picture of what i get after entering my user name and password ( ctl+alt+f2) for the LTS kernel boot :

  • @manuel
    Here’s the new journal :

  • @philipc
    Seems that lightdm is not starting correctly.
    Now that you can give commands, you could try another display manager:

    sudo pacman -S sddm
    sudo systemctl disable lightdm
    sudo systemctl enable sddm
  • @manuel
    I already tried SDDM and the result is the same, boot with LTS kernel fails.
    See my comment above about SDDM.
    Ringo32 gave me this suggestion!

  • Wat is the hardware video-kaart & drivers are you using ?

  • pacman -S nvidia-390xx-lts needs to be installed also

  • @philipc said in Boot fails on LTS kernel:

    Ringo32 gave me this suggestion!

    Sorry about that, TL;DR I guess… ;)

  • @philipc
    You might want to install nvidia-installer and run it. Please show the result here:

    sudo pacman -S nvidia-installer
    nvidia-installer -t

    This should show if any packages are missing.

boot320 kernel152 lts20 fail20 Posts 25Views 193
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.