• Blank screen after updating system

    I have antergos up and running, and after a system update with “pacman -Syu” I get a blank screen on booting.

    I can’t event switch to console using ctrl-alt-fx

    I have a dell Inspiron 11

    Here’s some info that might help (I’m running it from an ubuntu 18.04.1 on a different partition)

    $ lspci | grep VGA
    00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)

    $ lsmod | grep “kms|drm”
    drm_kms_helper 172032 1 i915
    syscopyarea 16384 1 drm_kms_helper
    sysfillrect 16384 1 drm_kms_helper
    sysimgblt 16384 1 drm_kms_helper
    fb_sys_fops 16384 1 drm_kms_helper
    drm 401408 15 drm_kms_helper,i915

    I can access my antergos partition, but I don’t know which logs sould I have a look at.

    On another partiion I installed manjaro and I have the same trouble.

    Some more info that might be useful:

    $ inxi -Fxxxz
    System: Host: bionic Kernel: 4.15.0-44-generic x86_64 bits: 64 gcc: 7.3.0
    Desktop: Gnome 3.28.3 (Gtk 3.22.30-1ubuntu1) info: gnome-shell dm: gdm3 Distro: Ubuntu 18.04.1 LTS
    Machine: Device: portable System: Dell product: Inspiron 11 - 3148 v: 00h serial: N/A
    Mobo: Dell model: 0NKPM9 v: A00 serial: N/A UEFI [Legacy]: Dell v: A00 date: 06/30/2014
    Battery BAT0: charge: 45.1 Wh 1891.4% condition: 2.4/45.1 Wh (5%) volts: 12.1/10.8
    model: SANYO DELL 4K8YH481 Li-ion serial: <filter>status: Full cycles: 0
    CPU: Dual core Intel Core i3-4010U (-MT-MCP-) arch: Haswell rev.1 cache: 3072 KB
    flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6784
    clock speeds: min/max: 800/1700 MHz 1: 1696 MHz 2: 1696 MHz 3: 1696 MHz 4: 1696 MHz
    Graphics: Card: Intel Haswell-ULT Integrated Graphics Controller bus-ID: 00:02.0 chip-ID: 8086:0a16
    Display Server: x11 (X.Org 1.19.6 ) driver: i915 Resolution: [email protected], [email protected]
    OpenGL: renderer: Mesa DRI Intel Haswell Mobile
    version: 4.5 Mesa 18.2.2 (compat-v: 3.0) Direct Render: Yes
    Audio: Card-1 Intel 8 Series HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:9c20
    Card-2 Intel Haswell-ULT HD Audio Controller driver: snd_hda_intel bus-ID: 00:03.0 chip-ID: 8086:0a0c
    Sound: Advanced Linux Sound Architecture v: k4.15.0-44-generic
    Network: Card: Broadcom Limited BCM43142 802.11b/g/n driver: wl bus-ID: 01:00.0 chip-ID: 14e4:4365
    IF: wlp1s0 state: up mac: <filter>
    Drives: HDD Total Size: 480.1GB (70.2% used)
    ID-1: /dev/sda model: KINGSTON_SV300S3 size: 480.1GB serial: <filter> temp: 35C
    Partition: ID-1: / size: 20G used: 11G (58%) fs: ext4 dev: /dev/sda5
    RAID: System: supported: N/A
    No RAID devices: /proc/mdstat, md_mod kernel module present
    Unused Devices: none
    Sensors: System Temperatures: cpu: 62.0C mobo: N/A
    Fan Speeds (in rpm): cpu: N/A
    Info: Processes: 289 Uptime: 22:41 Memory: 2518.6/7905.1MB Init: systemd v: 237 runlevel: 5 Gcc sys: 7.3.0
    Client: Shell (bash 4.4.191 running in terminator) inxi: 2.3.56

  • @opensas
    You can boot with the Antergos installer USB stick, and chroot to the installed Antergos.
    So after boot, start a terminal.

    Below you’ll need values for X, Y, and Z, you can see them with e.g.

    lsblk -fm

    Now chroot to Antergos:

    mount /dev/sdXY /mnt       # Antergos root partition
    mount /dev/sdXZ /mnt/boot  # Antergos boot partition, if you have it
    arch-chroot /mnt

    Now you are in the installed Antergos.

    Some ideas you could try to fix or work around the problem:

    • You might want to try a different kernel:
    pacman -S linux-lts linux-lts-headers
    • Change Display Manager (lightdm, sddm, gdm)
    pacman -S sddm             # new DM
    systemctl disable lightdm  # current DM
    systemctl enable sddm      # new DM
    • Update again, now refreshing the repos:
    pacman -Syyu

    and reboot to the installed Antergos.
    If any of these doesn’t work, repeat and try another.

  • @manuel I’d like to try some of those step, but the problem I have is that antergos live cd won’t recognize my wifi card. Once installed, it does recognizes it, but it won’t pick it from the live cd.

    I can boot to a manjaro or ubuntu partition, but I can’t run arch-chroot from there

    Is there some way to manually mount the antergos partition, or download arch-chroot to use from other distros?

    I’ve just installed it with $ sudo pacman -S arch-install-scripts… wish me luck

  • it seems the problem is the display manager

    I disabled lightdm and enabled gdm and now it works

    I tried reinstalling lightdm but still get the same problem

    also tried to uninstall it but I get:

    $ pacman -Rns lightdm
    [sudo] password for sas: 
    checking dependencies...
    error: failed to prepare transaction (could not satisfy dependencies)
    :: antergos-common-meta: removing lightdm breaks dependency 'lightdm'
    :: gnome-shell-extension-status-menu-buttons: removing lightdm breaks dependency 'lightdm'
    :: light-locker: removing lightdm breaks dependency 'lightdm'
    :: lightdm-webkit2-greeter: removing lightdm breaks dependency 'lightdm'

    Any other idea how could I troubleshhot lightdm?

  • Reinstalling do not help in most cases.
    Troubleshoot needs logs

display59 blank screen12 boot error8 Posts 6Views 93
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.