• Can't install bumblebee properly


    @manuel
    2019-02-04 18:44:29 [INFO]: Antergos Nvidia Installer v1.17
    2019-02-04 18:44:29 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
    2019-02-04 18:44:29 [INFO]: Running the installer in testing mode…
    2019-02-04 18:44:29 [INFO]: Installing bumblebee driver…
    2019-02-04 18:44:29 [INFO]: Removing conflicting packages…
    2019-02-04 18:44:29 [INFO]: Downloading and installing driver packages, please wait…
    2019-02-04 18:44:29 [INFO]: pacman -Sqy --noconfirm --noprogressbar bumblebee mesa xf86-video-intel nvidia virtualgl nvidia-settings bbswitch lib32-nvidia-utils lib32-virtualgl lib32-mesa nvidia-lts bbswitch-dkms
    2019-02-04 18:44:29 [INFO]: Adding user nad to bumblebee group…
    2019-02-04 18:44:29 [INFO]: gpasswd -a nad bumblebee
    2019-02-04 18:44:29 [INFO]: Adding user nad to video group…
    2019-02-04 18:44:29 [INFO]: gpasswd -a nad video
    2019-02-04 18:44:29 [INFO]: Enabling bumblebeed.service service…
    2019-02-04 18:44:29 [INFO]: systemctl enable bumblebeed.service
    2019-02-04 18:44:29 [INFO]: Patching /usr/share/applications/nvidia-settings.desktop…
    2019-02-04 18:44:29 [INFO]: sed -i s|Exec=/usr/bin/nvidia-settings|Exec=optirun -b none /usr/bin/nvidia-settings -c :8| /usr/share/applications/nvidia-settings.desktop
    2019-02-04 18:44:29 [INFO]: /etc/X11/xorg.conf.d/20-nvidia.conf not found. That’s ok.
    2019-02-04 18:44:29 [INFO]: Installation finished. Nothing has been modified as testing mode was ON.

  • @konstantinova
    Thanks, that looks good, but strange it didn’t work.

  • https://www.geforce.com/hardware/notebook-gpus/geforce-gtx-950m

    is a optimus card…

    but make it sure with the output of this command:

    lspci -vnn | grep '\''[030[02]]'
    

    geforce-gtx-950m is not listed in the known working cards inside Antergos bumblebee wiki entry…

    Without a full bootlog journalctl -b -0 or pastbin it:
    journalctl -b -0 | curl -F [email protected] https://ptpb.pw/?u=1 and give the link here it will give out after processing the command.
    I can not see what exactly is going wrong.

  • @joekamprad
    00:02.0 VGA compatible controller [0300]: Intel Corporation HD Graphics 530 [8086:191b] (rev 06) (prog-if 00 [VGA controller])
    01:00.0 3D controller [0302]: NVIDIA Corporation GM107M [GeForce GTX 950M] [10de:139a] (rev a2)

    journalctl -b -1
    https://ptpb.pw/J7PI

  • @konstantinova
    I suppose the journal is when you have only Intel graphics driver installed.

    Can you provide journal and xorg log (/var/log/Xorg.0.log) after you have installed nvidia drivers and bumblebee and rebooted?

    You probably need to use console, like Ctrl-Alt-F2 to get to the console.

  • @manuel
    I’ve tried to install bumblebee only for 4.20.6-arch1-1-ARCH. thats why I’ve send previous boot(4.20.6-arch1-1-ARCH) not current (using lts kernel)
    I also can’t switch to console while trying to boot with main kernel Ctrl-Alt-F2/F3/F4/F5/F6 doesn’t work (have to turn off laptop using power button)
    If I install nvidia-lts bbswitch-dkms, I won’t be able to boot with lts kernel too.

  • Errors from my first post were because I forgot to add nvidia-lts during bumblebee installation. As @joekamprad mentioned. And booted with lts kernel, no wonder there were errors. I was dumb. Now the problem is that I can’t boot if I install bumblebee.

  • My advice is, make a clean installation and try this:

    • Install the last avaliable version of nvidia drivers (Don’t reboot yet).
    • Install the package optimus-manager (or Take it from github)
    • Follow the steps described in “installation” and “usage

    And thats it, after you reboot your computer everything should be working fine. See more.

  • Out of curiosity, can you just use Prime?

    My wife’s laptop is an older gaming laptop with hybrid graphics… Intel Sandy Bridge & a GeForce 920M. I installed the NVidia proprietary graphics driver, and using the NVidia control panel, set it to use the Intel graphics as default. Then for anything I want to run using the NVidia graphics, I just edited the launcher to invoke it with “PRIME_RUN=1 %command%” (that’s the Steam-specific edit you’d need to make… Lutris actually has a checkbox in the launcher settings to use Prime, and is easier to configure in that respect). While the laptop absolutely supports bumblebee as a launcher, and I have actually used bumblebee on it, I found that Prime was much less headache to get working and was a set it & forget it method.

error334 installation321 bumblebee49 Posts 29Views 233
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.