• Can't install bumblebee properly


    Hi everyone,
    I’ve installed Antegros a few days ago on laptop with Intel Corporation HD Graphics 530 and nvidia 950m. And tried to install bumblebee, but not in the right way, I suppose. Antegros with linux 4.20.6.arch1-1 now stucks during boot. so booted with linux-lts 4.19.18-1

    [ 395.961647] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) Failed to load module “nouveau” (module does not exist, 0)
    [ 395.961676] [ERROR]Aborting because fallback start is disabled.

    I’ve changed line Driver= to Driver=nvidia in /etc/bumblebee/bumblebee.conf
    after that I’ve got:

    [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [ERROR]Could not connect to bumblebee daemon - is it running?

    I will appreciate any help.

  • How do you install/configure bumblebee?

  • @joekamprad
    sudo pacman -S bumblebee mesa nvidia nvidia-settings xf86-video-intel lib32-nvidia-utils lib32-virtualgl bbswitch
    sudo gpasswd -a nad bumblebee
    sudo systemctl enable bumblebeed.service
    reboot

  • @konstantinova
    How about installing package nvidia-installer and run command

    nvidia-installer -h
    

    to give some help about the usage.

    Then test what it would do:

    nvidia-installer -b -t
    

    If you are OK with the results, then run

    sudo nvidia-installer -b
    

    But before really installing (the last command above), you may need to remove the bumblebee or nvidia settings you did before. Please show what you currently have in /etc/X11/xorg.conf.d:

    ls -l /etc/X11/xorg.conf.d
    
  • @manuel

    /etc/X11/xorg.conf.d

    -rw-r–r-- 1 root root 311 фев 1 16:51 00-keyboard.conf
    -rw-r–r-- 1 root root 1691 фев 1 16:54 50-synaptics.conf
    -rw-r–r-- 1 root root 216 фев 1 16:54 99-killX.conf

  • @konstantinova
    OK, you don’t seem to have anything to remove there.

  • @konstantinova said in Can't install bumblebee properly:

    @joekamprad
    sudo pacman -S bumblebee mesa nvidia nvidia-settings xf86-video-intel lib32-nvidia-utils lib32-virtualgl bbswitch
    sudo gpasswd -a nad bumblebee
    sudo systemctl enable bumblebeed.service
    reboot

    sudo pacman -Rc xf86-video-nouveau
    sudo gpasswd -a $USER video
    

    is missing as wiki say:
    https://antergos.com/wiki/hardware/bumblebee-for-nvidia-optimus/
    but it should be the easier way to use what @manuel is giving you:
    https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/#Bumblebee

  • @joekamprad
    I did sudo pacman -Rsc xf86-video-nouveau and sudo gpasswd -a nad video 2 days ago
    nothing has changed.
    After that I found information that bbswitch may be configurated (don’t know how to name this correctly) for another kernel, not for kernel I’m using. as I couldn’t boot with 4.20.6.arch1-1 and used linux-lts 4.19.18-1 I thought it may be true because nvidia driver was 415.27-3.
    so I did
    sudo pacman -Rsc linux (bbswitch-0.8-194 nvidia-415.27-3 linux-4.20.6.arch1-1 were delited after this command)
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    reboot
    after that during boot I had only lts Kernel so dicided that I did this correctly
    delited bumblebee
    sudo pacman -Rsc bumblebee
    and tried to install bumblebee again using the same commands but linux-4.20.6.arch1-1 was installed again altough I didn’t mention linux after pacman -S. I don’t know why. So the were bbswitch-0.8-194 nvidia-415.27-3 linux-4.20.6.arch1-1 again

  • @konstantinova said in Can't install bumblebee properly:

    nvidia

    is for main kernel, for LTS kernel you need nvidia-lts !

  • @konstantinova
    What happens if you run the following commands:

    su
    pacman -S --needed nvidia-installer
    pacman -S --needed linux linux-lts linux-headers linux-lts-headers
    pacman -S --needed nvidia-dkms
    nvidia-installer -b
    

    and reboot?

  • @joekamprad
    Thank you. stupid mistake

  • @manuel
    nvidia-installer -b
    Cannot install required packages ‘nvidia’ and ‘nvidia-dkms’ are in conflict
    don’t know how to refuse installation of nvidia

  • Seems nvidia-installer -b do not detect kernels installed itself…

  • @konstantinova said in Can't install bumblebee properly:

    Cannot install required packages ‘nvidia’ and ‘nvidia-dkms’ are in conflict

    but it should work with nvidia-lts or nvidia-dkms installed after using nvidia-installer

  • @konstantinova
    You may remove nvidia before running the commands. Sorry about that, I wasn’t careful enough.

  • @manuel
    Now I also can’t boot with lts kernel

  • @konstantinova
    Then you could go back to using only Intel graphics, that should enable you to boot.

    To do that,

    • uninstall packages starting with words nvidia, bumblebee and bbswitch
    # first check which you have as installed
    pacman -Qqs nvidia | grep "^nvidia"
    pacman -Qqs bumblebee
    pacman -Qqs bbswitch
    # then remove the ones that start with nvidia, bumblebee or bbswitch
    # with "sudo pacman -R <names>"
    
    • if /etc/X11/xorg.conf.d contains file 20-nvidia.conf, remove it
    • make sure you have installed Intel related video drivers xf86-video-fbdev and xf86-video-vesa. Optionally xf86-video-intel.

    Can you boot now?

    This may help: https://antergos.com/wiki/hardware/bumblebee-for-nvidia-optimus/

  • @manuel
    Yes I can boot with Intel drives but what should I do to make bumblebee work, feel like nothing can help with this problem

  • Reinstalled Antegros again. Added modprobe.blacklist=nouveau in boot menu before installation. Added modprobe.blacklist=nouveau before first boot, deleted nouveau driver. And so on from this instruction. I did this steps 3 times, result doesn’t change, I guess because everything that I do is the same

  • @konstantinova
    Strange.
    I thought nvidia-installer should work, but maybe that’s not true in all cases.
    Could you still show what

    nvidia-installer -b -t
    

    prints? It doesn’t change anything with those options.

    Does @joekamprad have any definitive ideas?

    I’m currently out of ideas, except that the Arch wiki might have some useful nvidia/bumblebee/optimus-manager stuff like
    https://wiki.archlinux.org/index.php/NVIDIA_Optimus
    https://wiki.archlinux.org/index.php/Bumblebee
    https://wiki.archlinux.org/index.php/NVIDIA

error328 installation316 bumblebee48 Posts 29Views 209
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.