• (SOLUCIONADO) Inicio de sesión automático


    Hola,

    Les comento lo sucedido: He tenido que instalar y reinstalar el sistema algunas veces para solucionar algunos problemas que tenía con Gnome (el entorno se veía muy mal luego de reiniciar debido a que durante la instalación algo parece haber ido mal con los drivers Ati para mi tarjeta de vídeo). Finalmente, logré solucionar el asunto pero al instalar la última vez olvidé marcar la opción de iniciar sesión automáticamente, así que cada vez que prendo la notebook debo logearme (lo cual es incómodo e innecesario debido a que soy el único usuario de la terminal).

    Ya intenté cambiar la configuración desde la opciones de usuarios de Gnome y también probé editando el archivo lightdm.conf, pero ninguno de esos métodos me funcionó.

    Gracias de antemano.

  • Hola,

    Les comento lo sucedido: He tenido que instalar y reinstalar el sistema algunas veces para solucionar algunos problemas que tenía con Gnome (el entorno se veía muy mal luego de reiniciar debido a que durante la instalación algo parece haber ido mal con los drivers Ati para mi tarjeta de vídeo). Finalmente, logré solucionar el asunto pero al instalar la última vez olvidé marcar la opción de iniciar sesión automáticamente, así que cada vez que prendo la notebook debo logearme (lo cual es incómodo e innecesario debido a que soy el único usuario de la terminal).

    Ya intenté cambiar la configuración desde la opciones de usuarios de Gnome y también probé editando el archivo lightdm.conf, pero ninguno de esos métodos me funcionó.

    Gracias de antemano.

  • ¿En que parte del lightdm.conf has añadido tu usuario?

    En la siguiente línea

      
      
    Si la descomentas, agregas tu usuario y salvas cambios debería funcionar.  
      
    
    

    Antergos (Gnome)

  • Sí ya había probado eso, y ahora he intentado de nuevo:

    Entré a lightdm.conf (como root) y vi que son dos las líneas iguales (la 33 y la 105), las descomenté y les agregué al final mi nombre de usuario, pero no funcionó…


    PD: Soy seguidor de tu movedizo blog y debo decirte que es genial. Felicitaciones. (De hecho, me pasé definitivamente a Antergos debido a tus reseñas, y estoy estoy muy contento porque el sistema operativo es genial, y como fanático de Gnome que soy, me siento a mis anchas con todo el artwork de Numix y lo fantástico que anda en Antergos).

  • Ok, bueno, entonces como quieres sesión automática no te va a hacer daño instalar el gestor de sesiones de Gnome, GDM, en vez de usar Lightdm

    Instala GDM

    sudo pacman -S gdm
    

    Lightdm no lo desinstalamos, lo dejamos ahí de repuesto

    Ahora deshabilita lightdm

    sudo systemctl disable lightdm
    

    Y habilita gdm

    sudo systemctl enable gdm
    

    Ahora te vas a la configuración del sistema, Usuarios, desbloqueas y marcas como activa la opción de inicio de sesión automático y luego vuelves a bloquear para que no se cambie.

    [[img:2pihmuge]http://wstaw.org/m/2014/08/22/Usuarios_004_png_300x300_q85.jpg[/img:2pihmuge][/url:2pihmuge]

    Ya está, ya iniciaras sin gestor de sesiones en tu próximo reinicio, probado ahora mismo por mi y funcionando

    Antergos (Gnome)

  • Sí, Yoyo, funciona pero cambia el gestor con lo cual se pierde el theme de Antergos (que es una de las cosas que el equipo de esta distro ha hecho muy bien).

    Igual, encontré la solución en la wiki de Arch (es grandiosa…). Era en parte lo que vos decías más arriba, pero con editar el lightdm.conf no alcanza:

    "LightDM pasa por PAM incluso cuando autologin está habilitada. Usted debe ser parte del grupo de inicio de sesión automático para poder iniciar sesión sin introducir su contraseña:

    # Groupadd autologin
    # Gpasswd: un nombre de usuario de sesión automático"

    Entonces los pasos serían dos:

    1. Editar lightdm.conf
    2. Agregar el usuario al grupo de inicio de sesión automático.

    Y listo… ¡autologin en lightdm funcionando sin problemas!

    Gracias Yoyo por tu ayuda.

  • No entendí esto

    pero pero cambia el gestor con lo cual se pierde el theme de Antergos

    A mi no se me ha perdido ningún theme, los themes puedes cambiarlos desde la herramienta retoques (gnome-tweak-toool)

    [[img:3r79euua]http://wstaw.org/m/2014/08/22/gnome-tweak-tool_005_png_300x300_q85.jpg[/img:3r79euua][/url:3r79euua]

    No se si voy encaminado.]0

    Antergos (Gnome)

  • Me refiero a que al cambiar el gestor (lightdm por gdm), obviamente, no podés ver el theme que la gente de Antergos hizo para sus inicios de sesión con lightdm (que aparece también cuando cerrás la sesión para cambiar de entorno de escritorio, por ejemplo). Es una tontería sin mayor importancia… ¡pero me gustan esos detallitos!

Posts 8Views 3559
Log in to reply