• Error python-pyqt5


    Hi

    I bumped on this one while trying to update python-pyqt5. As this error blocked all updates, I uninstalled python-pyqt5 and pulseaudio-equalizer which depended on it.

    I tried later to reinstall pulseaudio-equalizer, but the same error surfaces:

    [[email protected] ~]$ sudo pacman -S pulseaudio-equalizer
    [sudo] Mot de passe de roger : 
    résolution des dépendances…
    recherche des conflits entre paquets…
    
    Paquets (2) python-pyqt5-5.11.3-3  pulseaudio-equalizer-12.2-2
    
    Taille totale du téléchargement :   3,33 MiB
    Taille totale installée :        23,23 MiB
    
    :: Procéder à l’installation ? [O/n] O
    :: Récupération des paquets…
     python-pyqt5-5.11.3...     3,3 MiB  1135K/s 00:03 [######################] 100%
     pulseaudio-equalize...    29,9 KiB  2,24M/s 00:00 [######################] 100%
    (2/2) vérification des clés dans le trousseau      [######################] 100%
    (2/2) vérification de l’intégrité des paquets      [######################] 100%
    (2/2) chargement des fichiers des paquets          [######################] 100%
    (2/2) analyse des conflits entre fichiers          [######################] 100%
    erreur : la validation de la transaction a échoué (conflit de fichiers)
    python-pyqt5 : /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc est déjà présent dans le système de fichiers
    Des erreurs se sont produites, aucun paquet n’a été mis à jour.
    
    

    I do not understand the error message. Any advice on how to proceed?

  • @roger64 said in Error python-pyqt5:

    sudo pacman -S pulseaudio-equalizer

    please give the output of:
    LANG=C sudo pacman -S pulseaudio-equalizer

    so output will be in english

  • @roger64 said in Error python-pyqt5:

    /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc

    personal i think if you remove :

    sudo rm /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc
    

    And reinstall both packages again it will do fine,

    pacman -Qo /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc
    

    do show python-pyqt5 is the owner probably bad packaged ? or a sort of package split of python-pyqt5 … so some owner levels got mistaken i gues, its not on pulseaudio-equalizer its on that depency.

  • @ringo32 said in Error python-pyqt5:

    @roger64 said in Error python-pyqt5:

    /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc

    personal i think if you remove :

    sudo rm /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc
    

    And reinstall both packages again it will do fine,

    @ringo32

    I did exactly what you suggested and I could reinstall python-pyqt5 and pulseaudio-equalizer without any problem.

    Thank you very much for your help.

error320 python-pyqt51 Posts 4Views 106
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.