• Intel HD Graphics and Flickering Screen When Not Plugged in


    New to Linux in general and have been distro hopping for a bit. I recently installed Antergos with Deepin DE on my laptop and encountered strange behavior with the screen “flickering”, but only when the laptop is not plugged in. I have a short video of it I can upload if the description of the problem seems vague.

    Previously I have encountered this issue with other distros and it has been fixed in a number of ways -

    On Ubuntu I use Kernel parameter nomodeset and it screws up my screen resolution but otherwise fixes the flickering.

    On Manjaro XFCE I simply completely removed the xf86-video-intel package and this fixed it. It does nothing it seems here.

    I have also tried some other kernel parameters and none of these appear to fix it:
    I used:
    i915.enable_psr=0 This appears to do nothing Arch wiki suggested this
    nomodeset Appears to do nothing, and the combination of the proceeding two does nothing as well
    i915.enable_rc6=0 Also appears to do nothing

    I have also tried editing the Xorg config file to try and force the use of certain drivers, but each time nothing seems to change, so I’m unsure if I’m editing the right file or if it just doesn’t do anything for my problem.

    During my install of Antergos I elected to use the optional advanced power saving installation option. Could this causing an issue?

    I’m not sure what protocol dictates for how I share my system logs, I can’t find a way to upload a file and the logs are messed up by the forum posting so I don’t want to just copy and paste them. Here is the tar file on a google drive. If there is another way to share them let me know.

    Here is what hardware information I could grab

    `hwinfo --short

    pppoe.2: discovery
    cpu:
    Intel® Core™ m5-6Y54 CPU @ 1.10GHz, 1511 MHz
    Intel® Core™ m5-6Y54 CPU @ 1.10GHz, 1975 MHz
    Intel® Core™ m5-6Y54 CPU @ 1.10GHz, 1829 MHz
    Intel® Core™ m5-6Y54 CPU @ 1.10GHz, 1980 MHz
    keyboard:
    /dev/input/event3 AT Translated Set 2 keyboard
    mouse:
    /dev/input/mice ALP000F:00 044E:120C
    /dev/input/mice AlpsPS/2 ALPS GlidePoint
    monitor:
    LCD Monitor
    graphics card:
    Intel HD Graphics 515
    sound:
    Intel Sunrise Point-LP HD Audio
    storage:
    Intel Sunrise Point-LP SATA Controller [AHCI mode]
    network:
    wlp108s0 Intel Wireless 8260
    network interface:
    lo Loopback network interface
    wlp108s0 Ethernet network interface
    disk:
    /dev/sdb PNY USB 2.0 FD
    /dev/sda SanDisk SD7TN3Q-
    partition:
    /dev/sdb1 Partition
    /dev/sda1 Partition
    /dev/sda2 Partition
    /dev/sda3 Partition
    /dev/sda4 Partition
    usb controller:
    Intel DSL6540 USB 3.1 Controller [Alpine Ridge]
    Intel Sunrise Point-LP USB 3.0 xHCI Controller
    bios:
    BIOS
    bridge:
    Intel PCI bridge
    Intel ISA bridge
    Intel DSL6540 Thunderbolt 3 Bridge [Alpine Ridge 4C 2015]
    Intel DSL6540 Thunderbolt 3 Bridge [Alpine Ridge 4C 2015]
    Intel Skylake Host Bridge/DRAM Registers
    Intel DSL6540 Thunderbolt 3 Bridge [Alpine Ridge 4C 2015]
    Intel Sunrise Point-LP PCI Express Root Port #9
    Intel DSL6540 Thunderbolt 3 Bridge [Alpine Ridge 4C 2015]
    Intel DSL6540 Thunderbolt 3 Bridge [Alpine Ridge 4C 2015]
    hub:
    Linux Foundation 2.0 root hub
    Linux Foundation 3.0 root hub
    Linux Foundation 2.0 root hub
    Linux Foundation 3.0 root hub
    memory:
    Main Memory
    bluetooth:
    Intel Bluetooth Device
    unknown:
    FPU
    DMA controller
    PIC
    Keyboard controller
    PS/2 Controller
    Intel Sunrise Point-LP PMC
    Intel Skylake Processor Thermal Subsystem
    Intel Sunrise Point-LP CSME HECI #1
    Intel Sunrise Point-LP Serial IO I2C Controller #0
    Intel Sunrise Point-LP Thermal subsystem
    Intel Sunrise Point-LP SMBus
    Intel Sunrise Point-LP Serial IO I2C Controller #3
    Chicony Electronics HP HD Camera
    /dev/input/event10 Chicony Electronics HP IR Camera
    `

    This is a fresh install, nothing else has been done.

    Does anyone have any suggestions as to how I can fix this Enigma? My gut says some kind of power saving problem, but I would have no clue where to look or how to fix it. Thanks for any help offered.

    My kernel is 4.20.4-arch1-1-ARCH

  • Reinstalled without power manager and with i3wm and then flickering continued, regardless of plugged in status. Then I performed sudo pacman -R xf86-video-intel and the flickering has discontinued. I’m still looking to use deepin, so I’m going to reinstall again and see if just not using the advanced power manager option will help anything, or if its linked to the DE I selected. If the option of selecting the deepin DE during installation continues to cause problems it might be linked to that. Otherwise I’m going to install deepin after installing i3 from the regular OS install. Still wondering what is causing the issue however.

    Update: I reinstalled and selected deepin and no power saving installation option. I uninstalled xf86-video-intel and the flashing continues unabated, even while plugged in which it did not do before. Going to go back to i3 and try the power saving module installation option again.

  • Just out of curiousity, try installing Gnome or Budgie and see if the screen flickering is also present there, since those two DE’s are more related to Deepin.

  • Same issue here. Solved by sudo pacman -R xf86-video-intel . Thank you very much! This nightmare nearly took all of my spare times…

    Information:
    Kernel: 4.20.8-arch1-1-ARCH
    WM: i3
    CPU: Intel i5-8250U (8) @ 3.400GHz
    GPU: Intel UHD Graphics 620

intel42 graphics29 flickering8 plugged2 Posts 4Views 125
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.