• Trouble with Antergos Gnome After Installation

    Hi everyone!
    I am a new Antergos user and relatively new to gnu-linux OS. I have a the GL552VW Asus Rog Laptop with one 128GB SSD for Windows and a 1TB HDD for storage with a 200GB partition in which I installed Ubuntu (these two disks are stock).
    I recently replaced the optical disk drive with a caddy with 250GB SSD. My plan was to install Antergos in it, because Ubuntu is slow to load, due to it being in a 3400rpm HDD, and I wanted to switch to an Arch-based OS. The installer from the live-usb works great, but after the installation I noticed some problems with gnome. I don’t know if I’m doing something wrong during the installation, I chose GRUB as the default bootloader and selected it to be installed in this new SSD I got (I still chose the EFI system partition as the boot partition).
    Anyway, the first time after the installation (I had to tinker a bit with the nvidia drivers, but I don’t remember what I did exactly tbh) everything worked great, except when I found out that the pc froze when I tried to login when the laptop was on battery.
    I tried reinstalling it, this time with way less additional packages, and even though I could login both when on battery and while charging, the OS freezes as soon as I try to open any program, from chromium to settings etc.
    I don’t know what to do, please help.

  • give us logs: lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    copy paste to cli/terminal it will give you a link at the very end you can post here (pastebin of the loggs and specs)

    do you try to reach TTY (CLI based terminal login) by pressing [Ctrl+Alt+F2] ?

  • @BrachyKnight said in Trouble with Antergos Gnome After Installation:

    GL552VW Asus Rog

    You seem to have optimus graphics hardware with Intel HD graphics 530 and Nvidia GeForce GTX 960M.
    Which graphics drivers do you have installed now?
    The logs what @joekamprad asked for should reveal them too…

    Also the Display Manager may cause touble, which one do you have installed?

  • @joekamprad I tired the command you gave me, and the only output was: “ACPI Error: Method Parse/execution failed \SB.PCIO.PGON, AE_AML_LOOP_TIMEOUT (20181003/psparse-516)”
    The strange thing is that if I login from the default dm (lightdm) the pc freezes for every program I try to open, except for the terminal.
    I can reach TTY, but the output of the command is the same.

  • @manuel Right now I have the default lightdm installed, on the previous innstallation I tried to switch to gdm, but with it I cannot even login, after I enter the password it is stuck on the background of the login page.
    About the optimus hardware, I was aware of that, I tried bumblebee (both on Ubuntu and Antergos) but I couldn’t get it to work, so on Ubuntu I use the default nvidia drivers and I pass as kernel boot option vt.handoff=7 and i915.preliminary_hw_support=0 if I remember correctly.
    On a totally different note, I don’t know if this problems have something to do with the type of partition table I use, I created a live usb with the Antergos ISO using a gpt partition, and Installed on my samsung SSD using a gpt partition.

  • @BrachyKnight this is not any output of the command… looks more like error message splashing into cli from something else failing… do you have secure boot disabled, and efi-firmware set to uefi mode or to legacy boot mode?

  • @joekamprad I have secure boot disabled and have another option called “Launch CSM” (Compatibility Support Module, probably similar to legacy) disabled. I don’t know if I should turn one of the two on.

  • @BrachyKnight
    Joe is right, that output is not the command output but something else. Maybe there was a typo when copying the command?

    Usually with nvidia cards the easiest way to install drivers is using package & command nvidia-installer. Help is available with command

    nvidia-installer -h

    and a test what would be installed is

    nvidia-installer -t

    Actual installation is simply

    sudo nvidia-installer

    But one question: does your BIOS/firmware support disabling the Intel GPU? If so, then you could simply disable Intel and use the Nvidia GPU with the drivers installed with nvidia-installer.

  • @manuel Unfortunately, there’s no option for disabling one of the two in the bios, so I’ll have to do it in another way. I’ll try to see if I can make it work with the link you provided me (https://wiki.archlinux.org/index.php/NVIDIA_Optimus). I’ll keep you updated. Anyway, thanks for your patience and for all your advices!

  • @BrachyKnight
    There seems to be several attempts, like PRIME, xrun, optimus-manager, and bumblebee (AFAIK) to make hybrid graphics work. Choose the one that works for your machine. Arch wiki contains quite much info about them.

  • @joekamprad Sorry for the delay guys, I was busy so I couldn’t even use my pc. Anyway, I managed to make antergos to work, thanks to your advices! First I found out why lspci and other commands didn’t work (nvidia-installer -t didn’t work and showed the same error as lspci) because the nouveau drivers were making some troubles, so I used the kernel parameter modprobe.blacklist=nouveau to get around that. In the end I just installed the nvidia drivers with sudo nvidia-installer and right now it seems that everything works out of the box. The only thing that I still didn’t manage to fix is the bluetooth, but I may try a bit reading in the forum before posting here again. Thanks again for all your help!

gnome361 installation326 trouble20 Posts 14Views 204
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.