• pacman -Syu issue: cannot open the file.


    Hello everyone.

    When I try pacman -Syu i get this output:

    :: Sincronizando las bases de datos de los paquetes...
     antergos está actualizado
     core                                                                          135,0 KiB   634K/s 00:00 [##############################################################] 100%
     extra                                                                        1691,1 KiB   850K/s 00:02 [##############################################################] 100%
     community                                                                       4,8 MiB   692K/s 00:07 [##############################################################] 100%
     multilib                                                                      177,0 KiB   681K/s 00:00 [##############################################################] 100%
    :: Iniciando actualización completa del sistema...
    :: ¿Remplazar libmariadbclient con extra/mariadb-libs?  [S/n] 
    error: no se pudo abrir el archivo /var/lib/pacman/local/libsynctex-2018.48691-4/desc: No existe el fichero o el directorio
    resolviendo dependencias...
    buscando conflictos entre paquetes...
    advertencia: no se pudieron cargar completamente los metadatos para el paquete libsynctex-2018.48691-4
    error: no se pudo preparar la operación (paquete no válido o dañado)
    

    The issue is this:
    error: cannot open the file /var/lib/pacman/local/libsynctex-2018.48691-4/desc: file or directory does not exists.

    I have not idea what is happening.

    Thank you.

  • @roman-0
    You could try option --force:

    sudo pacman -Syu --force
    
  • @manuel said in pacman -Syu issue: cannot open the file.:

    @roman-0
    You could try option --force:

    sudo pacman -Syu --force
    

    I get the same output… Fail too :(

  • @roman-0
    Then maybe

    sudo pacman -Syyu
    

    without or with --force?

  • –force is dead , its removing things completly of that package or --overwrite, but have to test a proper way :) --overwrite confusing me general :)

  • @manuel said in pacman -Syu issue: cannot open the file.:

    @roman-0
    Then maybe

    sudo pacman -Syyu
    

    without or with --force?

    This not fix the problem :(

    Thank you anyway ;)

  • @roman-0 said in pacman -Syu issue: cannot open the file.:

    libsynctex

    try this

    sudo pacman -S libsynctex --overwrite *synctex*
    

    not with -Syu offcource always bad to do in combination with update parameter…

  • @all lot of pacman database corruptions lately…

  • it probably happends by installing trhough mirror probably somehow it breaks off or something happend in that kind it could installl it i dont know :)

  • @BlaiseD said in pacman -Syu issue: cannot open the file.:

    @roman-0 The fix I detailed in https://forum.antergos.com/topic/11283/issues-with-update-and-cups/3 should work for you too.

    Yes!!! That is. My problem was fixed. Thank you so much ;)

pacman122 syu10 file6 Posts 11Views 99
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.