• most icons in menu are gone

    Only for user uid 1000 nearly all icons are missing in plasma menu. At all other uids everything is fine. What I already tried:

    1. deleting user and home directory, created new, issue persists

    I have looked for any files/folders which do have uid 1000 or gid 1000 after deleting user: nothing exists.

    Interesting observation:
    Every new user which is created has theme “breeze dark” at first login - except uid 1000. This one has “breeze” (without “dark”). I can temporarily get icons by checking “use layout of design” at kde system config (I do not know exact naming in English because I use German language) but icons are gone at logout and login. Any idea is welcome!

  • You have saved your session ?

    find session management, try to start an empty sessio ?

  • If I remove user “1000” by deluser, delete home directory and create a new user “1000” it starts with an empty session. Home directory was empty at first start - when reaching plasma desktop everything works except icons in menu and in kde system config - no icons there…

  • and which icon theme does that user use ?

  • in kde you have a session manager you can start with an empty session its possible kde save a session, but , did you check which icon-theme kde uses currently?

  • It is without any effect what icon theme I activate. For all users with user id != 1000 all themes work out of the box and are stable. For user 1000 I can switch to any theme and there are no icons. I must activate checkbox “use layout of design” - then I get a warning that personal layout is overwritten - and the all icons are there. But only as long as the session lasts. If I shuttwown or restart icons are gone again - even after logoff and login they are gone. I have compared environment variables of user 1000 with other users - everything exactly identical. I can install new themes - they work for all users except user 1000.

  • dpo you use the standard display manager (lightdm) or sddm ?

  • ok i dont know realy could be a bug or what,

    what you can do is for now to compare for your current user and your new user which is member of,

    like in terminal :


    what is the difference, look in user-manager of your account which are the members are and that user 1000 … which is a new user probably mis some member ship… atleast dont give adm rights if not neeeded :)

    dont think 1000 should make a difference, but i think member ship of a group you comming close…

  • I use sddm - but nice idea, I can check with lightdm…

    I already have compared membership of groups - everything identical to other users. I have tested with other GUI (Gnome, LXDE) - the icons are on their place for all users including 1000.

    Because of I already

    • purged user 1000
    • deleted his home directory
    • deleted every file or folder which matches find # / -uid 1000
      For my view there are very few possibilities. I agree that it cannot be a problem of “number”. There must be one setting (e.g. in etc) which matches uid 1000 and survives all the procedures above. But how to find? I will start # grep -lr 1000 in /etc and possibly in /var

    I am nearly sure this is not a problem of Antergos at all - I never ever have seen that before. I am working 20 years with Linux now, first SuSE, from 1004 Ubuntu, from 2008 Debian and since 6 months Antergos and I am very happy with Antergos. Of course I can simply ignore that and start users at 1001 - but I always want to learn :)

  • Dont know why :) dont think is a DM i thought you was using kde and lightdm :)

    icons should not be user level depended.

  • I am a step forward! You are right: It was lightdm with webkit greeter. Switching to sddm gives all icons to user 1000. Switching back to lightdm let them vanish again. Switching to gtk greeter does not change anything: icons for user 1000 are vanished like at webkit greeter. So the issue is somewhere in the lightdm conf.

    Many thanks for pointing me in this direction - I will investigate and report what I have found.

  • atleast with sddm & plasma things works more integrated., my self using lxqt with sddm have also a sddm-config for it :)

  • Got it - but do not understand what is wrong. There is a bash script /etc/lightdm/Xsession which contains the following part:

    if ! [[ “${@}” =~ plasma|lxqt ]]; then
    # Fix ugly styles for Qt applications when running under GTK-based desktops and Qt 5.7+
    export QT_QPA_PLATFORMTHEME=‘qt5ct’

    If I comment this completely out everything is running fine - all icons there for usr 1000. But as I understand this part is only executed if session is NOT plasma or lxqt so it should not be executed when starting plasma…

  • @df8oe said in most icons in menu are gone:


    this should also stand in /etc/environment ? thats system overal atleast… ?also qt5ct should then installed …

  • community/qt5ct 0.37-1 is installed.
    QT_QPA_PLATFORMTHEME=‘qt5ct’ is not in /etc/environment.

    Strange. And very strange that it seems so I am the only one who struggles with this issue…

  • yeah thats weird indeed… hard to find what it is.

    i hope @developers read this too

  • pacman -Qo /etc/lightdm/Xsession
    /etc/lightdm/Xsession is owned by lightdm 1:1.28.0-1
  • I have tested if commenting out impacts gtk based desktops - but it does not. So I left it commented out and eyerything is working perfectly.

    Many thanks for your help and I feel very comfortable at this community forum for this was my first posting - hope I can help others when I gets more familar with Antergos and Arch.


  • @df8oe asking questions helps also a lot ;)
    welcome here!

    qt5ct should be used only in GTK Desktop Environments, to make themes fitting each other.
    It will cause problems if you change settings with it inside kde/plasma.

  • Yes - I already suggested that. So I am confused that commenting out has any effect for working with plasma. I am not perfect in shell scripts but as I understand the condition the code is only executed if desktop is NOT (plasma OR lxqt). It seems so that code is executed when plasma ist started - and that is not correct…

menu48 icons44 Posts 26Views 162
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.