• touchpad is not working


    Hello to all.
    I installed a fesh copy of antergos gnome 2019.1 on a laptop, after the install my touchpad is not working anymore, there is not any error, i installed 2018.12 on this very same machine some weeks ago, i delete it for distro hoping and i am coming back to antergos, all settings are the same as before, the hardware is working fine if i reboot in iive mode.
    this is the list-devices info:

    [[email protected] ~]$ sudo libinput list-devices

    Device: PixArt USB Optical Mouse
    Kernel: /dev/input/event11
    Group: 4
    Seat: seat0, default
    Capabilities: pointer
    Tap-to-click: n/a
    Tap-and-drag: n/a
    Tap drag lock: n/a
    Left-handed: disabled
    Nat.scrolling: disabled
    Middle emulation: disabled
    Calibration: n/a
    Scroll methods: button
    Click methods: none
    Disable-w-typing: n/a
    Accel profiles: flat *adaptive
    Rotation: n/a

    Device: Synaptics TM3127-001
    Kernel: /dev/input/event5
    Group: 8
    Seat: seat0, default
    Size: 108x42mm
    Capabilities: pointer gesture
    Tap-to-click: disabled
    Tap-and-drag: enabled
    Tap drag lock: disabled
    Left-handed: disabled
    Nat.scrolling: disabled
    Middle emulation: n/a
    Calibration: n/a
    Scroll methods: *two-finger edge
    Click methods: none
    Disable-w-typing: enabled
    Accel profiles: none
    Rotation: n/a

    kernel:
    [email protected] ~]$ uname -a
    Linux mike-ltop 4.20.3-arch1-1-ARCH #1 SMP PREEMPT Wed Jan 16 22:38:58 UTC 2019 x86_64 GNU/Linux

    What shoud i check to try to solve solve the problem?

  • @miguel-mirandag Try the LTS kernel if you are not using it already already.

  • in antergos i have not tried but manjaro. tumbleweed, fedora all works fine with 4.20
    to install linux-lts is enough or i have to run grub-mkconfig and all the manual configs?

  • i tried with kernel 4.19 lts to no avail :(, same result

    [[email protected] ~]$ uname -a
    Linux mike-ltop 4.19.17-1-lts #1 SMP Wed Jan 23 15:38:53 CET 2019 x86_64 GNU/Linux
    
  • I don’t know if this will help but I remember I manjaro I had to set my touchpad to basic in the BIOS. I know this question about antergos but can’t hurt to try.

  • i dont think it is a bios setting, i have installed all the popular distros and never had any problems with this config.
    xorg config file, gnome setting, installed libs etc all looks perfectly fine and are pristine configs as made by cnchi. I remember in arch kernel there was an ARCH word somewhere in the description. i don’t have any ARCH word in this installation. Do antergos devs make custom settings to default arch kernel? If so, it would be useless to post there (we all know the bad attitude of the motherf*****rs) and there is not any active post about touchpad. Has anything chaged from 4.18 to 4.19?

touchpad55 Posts 7Views 120
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.