• How to prevent packages/apps from being updated ?


    Hi guys !

    I’m looking for a way to prevent specific packages or apps from being updated when updates are pushed out to repos, even thoug I want to update the rest of the system. Coming from Ubuntu I could easily go in to i.e Synaptic Packagemanager and choose a specific file and “freeze” it so it doesn’t get updated.

    Couldn’t find anything in the Pacman settings but searching and googling I found this in the the archwiki: https://wiki.archlinux.org/index.php/Pacman
    Specifically the IgnorePkg=linux or IgnoreGroup=gnome commands.

    Is there a gui way to do it or am I stuck with thoose commands above ?

  • You could also do it in the settings of Pamac, but why would you like to do that? It’s not recommended to update Arch partially, this makes the chance for breaking the system bigger.

  • pamac will do it but the trick i learned is install downgrade do something like downgrade wine select the highest version which is not downgrading but re-installing the same version, then at the end downgrade will ask you if you want to add it to the ignore packages and say YES. it will add the exception to /etc/pacman.conf

  • it is not supported at all to partly upgrade archlinux systems!

    You can use ignore packages, but only for solving a tempoary issue, but not for keeping this for long term.

    But looks like typical zy-problem.
    So why you want to do so?

  • You also dont need to update right away… but make the gaps not to long once in a week just put off the update notifier :) look manual later if you feel to need to update…

  • Thnx for your for your respons and help, really appreciate it ! 👍 😍
    It’s not at corepackage or vital to the distro it self, so I really don’t see any reason as to why an update should break the system if hold back those packages.

  • @mraz if the package does not have any special dependencies then it will be o.k. and it is not something like a library… something else depending on ;)

  • @joekamprad said in How to prevent packages/apps from being updated ?:

    @mraz if the package does not have any special dependencies then it will be o.k. and it is not something like a library… something else depending on ;)

    Thnx, Joe, much appreciated. ☺

updated14 prevent7 packagesapps1 Posts 8Views 77
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.