• switched to new mainboard and now the OS does not boot


    Hello there,

    I just swapped/switched my hardware (new MB, CPU, RAM) and am no longer able to boot into antergos.

    The SSD with antergos is still the same, so I expected a smooth transition.

    Booting up I can see grub loading and antergos is shown in the grub menu. After choosing antergos the terminal stops with the following message:

    ERROR: resume: hibernation device ’UUID=...’ not found. 
    ERROR: device: 'UUID=...' not found.  Skipping fsck.
    mount: /new_root: cant find uuid...
    You are now being dropped into an emergency shell.
    sh: can't access TTY; job control turned off
    

    I did not hibernate before going to bed yesterday so I don’t have a clue what this is about.
    Hope this state is recoverable since I have no backup.

    Thanks in advance!

  • My new MB is a Asrock b450 pro 4.

    Could uefi be at fault here?

  • @Wandang looks like uuids have changed so you can boot from ISO chroot into system get new uuids and put then in place, in /etc/default/grub and /etc/fstab rebuilding grub.cfg and it should boot again.

    If new board have change from bios to uefi thus will need some more hacking

  • @joekamprad thanks for your help.

    ISO chroot requires a live distri system via USB right?

    I will need to find a tutorial for your steps because I never worked with chroot before .

    The old system was uefi as well afaik

  • @Wandang chroot is pretty easy, do the following (these are my drive/partitions - look in gparted for yours), NB. the 1st is root:

    mount /dev/sda3 /mnt
    mount /dev/sda2 /mnt/boot 
    mount /dev/sda1 /mnt/boot/efi 
    arch-chroot /mnt
    

    You’ll then be root for the drive you’ve mounted. When done type exit and you’ll return to the Live ISO CL.

  • @Wandang
    When you’re in the live iso, just open Chromium and go to the Antergos wiki, open the terminal and follow the instructions for chrooting on the site.

  • Sorry for the late reply guys.

    @robgriff444 said in switched to new mainboard and now the OS does not boot:

    @Wandang chroot is pretty easy, do the following (these are my drive/partitions - look in gparted for yours), NB. the 1st is root:

    mount /dev/sda3 /mnt
    mount /dev/sda2 /mnt/boot 
    mount /dev/sda1 /mnt/boot/efi 
    arch-chroot /mnt
    

    You’ll then be root for the drive you’ve mounted. When done type exit and you’ll return to the Live ISO CL.

    My setup is

    • sda1 boot
    • sda2 root
    • sda3 home
    • sda5 swap

    so I am wondering right now if I did not have uefi beforehand and how I can check that. (there is no mount point for efi in my gparted).

    As someone said, going from BIOS to UEFI would require more hackery, so I am still googling.

    https://itsfoss.com/check-uefi-or-bios/ -> its efi, but i didn’t have the mounting point. i guess i can just skip that and start reading the uuid values and editing the configs

    @joekamprad thanks for providing those direct references. much more concise than the arch wiki

  • @joekamprad said in switched to new mainboard and now the OS does not boot:

    @Wandang looks like uuids have changed so you can boot from ISO chroot into system get new uuids and put then in place, in /etc/default/grub and /etc/fstab rebuilding grub.cfg and it should boot again.

    /etc/default/grub does not have any uuid entries (only flags how the system should handle them) so I am leaving that file as it is and only change the fstab. after that i just regenerate grub via update-grub and i am good to go right?

    Dang I was too sloppy. Opened another terminal to copy paste those ids and the 2nd was not chroot on my system. Found the error fast enough and am modifying both (the default/grub should include the /boot uuid , right? it’s swap as stated in fstab)

    This step is not required at all? mkinitcpio -p linux

    Edit: getting errors from rebuilding grub file

    grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file ...
    Found theme: /boot/grub/themes/Antergos-Default/theme.txt
    Found Intel Microcode image
    Found linux image: /boot/vmlinuz-linux
    Found initrd image: /boot/initramfs-linux.img
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img
      WARNING: Failed to connect to lvmetad. Falling back to device scanning.
      WARNING: Device /dev/loop0 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda1 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda2 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda3 not initialized in udev database even after waiting 10000000 microseconds.
      /dev/sda4: open failed: No such device or address
      WARNING: Device /dev/sda5 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sdb not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sdb1 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/loop0 not initialized in udev database even after waiting 10000000 microseconds.
    

    Upon closer inspection I realized that the UUIDs never changed. The old and new values were identical.

  • sda1 boot
    sda2 root
    sda3 home
    sda5 swap

    No fat32 efi partition… so may a switch from legacy boot (boot as it was bios system before) and now efivenabled…
    You can check if there are such settings in your efi firmware?

  • You say:

    mount /dev/sda3 /mnt
    mount /dev/sda2 /mnt/boot 
    mount /dev/sda1 /mnt/boot/efi 
    arch-chroot /mnt
    
    

    You do mount / (root file system) as /mnt/boot ? thats wrong…

    As mounting /home as / is also wrong…

    sda1 boot = /mnt/boot
    sda2 root = /mnt
    sda3 home = /mnt/home (but no need to mount for arch-chroot)
    sda5 swap (no need to mount too)

  • @joekamprad said in switched to new mainboard and now the OS does not boot:

    You say:

    mount /dev/sda3 /mnt
    mount /dev/sda2 /mnt/boot 
    mount /dev/sda1 /mnt/boot/efi 
    arch-chroot /mnt
    
    

    You do mount / (root file system) as /mnt/boot ? thats wrong…

    As mounting /home as / is also wrong…

    that’s a quote from @robgriff444 not me.
    I have this:

    • sda1 /Boot
    • sda2 /
    • sda3 /home
    • sda5 swap

    So I did:

    sudo mount /dev/sda2 /mnt
    sudo mount /dev/sda1 /mnt/boot
    arch-chroot /mnt
    

    which is mounting root and then boot

    Edit: Taken from here

    The easiest way to find out if you are running UEFI or BIOS is to look for a folder /sys/firmware/efi. The folder will be missing if your system is using BIOS.

    I have this folder

    [[email protected] /]# ls /sys/firmware/efi/
    config_table  efivars  esrt  fw_platform_size  fw_vendor  runtime  runtime-map  systab
    
  • Oh sorry i do posting from smartphone so little screen …

    But you do not have a fat32 efi partition at all… what do indicating that you do have legacy bios boir enabled before, or was setting up a dualboot with a second hd holding windows…

  • @joekamprad No worries joe!

    I edited my last post where the uefi claim came from.

    I tried to install antergos as a dual boot the first time I tried antergos, but it was not working (you helped me back then as well). In the end I just installed antergos alone and let it format and repartition iself (auto mode).

    Looking back at that thread it seems like I was never able to start the uefi version of the usb boot medium so I assume it was a bios installation after all.

    Maybe I will just do a dirty backup (media data, etc) and reinstall this time with uefi? Or is there a better way to switch to uefi? (It does not need to be uefi though. If I can force the mainboard to accept bios that’s fine as well).

    edit: I am going to try to create new uuids with gparted when its not mounted (otherwise gparted does not allow to create a new uuid)

    edit2: gparted warns me of potential data loss… I will start a dirty backup while I search for a suitable solution to my initial problem in the meantime :(

  • @Wandang
    A quick tip, didn’t read carefully what you said… ;)

    Try using LABELs instead of UUIDs in files /etc/fstab and /boot/grub/grub.cfg.
    You may use gparted to create LABELs for the partitions.

    Then in chroot run

    grub-mkconfig -o /boot/grub/grub.cfg
    
  • @manuel

    so basically it will look like this?

    my etc/default/grub will change from
    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=myNumber"
    to
    GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=LABEL=SWAP"
    ?

    and fstab would change from

    UUID=myNumber1 /boot ext4 defaults,noatime,discard 0 0
    UUID=myNumber2 / ext4 defaults,noatime,discard 0 1
    ...
    

    to

    LABEL=EFI /boot ext4 defaults,noatime,discard 0 0
    LABEL=SYSTEM / ext4 defaults,noatime,discard 0 1
    LABEL=DATA /home ext4 defaults,noatime,discard 0 0
    LABEL=SWAP swap swap defaults 0 0
    

    ?

    The EFI label would change to BIOS in case it is not EFI?

    Edit: To compare the LABELS I added Screenshot from 2019-01-24 21-29-47.png this screenshot. So it would be AntergosBoot, AntergosRoot, and so on

  • @Wandang backup personal data is a good idea ;)

    you can do easily from Live-ISO boot to an external drive or so…

    It will be a more clean way to backup and do a new installation, and if new board is working with efi i would take it as efi system and do not change to legacy boot…

  • @manuel said in switched to new mainboard and now the OS does not boot:

    @Wandang
    A quick tip, didn’t read carefully what you said… ;)

    Try using LABELs instead of UUIDs in files /etc/fstab and /boot/grub/grub.cfg.
    You may use gparted to create LABELs for the partitions.

    Then in chroot run

    grub-mkconfig -o /boot/grub/grub.cfg
    

    still getting the same error

    grub-mkconfig -o /boot/grub/grub.cfg
    Generating grub configuration file ...
    Found theme: /boot/grub/themes/Antergos-Default/theme.txt
    Found Intel Microcode image
    Found linux image: /boot/vmlinuz-linux
    Found initrd image: /boot/initramfs-linux.img
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img
      WARNING: Failed to connect to lvmetad. Falling back to device scanning.
      WARNING: Device /dev/loop0 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda1 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda2 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda3 not initialized in udev database even after waiting 10000000 microseconds.
      /dev/sda4: open failed: No such device or address
      WARNING: Device /dev/sda5 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sdb not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sdb1 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/loop0 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda1 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda2 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda3 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sda5 not initialized in udev database even after waiting 10000000 microseconds.
      WARNING: Device /dev/sdb1 not initialized in udev database even after waiting 10000000 microseconds.
    Found memtest86+ image: /boot/memtest86+/memtest.bin
    done
    
    
    

    This seems to be a recent bug (december 2018).

  • @Wandang if system boots in efi mode it will not work as you try at all… you will need to set efi-firmware to boot in legacy (BIOS) mode!

  • @joekamprad yeah, I will check for a flag in my mainboard firmware. But even if that is possible I am still concerned about the error ridden grub config generation.

    Thank you guys for your amazing patience!

    Edit: the only thing I could find was CSM(compatibility support module) which was already enabled by default.

    Furthermore 'Launch PXE OpROM Policy ’ and 'Launch Storage OpROM Policy ’ are both set to ‘legacy only’ per default

boot321 hdd13 Posts 29Views 366
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.