• Antergos with KDE Plasma on VirtualBox freezing


    Hi all,

    I’m running Antergos with KDE Plasma on a VirtualBox Machine. For a long time now the machine keeps freezing irregularly. I can move the mouse pointer around but I cannot click anything. The upgrade of VirtualBox from v5 to v6 didn’t help.
    I cannot tell what causes the freeze. With journalctl I see this error:

    qt.qpa.xcb: QXcbConnection: XCB error:

    very often but it seems to be common:

    https://forum.manjaro.org/t/kde-plasma-related-error-messages-in-journal/21790

    and not the culprit.

    Any ideas?

  • how much ram is installed hardwaresided?

  • @joekamprad : 32GB memory on the main system, 10 GB is assigned to the Antergos VM.

  • @anergos I’ve just installed it on a plain VB (latest available) with no guest additions and it works fine: I can open menu, start dolphin, type to find konsole and start it.

  • @robgriff444 : Yes, but like I wrote before, it happens at irregular intervals. Maybe almost once a day. This is annoying because I’m doing serious stuff on it and every time it happens I have to reboot the VM which also means I might loose unsaved data.

  • @anergos you can debug it by serving logs from a period the freeze happen:

    journalctl --since "10 minutes ago" | curl -F [email protected] https://ptpb.pw/?u=1
    

    this will output a link to created Pastebin of the logs.

  • @anergos said in Antergos with KDE Plasma on VirtualBox freezing:

    it happens at irregular intervals

    Sorry, I missed that (brain froze?) …

  • @joekamprad: I put the log on pastebin.com:

    https://pastebin.com/Yc6CUHmZ

    The freeze occurred here:
    Jan 20 15:05:42 antergos-sd plasmashell[672]: qt.qpa.xcb: QXcbConnection: XCB error: 2 (BadValue), sequence: 13324, resource id: 75497509, major code: 142 (Unknown), minor code: 3

    Then I started a tty:
    Jan 20 15:08:23 antergos-sd systemd[1]: Started Getty on tty2.

    And finally I did a reboot:
    Jan 20 15:16:59 antergos-sd systemd-journald[205]: Journal stopped
    – Reboot –
    Jan 20 15:20:15 antergos-sd kernel: Linux version 4.19.12-arch1-1-ARCH ([email protected]) (gcc version 8.2.1 20181127 (GCC)) #1 SMP PREEMPT Fri Dec 21 13:56:54 UTC 2018

    These errors:
    qt.qpa.xcb: QXcbConnection: XCB error
    appeared already in the morning at 08:42 as I powered on the VM and many times until the VM finally freezed at 15:05.

  • @anergos
    Do you have all the latest virtualbox related packages installed? And the same versions on host and guest?
    In the guest, check packages virtualbox-guest-utils virtualbox-guest-dkms.
    In the host, check packages virtualbox, virtualbox-host-dkms, virtualbox-ext-oracle (from AUR) and optionally virtualbox-guest-iso.

    In the guest, user should be in group vboxsf.
    In the host, user should be in group vboxusers.

  • @manuel
    Host:

    $ aurman -Q | grep virtualbox
    virtualbox 6.0.2-1
    virtualbox-ext-oracle 6.0.2-1
    virtualbox-host-dkms 6.0.2-1
    
    $ groups myuser
    wheel users vboxusers myuser
    

    Guest:

    $ aurman -Q | grep virtualbox                           
    virtualbox-guest-dkms 6.0.2-1
    virtualbox-guest-utils 6.0.2-1
    
    $ groups myuser                                         
    wheel vboxsf myuser
    
  • @anergos
    An unrelated thing: aurman is no more supported, recommended changing to e.g. yay.
    https://wiki.archlinux.org/index.php/AUR_helpers

    Then, could you show the output of commands

    pacman -Qm
    lspci -vnn
    

    on the host?

  • @manuel

    Thanks for the tip! Yes I know but it still works. yay is also installed in any case.

    $ lspci -vnn
    

    Output:
    https://pastebin.com/mYqBue4E

    And

    $ pacman -Qm
    

    Output:
    https://pastebin.com/5BjiQy5w

  • @anergos
    How did you install the nvidia graphics driver? Did you use the nvidia-installer app?

    Also, you have installed quite a lot of AUR packages. That can sometimes cause e.g. stability issues. But it may be problematic to remove them, so is it possible to reinstall and not use so many AUR packages? As you know, AUR packages are not officially supported.

    If total reinstall is not possible, then can you make a new install to another partition (and not use AUR packages)?

  • @manuel

    I use the nvidia-dkms package on the host (Arch).

    But now I’m confused. You asked about the output of pacman -Qm and lspci -vnn on the host (Arch) not the guest (Antergos), or not?

    The host (Arch) although it has so many AUR packages runs without any issues. The guest (Antergos) has far less packages.

  • @anergos
    Didn’t realize your host is Arch. I was just thinking that some AUR packages on the host might bring some incompatibility to cause the issue.

    I searched the net and didn’t find much about this problem. It may be a Virtualbox or Qt issue. But the references I found on the net did not have a solution.

    BTW, I’m running Antergos Xfce in Virtualbox a lot and have no such freezing issues. Would you like to test Antergos with Xfce in a VM in your environment? If that work OK then it would seem to be a KDE issue. However, I’m not a KDE user and have only limited experience with it.

  • @manuel

    Yes, when I find some time I’ll try either i3 or Xfce. Thanks!

kde205 plasma46 virtualbox46 freezing15 Posts 17Views 151
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.