• Can't boot ISO 19.1 [SOLVED]

    I’ve been using Antergos for over 3 years. I like it a lot … :))
    Now I bought a new computer, a Chinese mini computer (I7 CPU, 8GB ram, SSD), and I would like to reinstall the system from scratch. I downloaded the Live ISO 19.1, I transferred to the USB stick according to the the tips of the wiki (with the dd command and with Etcher), I did it using different sticks of different brands (Lexar, Transcend, Sundisk…), but it can never complete the Live boot.
    When the graphical interface of the initial menu disappears, the error always arrives:
    losetup: /run/archiso/bootmnt/arch/root-image.sfs: failed to set up loop device.
    Mounting ‘’ to '/ run / archiso / sfs / root-image
    Waiting 30 seconds for device …
    ERROR: ‘’ device did not show up after 30 seconds …
    Falling back to interactive prompt "
    And of course the boot stops.
    I tried countless times changing ISO support (I also used a DVD). I used USB2 and USB3 ports.
    I tried also with the Minimal ISO, I changed with F5 all the types of kernels available … Nothing! :(
    I tried the media on another mini PC not recent (Sapphire Edge) and the story is the same.
    Instead the same ISO USB stick can be used on another 10-year-old laptop (Acer Aspire 8930G).
    In this case , the system is normally charged, but sometimes, when it comes to the login, it stops.
    On the other computers instead always it fails.
    Is there any remedy or should I leave Antergos ?
    It seems to me a problem of how the Antergos ISO was implemented.
    By the way, any other Linux ISO is loaded without problems, Arch too.
    Thanks to answers and advices.

  • @xginsa Did you choose the CD/DVD option in the EFI menu? The USB option is known to fail on some systems.

  • @robgriff444 The CD/DVD is not internal but is connected via USB, so there is no option in the initial menu.
    On the laptop with the internal CD/DVD the option is instead present and it works.
    But 3 years ago I did not have all these problems when I installed it for the first time, not at least in the start-up phase and I booted the Live on Sapphire Edge, while now it does not work anymore.
    Only 2 of my 4 computers can start ISO.
    It can be said that this is a distribution for the lucky few … and it does not seem a small problem for a software distribution. Perhaps you need to specify well what hardware architecture and components you must have to run the installation properly.

  • @xginsa said in Can't boot ISO 19.1:

    It can be said that this is a distribution for the lucky few … and it does not seem a small problem for a software distribution. Perhaps you need to specify well what hardware architecture and components you must have to run the installation properly.

    from your point of view it may look like this, but I do not see that only a lucky few are able to boot the ISO, and as Antergos is a little little little Distro there is not a big lab in the background to test on all different systems, we need the users itself to provide issues and problems with logs and specs to get issues solved.

  • @xginsa Did you understand me correctly? I mean after you boot the ISO on the USB, you THEN choose CD/DVD from the list (instead of USB), this solves many boot problems and we have requested the devs fix this.

  • @joekamprad What you say is very clear and is a shared point of view. Mine was just a joke about the statistics of my situation: 50% of my computers can’t boot the live. I hope to be particularly unlucky, but with a distro that has difficulty installing the efforts of the few who work there (I say to them: thank you very much, anyway !) should perhaps address to solve in some way this basic and old problem to increase the “success” and the audience that the Linux distro deserves.
    Said without any polemical intention, if I were able I would give a hand, but when I was handling operating systems it was a century ago … ;))

  • @robgriff444 I hope I understand. But If I boot the ISO from USB port - on USB is connected an external DVD, because there isn’t an internal one - in the main menu don’t appear the CD/DVD option. So I think it is right that the ISO transferred on DVD behaves like the one written on USB stick for that computer.
    If the ISO is booted on internal DVD reader (as in a laptop) that option becomes instead available in the main menu and if I select it the boot properly starts.
    This is my experience on my computers. I don’t know other way to select external DVD. Am I wrong?
    The strange thing is that the system signals that it fails to set up loop device for root-image.sfs and then it tries to mount " " device that will never find !
    Thank you for your advice.

  • @xginsa @robgriff444 is not talking about booting ISO from a DVD he wants to say that if you boot from ISO-USB device you should try to choose the DVD option on boot screen, as on some system this is the only way to boot from USB device.

  • @joekamprad @robgriff444 I got the point … we were talking about 2 different menu.
    When I boot from USB the character menu:

    • Antergos Live system (cd / dvd)
    • Antergos LIve system (usb)
    • Antergos (not graphical Fallback)
    • and so on …
      does NOT appears to me.
      It immediately jump to the graphic logo of Antergos and after it appears the system configuration menu in which I choose the language, the keyboard, the screen resolution, the kernel.
      So I don’t see the CD/DVD mode, which is in the previous menu, and I can’t choose it.
      The menu where I can choose CD/DVD comes out only on a fairly recent laptop (ASUS X554L) and it appears with input of both DVD media and USB sticks.
      On the other old ACER laptop in both cases I get immediately to the system configuration menu, but on this computer the boot continues successfully.
      It seems to me that the behavior of the boot process (and the available menus) is too dependent on the hardware on which it operates.
      I wonder if there is any parameter in the BIOS that can affect it, but it seems very strange to me.
      What can I check ?
      I’m afraid I will not able not install Antergos on the new mini computer. ☹
  • @xginsa Maybe your new chinese PC isn’t set to UEFI? I’ve only seen the menu options ignored on legacy systems. And that would be set in the ‘BIOS’ and will be kinda specific to your MBD model (each one has a different menu structure and language).

  • @xginsa said in Can't boot ISO 19.1:

    Antergos Live system (cd / dvd)

    Bildschirmfoto vom 2019-01-20 19-29-38.png
    This will only show up on efi systems yes…

    Bildschirmfoto vom 2019-01-20 19-32-02.png
    this is the boot menu for Bios // legacy Systems

    May you change EFI-Firmware-Bios to boot in EFI mode (may it is set to legacy BIOS mode)

  • @joekamprad @robgriff444 This is certainly the thing to investigate …
    I will try to understand how the BIOS is set up.
    The computer came with an Ubuntu on board and I seem to have seen initially that UEFI was disabled.
    However, if the ISO behaves so differently in the two cases, this is certainly the cause of my difficulty.
    After wasting your time, I hope that what I have now discovered is reported in some wiki or instructions to install Antergos that I have not found and read.
    Thank you.

    By the way… I don’t know how modify this post as SOLVED, I put it in title.

  • @xginsa
    you should give us more details about the machine where you are trying to install Antergos. Otherwise we do not have much to work on.

    Some pointers:

    • The EFI vs. BIOS legacy difference is very important. You may be able to select at boot time in the firmware/BIOS how your machine is set to boot. So check your BIOS at boot time (maybe press F2 or other function keys to get to the BIOS). New machines should use EFI boot, and old machines use BIOS legacy boot. Some machines support both.
    • If you can make it to boot with EFI support, then make sure the Secure Boot is disabled.
    • You may need to try other USB ports, sometimes certain USB ports do not work properly.
  • @manuel Thank you. I understood that this is the problem solution as joekamprad and robgriff444 said.

boot321 iso83 19.13 Posts 14Views 434
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.