• Error 28 No space left on device while installing

    So every time I try to install Antergos I always get the same error right at the end : Error 28 No space left on device even though there is enough space. Is it a problem with cnchi?

  • I’ve tried with Deepin and Gnome and some other ones, none working.

  • Could you tell us how much space you’ve got and how your drive is partitoned?

  • About 900gb for / and 20gb for swap.

  • Are you trying to install a dual or singleboot?
    Why so much swap by the way?

  • I’ve got nothing on this HDD, I have windows installed on a different SSD. I though that was maybe the problem that the swap was not enough idk.

  • The maximum swap you need is the size of your RAM. The 900 GB, which format is it?

  • It is FAT32

  • Ah, that’s the problem, Linux can’t be installed on FAT 32. The best thing to do is to go to gparted on the Live iso, wipe the entire disk and format it into ext4. Then let Cnchi do the rest, I do recommend to choose the option with a seperate home folder, in that case if something goes wrong in the future and you do have to do a reinstall or install another distro, your photos, movies and docs won’t get lost.

  • @beswaax
    Format using Gparted, let install by default with gnome once you have the functional system see if you can put deepin, the same error happened to me so I left deepin, and so I managed to install normally

  • I got the same results yesterday, when I tried to install Antergos Deepin. I made a full install whiping the disc.

    The first try I had a lot of extras checked in, so I reduced them the second try, and kept them to a minum the third time.

    I don’t know what did the trick, besides “third time’s, the charm”, but it worked finally.

error340 device29 space8 left8 Posts 13Views 365
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.