• Black screen after booting with Linux 4.20


    Hi everyone,

    I am new to Antergos and Linux and this is my first post. I would like to ask for suggestions related to problems I am having with the new Linux kernel 4.20.

    Everything worked fine with 4.19. However, after updating to 4.20, I am booting into a black screen. I have this problems with all versions of 4.20, including the last one (4.20.2-arch1-1-ARCH).

    After downgrading with chroot to my the last working version (4.19.8) everything is back to normal.

    I cannot try anything after booting with 4.20 because the screen is black except for a few dots along a line about 1/4 from the top of the screen. I have a HP PC with Intel i7-2600 and nvidia GeForce 405.

    After downgrading and rebooting I looked today in the logs. It seems that the problem is with nouveau. The “important” log (read from the gnome logs) shows:

    04:45:31 kernel: nouveau 0000:01:00.0: fb: trapped write at 010174e560 on channel -1 [3fed0000 unknown] engine 06 [BAR] client 04 [PFIFO_WRITE] subclient 01 [IN] reason 00000002 [PAGE_NOT_PRESENT]
    04:45:33 systemd-coredum: Process 598 (Xorg) of user 0 dumped core.
    04:46:35 kernel: nouveau 0000:01:00.0: DRM: base-1: timeout

    These lines are not present after booting with kernel 4.19.

    Anyone has these kind of problems with Intel CPUs? I read about problems with AMD but not Intel CPUs. Any suggestions?

  • I recommend to install the LTS kernel first, this is version 4.19.15 and is much more up to date than the version you’re using.
    Then after installing reinstall the newest kernel and try it with the nvidia drivers by installing nvidia-installer. After installing that, just type the following command:

    sudo nvidia-installer
    

    reboot and see if the newest kernel will run. I’ve tried the nouveau driver also earlier this month and the result wasn’t a smooth one. To be honest I didn’t bother to look into it further, since the nvidia driver gave me perfect results.

  • @Bryanpwo: thank you for the reply.

    if i use “nvidia-installer” to install the nvidia drivers, how do I uninstall them in case they do not work? Isn’t it better to use the graphical pacman tool to install the nvidia drivers?

  • You can use pamac, but if you don’t know which nvidia driver you’ll need, then nvidia-installer would be easier. It gets the correct nvidia driver. In your case it is important to install the LTS kernel first and then reinstall the newest kernel, before installing the nvidia drivers. Your kernel is an outdated one, so to avoid problems do it in that particular order.
    If the nvidia driver doesn’t work, you can uninstall it by

    sudo nvidia-installer -n
    

    In that case you’ll revert back to nouveau.

  • @new2antrgs
    The nvidia-installer can be used for testing the correct driver to install:

    nvidia-installer -t
    

    It gives details of all packages it would install. Would you like to show here the results of this command?

  • @manuel
    These are the results of nvidia-installer for my case:

    HP ~]$ nvidia-installer -t
    2019-01-18 03:47:49 [INFO]: Antergos Nvidia Installer v1.17
    2019-01-18 03:47:49 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
    2019-01-18 03:47:49 [INFO]: Running the installer in testing mode…
    2019-01-18 03:47:49 [INFO]: Installing nvidia-340xx driver…
    2019-01-18 03:47:49 [INFO]: Removing conflicting packages…
    2019-01-18 03:47:49 [INFO]: pacman -Rs --noconfirm --noprogressbar --nodeps xf86-video-nouveau
    2019-01-18 03:47:49 [INFO]: Downloading and installing driver packages, please wait…
    2019-01-18 03:47:49 [INFO]: pacman -Sqy --noconfirm --noprogressbar nvidia-340xx libvdpau lib32-nvidia-340xx-utils lib32-libvdpau
    2019-01-18 03:47:49 [INFO]: Creating /etc/X11/xorg.conf.d/20-nvidia.conf file…
    2019-01-18 03:47:49 [INFO]: Installation finished. Nothing has been modified as testing mode was ON.
    [HP ~]$ sudo nvidia-installer
    2019-01-18 04:04:00 [INFO]: Antergos Nvidia Installer v1.17
    2019-01-18 04:04:00 [INFO]: All logs will be stored in /tmp/nvidia-installer.log
    2019-01-18 04:04:00 [INFO]: Installing nvidia-340xx driver…
    2019-01-18 04:04:00 [INFO]: Removing conflicting packages…
    2019-01-18 04:04:00 [INFO]: Downloading and installing driver packages, please wait…
    2019-01-18 04:04:37 [INFO]: Unpatching /usr/share/applications/nvidia-settings.desktop…
    2019-01-18 04:04:37 [INFO]: Creating /etc/X11/xorg.conf.d/20-nvidia.conf file…
    2019-01-18 04:04:37 [INFO]: Installation finished. You need to reboot now!

    Finally I succeeded to make linux 4.20 work after installing nvidia drivers!

    @Bryanpwo

    I did not install linux-lts as that would have needed the lts-package of nvidia and I was not (yet!) interested to switch to the lts-version.

    However, what happened with so many people when upgrading Linux (and also happened in the past as everyone can google it) raises major questions about adopting Linux as a desktop. For example, a similar bug was filed 2 weeks ago in arch (https://bugs.archlinux.org/task/61230), never solved, and still tagged as “unconfirmed”. If one googles problems with nouveau similar to what I experienced happened in the past quite often. Many people switched to the lts-version after they experienced similar problems. It seems that there are major qualities problems not addressed by the developers of the Linux kernel!

    I have another question about the nvidia drivers. I noticed that nvidia-installer automatically installed the package “lib32-nvidia-340xx-utils” although another similar package (“nvidia-340xx-utils”) is needed for “nvidia-340xx”-drivers. Does anyone knows if the 32-bit package is really needed for 64-bit systems?

    And a final question, this time about the webpage of this forum: I cannot post in this forum from the newest Firefox I use with antergos. Hitting reply does nothing; also a message comes that I lost connection at the top of the page. Does anyone know why this happens and how to repair it? It has something with the Firefox settings but I do not know the exact cause.

  • @new2antrgs
    Glad to hear that the nvidia drivers worked.
    I only recommended the LTS kernel, because I wasn’t sure if you would encounter problems within the older 4.19 kernel version you were rolling with, if you’d install the nvidia drivers.

    The problems that are addressed concerning the kernel, are Linux (as in Linus Torvalds team) related, so Arch or any other distro can’t solve that problem. Having said that, most problems are also hardware related, sometimes hardware is too new, but often hardware is getting older to run smoothly on the newest kernel. That’s the reason why a lot of users switch to the LTS kernel. It will get resolved in time, especially if the concerning kernel is going to be a LTS candidate. This is also the reason why distro’s like Debian and Ubuntu aren’t using the latest kernel by default, Arch is using the latest software and therefore hick-ups and problems are lurking just around the corner after each update, we’re the testing audience so to say.

    My Nvidia machine is around the same age as yours, I also have a small laptop with an old Radeon (AMD) card with the same age as the first one and a one and a half year old Thinkpad with integrated Intel graphics.
    Needless to say that Linux runs smoother on the Thinkpad, but considering their age the older machines (Nvidia machine hits its tenth birthday this April and the Radeon laptop has just hit its twelfth birthday) those machines are still running strong with Linux. To be fair, editing videos and heavy gaming is out of the question for those, but daily duties like streaming videos, banking, light photo editing and office work are running very smooth. If you run Windows or Mac on such machines, you can forget smoothness or even a working website for your bank or webshop. I always keep that in the back of my mind when a problem occurs, until now they always came along with every new kernel or point releases sometimes with alterations, but on those machines I also have the LTS kernel installed as a system to fall back on. So in my opinion Linux isn’t really that hard to adopt as a desktop environment.

    For your Firefox problem, you better start a new thread on this one, it’s easier to find and other members can anticipate better on the problem. I replied this with Firefox, so I don’t know exactly what is going on, it could be the forum software (it has some issues) and not Firefox related at all.

  • @new2antrgs
    I do agree with @Bryanpwo on installing also the LTS kernel. Since Antergos is using the latest available kernels, there sometimes are bugs in a kernel just because it is so new and not tested in every possible hardware environment before release. Then the option to switch to another kernel (even temporarily) is a great thing to have.

  • @Bryanpwo & @manuel

    I can only agree with you that it is good to have a backup solution - you recommend linux-lts - in cases such as it happened to me. As I mentioned, I use chroot with the installation usb-stick to repair the system. In addition I can dual boot windows 7.

    As far as I understood having the lts-kernel installed is not unlike a dual boot, because many packages have two versions - one for main-, one for lts-kernel (nvidia for example). That is, you will have two linux systems sharing your hard drive. Question: do the two kernels share some of the installed packages? Can you estimate roughly the percentage they share?

  • If the system can’t be repaired for the time being, reverting back and holding back updates isn’t the wisest thing to do. Falling back on the LTS kernel, keeps you running with a system that’s up to date and picks your system up, there where you’ve left it, thanks to the acces to the home folder.
    You do have a point that I’m running two kernel systems on my machine and I can’t tell you what percentage each kernel reserves on my system, but it’s not that much as running two seperate operating systems on your machine. The core packages between the kernels differ, but you don’t need a LTS version of Firefox, Libreoffice and so on, unlike the case when you’re running two different operating systems next to each other.
    Don’t get me wrong, I’m not judging you for keeping Windows 7 and there must be some apps you may still need or love , I’m just proving my point with this.

  • @new2antrgs said in Black screen after booting with Linux 4.20:

    do the two kernels share some of the installed packages

    there are only some packages/modules needed to build against the kernel… most packages are shared between both kernels.

    under /boot you have the initrd (12MB) and vmlinuz (6MB) images from both …

    This will be not like two installed OS as it mostly only loads a different image at boot…

  • These commands should tell how many packages in all require different kernels:

    pacman -Qq | grep "\-lts" | wc -l
    pacman -Qq | wc -l
    
  • @joekamprad
    What about settings? Wouldn’t the settings for the two linux kernels interfere with each other?

    Thank you to all of you for the quick and helpful replies. I have two further question in this topic. I have also - with the problems I had - thought of installing the lts-version and, while we are at it, I would like to ask you how to do it, just for future reference. So, you install the lts-kernel. Will after that automatically appear a menu in grub to choose the version when booting? And are further steps needed to install the lts-kernel?

    I would also like to ask you about your preferred solution for backing up your system, but I will open a new topic for this subject.

  • @new2antrgs both kernels are only different versions of the same thing.
    Drivers from each one are under different folders, so that the right one is choosen depending on the kernel you are taking to boot.
    Most drivers will be provided from kernel itself, only kernelmodules like properitary ones from nvidia or some not inside the kernel will need the exact kernel version to get loaded.

black82 booting55 4.202 Posts 14Views 601
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.