• Poor Gaming performance with AMD R5 M430


    I’m using steam on Antergos 19.1 and getting poor gaming performance with respect to Windows 10. I’m trying to run “Team Fortress 2”, “Counter Strike - Global Offensive” and I noticed poor fps, hiccups on 1280x720 resolution with all graphics settings set low. My machine has a hybrid GPU combo of integrated Intel HD 520 and dedicated AMD R5 M430 (GEN-1 architecture) and I don’t know how to install proprietary AMD drivers on antergos. Really new into this, any help will be appreciated.

  • @j4ckfr0st AMD don’t do proprietary drivers they’re in the kernel now so you have the best already. I’m no expert on AMD (I’ve got an Nvidia 1050Ti) so I would look at Phoronix and Gaming on Linux websites to see what I could learn about this card and what to expect.
    Also take a look on the Arch wiki for any settings required for your games; eg: https://wiki.archlinux.org/index.php/Steam/Troubleshooting

  • @j4ckfr0st

    Sounds like your games are defaulting to the Intel graphics instead of the AMD. You can check this by running:

    $xrandr --listproviders
    

    It should show you an output saying there’s two, and most likely lists the Intel graphics as primary. You can configure X to use the AMD graphics entirely, but that’ll probably kill your battery life. Instead, if you add “DRI_PRIME=1” before the launch command, it’ll offload to the AMD for that app while keeping the rest of the system running on the Intel. (I use it for my eGPU setup on my laptop, works perfectly).

    Those are all Steam applications - if you edit the Steam launcher to use a custom launch command, it would look like this:

    DRI_PRIME=1 %command%
    

    And no, I wouldn’t bother installing the proprietary drivers. That card is well supported by the amdgpu opensource driver.

    https://wiki.archlinux.org/index.php/PRIME

amd36 performance11 gaming7 poor3 Posts 4Views 108
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.