• Fail to boot (black screen) after updates


    Hello,

    I have been using Antergos on my laptop for about a year.

    Yesterday I tried to update packages after having neglected to do so for several weeks . The package manager found some incompatibilities so I disabled all “community” packages, then those from “extra” and finally “multilib” as the problem persisted. So in the end I had only the core packages, and then only did the package manager agreed to proceed.

    Once the update ended, I got an unusual message telling me that the number of packages was not matching (I don’t remember the exact content of the message, it said something like “25 packages instead of 21”)

    I then proceeded to reboot but after the boot option menu, I get an empty black screen. I tried brutally turning off the computer and turning it back on, but that has seemingly no effect. In the boot menu, I tried all four options I have: “Antergos”; “Antergos - Fallback”, “Antergos - Linux LTS Kernel” and “Antergos - Linux LTS Kernel - Fallback”, but all lead to the same black screen.

    I can open the GRUB commandline, but that’s about it and I have no idea about to use it.

    Do you have any idea about what actions I could take to solve the problem?

    Best regards,
    Alexis

  • @theirongiant
    Generally, it is not a good idea to prevent official updates, at least without a compelling reason. And even if there temporarily would be a reason to prevent some particular update, usually it is better to wait, and update the system after the issue/reason is resolved.

    First, make a backup of anything important, like your data files. This puts you on the safe side, since anything can go wrong now that your system is not fully working.

    One thing you could do is to reinstall all packages. Before doing this, be sure to enable all updates in file /etc/pacman.conf or pamac, whichever you use.

    Reinstalling can be done e.g. like this:

    sudo pacman -S $(pacman -Qqn)
    

    If that gives errors, you might want to add the --force option.

  • Hi, thanks for your reply.
    I thought that only core package updates were absolutely necessary, good to know that this is not true.

    I am not sure to understand how to follow your advice because the only commandline I have access to is the GRUB one, so I don’t have the pacman command.

  • @theirongiant
    The backup probably is important for you? You can do that after booting with the USB installer stick, since it has all the required tools. Hopefully you have the “full” ISO burned to the stick, not the “minimal”.

    And after that I’d suggest a reinstall, since that is usually way faster than trying to solve all those little problems with correct packages, versions and dependecies.
    Of course, provided that your internet connection is relatively fast.

  • @manuel Thanks a lot. I will try this as soon as I can and let you know how it went.

  • @manuel said in Fail to boot (black screen) after updates:

    @theirongiant
    The backup probably is important for you?

    Good call, I thought there was a way to access a regular terminal somehow, and wanted to do the backup from there.

    That might be a silly question, but are there chances that my file system is already damaged? Or that I will damage it by booting from USB?

  • @theirongiant booting live iso is save, and filesystem should be o.k.

  • @theirongiant also possible to rescue installed system:

    https://antergos.com/wiki/miscellaneous/rescue-non-booting-antergos-from-arch-chroot/

    But better do backup your personal files to external HD before all actions.

  • Hi all, a little follow up as I managed to solve my problem.

    Actually, the black screen I was on did allow me to reach a terminal by pressing Ctrl+Alt+F4. From there I was able to backup my files to an external harddrive and then run sudo pacman -Syyuu
    This revealed that the package cups-pk-helper-0.2.6-2 had only been partially written to /var/lib/pacman/local/cups-pk-helper-0.2.6-2.
    So I copied the files from another computer and updated again (sudo pacman -Syyuu), which run smoothly with just a few warnings, finally a reboot gave me access to the graphical interface as usual.

    Thank you very much for your help!

boot311 update57 black screen11 Posts 9Views 176
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.