• Grub won't boot to 2nd Antergos drive

    I have added on old WD80GB HDD to my machine and installed Antergos KDE on it. I’m using it for a backup device and I want to be able to boot from it from my main device’s grub menu.

    The problem is after running

    grub-mkconfig -o /boot/grub/grub.cfg

    it finds the 2nd instance ok & it shows the entry in grub but selecting it just goes to a blank screen. I’ve seen it have a kernel panic too.

    I know that efi nvram is a pain so I’ve made sure I re-installed grub to each drive (after booting from live usb and chrooting etc) with

    grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Antergos-grub

    and they both boot from the efi boot menu ok.

    Does anyone know what is happening?
    BTW I installed lsb-release coz os-prober was taking ages.

  • @robgriff444 said in Grub won't boot to 2nd Antergos drive:

    so I’ve made sure I re-installed grub to each drive

    What were you trying to do with this?

    To have the grub install info in the one efi directory in the machine, you need to mount that common efi partition to e.g. /boot/efi while installing. That should create necessary info into the one efi partition.
    So you don’t want to create an efi partition to each disk, but use only one efi partition on one disk, e.g. on /dev/sdaX but not on /dev/sdbY (here X and Y are partition numbers).

    BTW, you might want to try this app: https://forum.antergos.com/topic/9188/create-boot-grub-custom-cfg-grub-assistant
    The app, antergos-customcfg, should find all installations on the machine and write new menu entries into file /boot/grub/custom.cfg. This file is then used at boot time, and you can use those new menu entries.

    So run it once, reboot, and use the new menu entries.

  • @manuel
    I am running a 2nd HDD with a partclone backup of my main drive saved on it. It is a full Antergos KDE which I can boot to from time to time (& update) to create a new partclone. This is obviously more efficient and faster than a Live USB (and I had a drive spare!).

    Are you saying I can’t do what I’m trying to? It worked 1st time around, I’ve redone things probably 4 times due to efi messing the boot order so it’s obviously flakey.

    EFI works on both of them independently, and I reinstalled it correctly as per https://antergos.com/wiki/miscellaneous/how-to-fix-grub-with-efi-boot/
    So how is EFI to blame? Grub loads on SDD1 then points to grub on HDD1. Does it in fact point to EFI on HDD1? and that’s where it fails?

  • Thanks, how do I install antergos-customcfg?

  • @robgriff444

    Not quite sure how you use your disks and what are the contents of them, could you please detail the usage?

    For antergos-customcfg, best way to install is:

    cd ~/Downloads
    wget https://github.com/manuel-192/antergos-customcfg/raw/master/PKGBUILD
    makepkg -sic
  • @robgriff444
    If antergos-customcfg does not help with booting, you could show the contents of files /boot/grub/grub.cfg and /boot/grub/custom.cfg here.

    Use e.g. pastebin and show the returned URLs here.

  • @manuel Thank-you very much, I don’t know why (nor do I really care) but your 🎩antergos-customcfg created an entry to the 2nd drive which worked so I’m all set up now 😎

  • @robgriff444
    Great that it works!

    I think the multiple EFI folders have mixed up grub, especially if/when they have very similar info about installations.

    But this solution should work for you in the future, too, since it (i.e. file /boot/grub/custom.cfg) is never overwritten by any system updates.

    And if you feel this thread is solved, can you mark it as such? :)

  • @manuel Yeah I think so too but I couldn’t find any way of digging any deeper so your program was a real ‘find’.
    (Already marked solved)

boot321 grub127 2nd4 Posts 9Views 117
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.