• Login loop problem after updating today...


    Hello everyone…

    After doing a Sudo pacman -Syu

    I am also stuck in the login loop…

    I turn my computer on and it boots to the login screen, I type in the password and the screen then fades to black (as normal) and appears to be logging in to the desktop… Then instead of the desktop, the login screen comes back ☹.
    The only way I was able to get to the desktop today was by doing a ctrl-alt-f2 and then starting kde manually.

    I have not done anything since the last time I was on my computer except the system upgrade.

    Has anyone been able to figure this out yet? I’m using kde plasma 5 as is everyone else I think this has been happening to…

    Matt

    edit: here is my journalctl -b log: https://ptpb.pw/uBn1

  • coredump:

    Jan 15 16:43:16 _hostname_ systemd-coredump[1342]: Process 1335 (kglobalaccel5) of user 1000 dumped core.
                                                           
                                                           Stack trace of thread 1335:
                                                           #0  0x00007f7fda0ead7f raise (libc.so.6)
                                                           #1  0x00007f7fda0d5672 abort (libc.so.6)
                                                           #2  0x00007f7fda48c7fc _ZNK14QMessageLogger5fatalEPKcz (libQt5Core.so.5)
                                                           #3  0x00007f7fdaa4e01a _ZN22QGuiApplicationPrivate25createPlatformIntegrationEv (libQt5Gui.so.5)
                                                           #4  0x00007f7fdaa4e4ce _ZN22QGuiApplicationPrivate21createEventDispatcherEv (libQt5Gui.so.5)
                                                           #5  0x00007f7fda689705 _ZN23QCoreApplicationPrivate4initEv (libQt5Core.so.5)
                                                           #6  0x00007f7fdaa4fc50 _ZN22QGuiApplicationPrivate4initEv (libQt5Gui.so.5)
                                                           #7  0x00007f7fdaa50868 _ZN15QGuiApplicationC1ERiPPci (libQt5Gui.so.5)
                                                           #8  0x000055f622ae3087 n/a (kglobalaccel5)
                                                           #9  0x00007f7fda0d7223 __libc_start_main (libc.so.6)
                                                           #10 0x000055f622ae33fe n/a (kglobalaccel5)
    
    ---
    
    
    Jan 15 17:33:14 _hostname_ baloo_file_extractor[7138]: This process needs a QCoreApplication instance in order to use KCrash
    Jan 15 17:33:15 _hostname_ baloo_file_extractor[7138]: Qt: Session management error: Could not open network socket
    Jan 15 17:33:16 _hostname_ baloo_file_extractor[7512]: QCoreApplication::arguments: Please instantiate the QApplication object first
    Jan 15 17:33:16 _hostname_ baloo_file_extractor[7512]: QCoreApplication::applicationDirPath: Please instantiate the QApplication object first
    Jan 15 17:33:16 _hostname_ baloo_file_extractor[7512]: This process needs a QCoreApplication instance in order to use KCrash
    Jan 15 17:33:17 _hostname_ baloo_file_extractor[7512]: Qt: Session management error: Could not open network socket
    

    lightdm do not show that it is failing… but after lightdm kde/plasma is not giving any interesting outputs to journal (on o shart view)

    I would try changing lightdm to sddm:

    https://antergos.com/wiki/de/desktops/installing-display-managers/

  • @TaraF // grep | flatpak

    Jan 15 16:29:35 _hostname_ polkitd[508]: Registered Authentication Agent for unix-process:849:56572 (system bus name :1.76 [flatpak --installations], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
    
  • I solved this issue this morning.
    By using a virtual terminal and logging in you can check ~/.xsession-errors.
    Mine had errors dealing with flatpak. (I don’t have the error message, because I solved this this morning.)
    updating flatpak was the solution for me.

  • This post is deleted!
login135 updating31 loop10 today8 Posts 6Views 290
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.