• Invalid or corrupted package (PGP signature)

    Hey guys,

    I haven’t updated my packages for a while now and accumulated about 200 package updates. Today I tried to update them with pacman -Syu, but it failed with the error message in the title. It asks me if the package should be removed, but the udpate process fails regardless if I choose yes or no.
    I did a lot of googling and tried different solutions, but none of them worked.
    I tried refreshing the pacman keys and reinstalling the archlinux-keyring and antergos-keyring packages a few times. I also tried pacman -Scc and then refreshing keys. I also tried pacman-key populate archlinux antergos. None of it resolved my problem and I am still unable to update.

    This is the error message I get:

    Fehler: cabextract: key "Alad Wenter <[email protected]>" is disabled
    :: Datei /var/cache/pacman/pkg/cabextract-1.9-1-x86_64.pkg.tar.xz ist beschädigt (Ungültiges oder beschädigtes Paket (PGP-Signatur)).
    Soll die Datei entfernt werden? [J/n] j
    Fehler: Konnte den Vorgang nicht durchführen (Ungültiges oder beschädigtes Paket)
    Fehler sind aufgetreten, keine Pakete wurden aktualisiert.

    It says something like the following:

    File /var/cache/pacman/pkg/cabextract-1.9-1-x86_64.pkg.tar.xz is damaged (invalid or corrupt package (PGP signature)).
    Remove the file? [y/n] y
    Error: Could not execute process (invalid or damaged package)
    Errors occured, no packages updated.

    I tried removing cabextract manually, but it’s a dependency of Wine and PlayOnLinux and I want to avoid removing those.

    Does somebody know how I can fix this?
    Thank you in advance.

  • have you already tried ;

    sudo pacman-key --populate archlinux antergos
    sudo pacman-key --refresh-keys

    or try to install archlinux-keyring ?

  • @ringo32 Yes, I tried both. Populating finished without any errors or warnings. Refreshing the keys also completed normally. But it sadly didn’t fix my issue.
    This is part of the output:

    gpg: key 6BC26A17B9B7018A: 10 duplicate signatures removed
    gpg: key 6BC26A17B9B7018A: 10 Beglaubigungen wegen fehlender Schlüssel nicht geprüft
    gpg: key 6BC26A17B9B7018A: 10 signatures reordered
    gpg: Schlüssel 6BC26A17B9B7018A: "Alad Wenter <[email protected]>" nicht geändert

    It says the key was not changed.

    archlinux-keyring is also installed:

    [[email protected] ~]$ sudo pacman -Q archlinux-keyring
    archlinux-keyring 20181218-1
  • @joekamprad

    question for you ?

    Can do like this also work as :

    sudo pacman-key -r 6BC26A17B9B7018A
    sudo pacman-key --lsign-key 6BC26A17B9B7018A

    or is that strange? :)

  • @joekamprad I followed the instructions in your link and edited my pacman.conf and now it works! I don’t really get why but I’m happy as long as it works. Thank you! :)

    Also thank you @ringo32.

  • @Lari0L edit of pacman.conf should be reverted after updating the system.

signature24 pgp24 invalid19 corrupted13 Posts 7Views 2514
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.