• Installation failure - error creating metalink

    Hello. I’m trying to install version 19.1 and cnchi fails with these errors. Full log on pastebin. This same thing happened to me on a different machine and I eventually got it to work just by retrying a few times. What causes this? I think the package name is irrelevant, because it fails on a different package each time.

    2019-01-11 01:41:57 [DEBUG  ] ALPM repository database order is: ['core', 'extra', 'community', 'multilib']  (pac.py:100)
    2019-01-11 01:41:57 [ERROR  ] Cannot sync Antergos repository database!  (metalink.py:322)
    2019-01-11 01:41:57 [ERROR  ] Cannot load antergos repository database  (metalink.py:409)
    2019-01-11 01:41:57 [ERROR  ] Unable to create download queue for package wpa_actiond  (metalink.py:125)
    2019-01-11 01:41:57 [ERROR  ] Error creating metalink for package wpa_actiond. Installation will stop  (download.py:178)
    2019-01-11 01:41:57 [ERROR  ] 'Error creating metalink for package wpa_actiond. Installation will stop'  (process.py:185)
    2019-01-11 01:41:57 [ERROR  ] Traceback (most recent call last):  (process.py:190)
    2019-01-11 01:41:57 [ERROR  ]   File "/usr/share/cnchi/src/installation/process.py", line 145, in run
        self.create_metalinks_list()  (process.py:190)
    2019-01-11 01:41:57 [ERROR  ]   File "/usr/share/cnchi/src/installation/process.py", line 91, in create_metalinks_list
        self.down.create_metalinks_list()  (process.py:190)
    2019-01-11 01:41:57 [ERROR  ]   File "/usr/share/cnchi/src/misc/extra.py", line 194, in helper
        return func(*args, **kwargs)  (process.py:190)
    2019-01-11 01:41:57 [ERROR  ]   File "/usr/share/cnchi/src/download/download.py", line 181, in create_metalinks_list
        raise misc.InstallError(txt)  (process.py:190)
    2019-01-11 01:41:57 [ERROR  ] misc.extra.InstallError: 'Error creating metalink for package wpa_actiond. Installation will stop'  (process.py:190)


  • @llamafilm I can confirm this too on try to install XFCE …

  • I tried following karasu’s instructions here to choose the mirrors, but it fails. I discovered this file is empty. How should I fix this?

  • @judd ok so remirror is replacing reflector. Cool. But isn’t this just for ranking the mirrors which the system already knows about? Is this supposed to be necessary for a new install? I’m not terribly concerned with finding the fastest mirror possible, I just want it to work.
    In this case, my mirrors file is empty. I copied the contents from Github and that seems to have fixed it.

  • Solved ??2019-01-11-161108_787x117_scrot.png

  • @judd Sure, we can call it solved. Although I don’t understand why this file was empty in the first place.

  • @llamafilm as far as I know the file will be added by cnchi now.

    after ranking there is antergos-mirrorlist created:

    [[email protected] ~]$ cat /etc/pacman.d/antergos-mirrorlist 
    # antergos mirrorlist generated by cnchi #
    Server = https://mirror.alpix.eu/antergos/$repo/$arch
    Server = https://mirrors.nic.cz/antergos/$repo/$arch
    Server = https://mirror.umd.edu/antergos/$repo/$arch
  • today install is back as working again without this error!

error338 installation324 failure16 creating9 Posts 9Views 424
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.