• LiveUSB 'cow_spacesize=' to Increase Available Storage


    Hello Antergos forums. I recently got a new laptop which is vastly superior to my old one, which I can now use to test and eventually install a better OS than I had before. I want to really try Antergos on the LiveUSB but it gives me fewer than 200MB of storage. 200MB is awfully small and I can’t really install anything more than basic packages and thus I can’t use Antergos’ LiveUSB for the same amount of testing as other OSes.

    I tried using the Arch kernel parameter ‘cow_spacesize=XG
    but it did not work. Is there an equivalent for Antergos that I am unaware of? Is there another method to increase the amount of storage available on the LiveUSB? As I’m adding tags to this question I see that ‘cowspacesize’ without the underscore is something that others have used. Is that the way to increase the amount of storage available on the LiveUSB?

    I really want to try out Antergos before deciding on which distro will become my primary os on this new laptop so any info you can pass on to me would be extremely helpful! Thanks a lot!

  • I’ve never tried this but I just googled ‘Arch cowspacesize’ and in the 1st one that suggested what you’ve already done, it said you could do this manually so you’ll be able to see errors in the terminal:

    mount -o remount,size=1G /run/archiso/cowspace
    

    (obviously change archiso if necessary)

    from https://www.ostechnix.com/adjust-size-root-partition-live-arch-linux/

  • Your link also shows the ‘cow_spacesize’ with the underscore ‘_’ so I’ll give the other parameter a shot as well as trying cowspacesize without the _ as well. I’ll let the rest of the forums know what I find out. Thanks, @robgriff444!

    Alrighty, after testing both methods, cowspacesize without the underscore does not work. The ‘mount…’ command does! Happy testing everybody else!

liveusb7 storage5 live-usb5 cowspacesize2 Posts 3Views 72
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.