• Unable to boot after update, fresh install doesn't boot either

    At first I ran into this problem after running updates. Figuring this was just another case of some default solutions being changed, I then did a reinstall, but the problem persists. After GRUB tries to boot linux, it shows the following messages:

    Starting version 240
    ERROR: device 'UUID=3e992dc0-80c1-40b5-af96-d5cb68c4e44f' not found.  Skipping fsck.
    mount: /new_root: can't find UUID=3e992dc0-80c1-40b5-af96-d5cb68c4e44f.
    You are now being dropped into an emergency shell.
    sh: can't access tty; job control turned off
    [rootfs ]# 

    I’ve tried live-booting and chroot-ing to run pacman-Syu and mkinitcpio -P and grub-mkconfig and still same problem.
    I’ve tried changing the system from UEFI to Legacy, new MSDOS partition table, and reinstalling, same problem.
    With and without swap, fresh install each time, same problem.
    With and without dedicated home drive, fresh install each time, same problem.
    This system (a Lenovo Thinkstation P510 desktop) was working as of yesterday (2019-1-8), ran updates yesterday, booted up this morning and now nothing on it works … thoughts?

  • @mandibleman Mine is fine so it’s maybe something particular with your machine? I would start by getting the downgrade package (pacman -S downgrade) and rolling back systemd (which was updated to 240 yesterday).

  • @robgriff444 downgrading systemd to version 239 did it!
    Looks like version 240 may be having some issues, according the bug reports:

  • yeah yesterday someone on IRC had it also, he tried a ton of stuf later he mailed he seemed to fixed it, but i dont kow whas a weird fix, he replaces udev hybernation one thing else to systemd, is weird, probably that is not a fix, common issue was he also used efi system could not find root while uuid is correct…

  • Same issue here, as soon as I upgrade systemd to version 240 the system (Antergos with KDE Plasma on VMWare Workstation Pro 15.02) fails to boot. As a workaround I’ve added systemd to the list of ignored packages for upgrades.

  • Today I upgraded all systemd related packages and the system still boots. So I guess the issue with systemd 240 has been fixed.

boot321 unable76 fresh43 Posts 7Views 354
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.