• Pixelated screen after booting from grub but before lightdm


    Hi all,
    Long time no posting!
    Anyway, I updated Antergos and did a reboot as linux and headers were upgraded and now I cant get to the login screen following grub. It shows very pixelated text and black screen.
    I can get a terminal open (ctrl+alt+F2) but cannot make anything out due to how pixelated it is.
    My grub resolution and the screen just prior to trying to get into lightdm screen is fine so Im not sure if its a graphics issue.
    Any help appreciated and thank you in advance!

  • This does sound like a graphical issue. Can you give us your hardware specs and which Linux kernel are you using? (LTS kernel or not, nvidia, AMD or Intel graphics)

  • @Janxinz also looks like a long time not updated, as last kernel update was on 24.12.2018. ?

    lspci -v > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1 will create a systemspecs and bootlog pastebin and gives out a link to it, you can post here (also easy from CLI, as you need only to write down a short url)

  • Thanks for the feedback.
    The first thing I did before posting here was updating my system @joekamprad.

    Hardware specs:
    Processor: AMD Threadripper
    Graphics Card: Gigabyte GTX1080
    Ask for more as needed…

    Ill pastebin my systemspecs and bootlog when I get home from work (2 more hours).
    Thanks

  • So the issue is that the text is so fecked that I couldnt make out the url even if I wanted to (see attached photo).
    I did update the system again today and no change.
    Any suggestions for next steps? :)
    Thanks!

    https://imgur.com/a/2lG7PFw

  • @Janxinz said in Pixelated screen after booting from grub but before lightdm:

    Processor: AMD Threadripper

    Just in case, I could add to the kernel boot:

    amd_iommu=on
    
  • @judd Ill do my best to add lol.
    Thanks

  • if you are using grub, you can press e (for edit) on boot menu screen, and add kernel parameters

  • So I added in the amd_iommu=on via e on boot menu screen and initially it worked fine. Lightdm loaded and I was able to login. Then I figured this would be something I would need to add permanently so I edited the grub file in /etc/default/grub to include amd_iommu=on and rebooted. Now the same issue is occurring. When I edit the same file in the terminal after grub it seems like it writes out ok but when I hit ctrl+X (nano) it does not exit and Im not sure its writing out correctly. Any advice where to go from here?

  • @Janxinz said in Pixelated screen after booting from grub but before lightdm:

    When I edit the same file in the terminal after grub it seems like it writes out ok but when I hit ctrl+X (nano) it does not exit and Im not sure its writing out correctly.

    To edit and then close nano:

    Ctrl + O + Enter and to leave and close Crtl + X
    

    Do you do it that way ???

    Then to see if the file is edited correctly, and not to return to nano, you can do cat

    $ cat /etc/default/grub
    or any other file.

  • @Janxinz

    so I edited the grub file in /etc/default/grub to include amd_iommu=on and rebooted

    Did you run

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    before reboot?

    And into which variable you added the kernel parameter?

  • @judd I did do that in nano but the thing that happens is writing out (ctrl+O) executes okay but then ctrl+x to close makes the terminal freeze. Thus I have to hard reboot and when checking the file again either by opening it in nano or cat the content the change was not actually written out. Its very strange. Also keep in mind the the terminal I am using is pixelated like in the imgur link I attached to previous response so its hard to really make out what is happening. I know I am removing the amd line I added initially as I remember where I put it. I put it after the GRUB_CMDLINE_LINUX_DEFAULT line (line 3 or 4 in the /etc/default/grub file). When I first added the amd line when using e in the grub screen it was following the line starting with linux before the first if statement (if that helps), and thats when it initially worked.

    @manuel I ended up executing the wrong command. I will execute grub-mkconfig the next time I can successfully update the file.

    Thanks guys! Hopefully we can root out the issue.

  • @Janxinz you can also make use of arch-chroot:

    Boot up with our LiveIso.

    mount System to /mnt

    You need to know which device is the right one check with:

    sudo fdisk -l
    
    sudo su
    

    /dev/sdXn should be replaced with the right device information, and depending on your installation you may have or have not a seperate /boot partition. If not /boot is a folder under / on the same partition as the filesystem root.

    mount /dev/sdXn /mnt
    

    ( your “/” root partition)

    mount /dev/sdXn /mnt/boot
    

    (your /boot partition --> without extra /boot partition you do not need this step! )

    mount /dev/sdXn /mnt/boot/efi
    

    (your EFI-boot (fat32) partition {from dualboot windows maybe})

    arch-chroot /mnt
    

    More details about arch-chroot on the Arch wiki:

    Using_arch-chroot

  • I was able to get into my system by selecting LTS Kernal - Fallback from Grub advanced options menu. This allowed me to effectively remove the line from the /etc/default/grub file and address some non-related parcing issues. Now back to square one with the original issue but does knowing that LTS kernal fallback works help with anything?
    Thanks

  • ? if you can boot with LTS Kernel you can boot into system and add the kernel parameter permanent to /etc/default/grub and regenerate grub.cfg sudo grub-mkconfig -o /boot/grub/grub.cfg

  • Which line should I be adding this in? I tried putting it in after line 6 and it didnt work.

    https://imgur.com/a/re55Bqo

    Thanks for all the help guys!

  • Ah, I just noticed the last two lines at the bottom. Can you confirm if I need to uncomment that in order to get the amd_immou=on to work after line 6?

    Thanks

  • @Janxinz Straight after quiet on line 6

  • @robgriff444 Tried it and still cant boot normally

  • Do you mean it’s still pixelated? What’s the exact line you have that begins:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet
    

    and did you run

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    after?

lightdm137 grub127 booting56 pixelated1 Posts 35Views 399
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.