• ISO Refresh: antergos 19.1

    Notable Changes: Packages updated for the live and minimal install environments.

    Click here to see the full blog post

  • @lots-0-logs
    Thanks! Installation was OK, as usual.

    The only issue is the ~/.bashrc.aliases file, because it contains the following troublesome aliases:

    alias journalctl='sudo journalctl'
    alias systemctl='sudo systemctl'

    which causes problems when used with options (like --user) that assume a normal user. I suggest removing these two aliases.

  • …and /root’s directory is readable by everyone…

  • Yeah, root is the only user whose directory /root has world read rights…

  • @lots-0-logs
    I have the following grub boot menu entries in file /boot/grub/custom.cfg:

    menuentry 'Boot antergos-18.12-x86_64.iso' {
        set isofile=/ISO/antergos-18.12-x86_64.iso
        search --no-floppy --set=root --file $isofile
        probe -u $root --set=uuid
        loopback loop $isofile
        linux (loop)/arch/boot/vmlinuz img_dev=/dev/disk/by-uuid/$uuid img_loop=$isofile
        initrd (loop)/arch/boot/intel_ucode.img (loop)/arch/boot/archiso.img
    menuentry 'Boot antergos-19.1-x86_64.iso' {
        set isofile=/ISO/antergos-19.1-x86_64.iso
        search --no-floppy --set=root --file $isofile
        probe -u $root --set=uuid
        loopback loop $isofile
        linux (loop)/arch/boot/vmlinuz img_dev=/dev/disk/by-uuid/$uuid img_loop=$isofile
        initrd (loop)/arch/boot/intel_ucode.img (loop)/arch/boot/archiso.img

    Using the above entries, 19.1 does not boot, but 18.12 does. 19.1 says the file system is unknown and does not find the kernel to boot.
    I’ve had similar boot menuentries for quite a long time, but now 19.1 is the first not to boot with this.
    This is not a major issue for me, but merely an observation of a change.

    Has the ISO structure or contents changed somehow that could cause this?

  • @manuel It works for me with the next options:

        menuentry "Antergos Live ISO 19.1" {
            set isofile=/Software/linux/Antergos/antergos-19.1-x86_64.iso
            search --set --file $isofile         
            probe -l $root --set=volumelabel     
            set img_dev=/dev/disk/by-label/$volumelabel
            loopback loop $isofile
            linux (loop)/arch/boot/vmlinuz img_dev=$img_dev img_loop=$isofile 
            initrd (loop)/arch/boot/archiso.img
  • @folgui
    Thanks, I’ll try that!

  • Strange. I had the ISO files on an NTFS partition, and all except 19.1 worked.
    Then I copied all ISOs to and ext4 partition, and all of them worked.

    Really don’t understand why this happened. The menuentry was exactly the same for both filesystems.

    But this is no more an issue for me. Maybe my machine has something strange on NTFS, but I just don’t know what.
    The main thing is that the ISO is OK.

  • @manuel My ISO’s including Antergos 19.1 are on external usb drive with NTFS and all boot without problems. Strange 🤔

iso83 refresh29 19.13 Posts 9Views 622
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.