• Thunderbolt & Gnome

    Hi, folks,

    A recent update appears to have affected Gnome’s ability to work with Thunderbolt. Prior to an update that happened in the last 2 weeks or so, the Gnome control panel was able to detect & identify my Thunderbolt 3 hardware without problem, but now it shows that TBT is either undetected/unsupported or set incorrectly in BIOS. I haven’t made any changes to the BIOS configuration (it’s set to “Secure” mode, though in troubleshooting I tried “User” and “Legacy” options as well with no effect).

    I don’t know which update it is specifically, but the error was present before the 4.20 kernel came out, and I have updated to 4.20 with the error still present. I suspect it’s something to do with Gnome specifically, because /sys/bus/thunderbolt is still present & shows entries, boltd is still running, and usermode console commands tbtadm and boltctl do not throw errors when checking the status. (but if mods feel this belongs in Kernel/Hardware it can be moved there)

    Were the compile options changed on the package?

    Thanks in advance,

  • This can be marked as fixed. There was an update for the “bolt” package to 0.7.1 in today’s patches which appears to have resolved the issue - Gnome can now see Thunderbolt again. :)

  • Since GNOME 3.28 it supports integrated Thunderbolt 3 connections.

    Good to see it is working again for you, and as a mark that it is working at all for others ;)

    Please mark as solved:

    Please mark as solved:

gnome361 thunderbolt1 Posts 3Views 115
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.