• WiFi no longer working on freshly installed Antergos (BCM43142)


    WiFi no longer works on my Antergos. Usually what I do to get my WiFi working are:

    • Install linux-headers

    • Install broadcom-wl-dkms

    • Unload all modules and then do sudo modprobe wl. Reboot.

    I have followed the same method this time around but my WiFi is no longer working. It scans for the network and when I select a network, it tries very very hard to connect to it but in the end it doesn’t. Thankfully, Ethernet is working.

    Some info:

    [[email protected] ~]$ lspci -k
    00:00.0 Host bridge: Intel Corporation Broadwell-U Host Bridge -OPI (rev 09)
    	Subsystem: Dell Broadwell-U Host Bridge -OPI
    	Kernel driver in use: bdw_uncore
    00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
    	DeviceName:  Onboard IGD
    	Subsystem: Dell HD Graphics 5500
    	Kernel driver in use: i915
    	Kernel modules: i915
    00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
    	Subsystem: Dell Broadwell-U Audio Controller
    	Kernel driver in use: snd_hda_intel
    	Kernel modules: snd_hda_intel
    00:14.0 USB controller: Intel Corporation Wildcat Point-LP USB xHCI Controller (rev 03)
    	Subsystem: Dell Wildcat Point-LP USB xHCI Controller
    	Kernel driver in use: xhci_hcd
    	Kernel modules: xhci_pci
    00:16.0 Communication controller: Intel Corporation Wildcat Point-LP MEI Controller #1 (rev 03)
    	Subsystem: Dell Wildcat Point-LP MEI Controller
    	Kernel driver in use: mei_me
    	Kernel modules: mei_me
    00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
    	Subsystem: Dell Wildcat Point-LP High Definition Audio Controller
    	Kernel driver in use: snd_hda_intel
    	Kernel modules: snd_hda_intel
    00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3)
    	Kernel driver in use: pcieport
    00:1c.2 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #3 (rev e3)
    	Kernel driver in use: pcieport
    00:1c.3 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #4 (rev e3)
    	Kernel driver in use: pcieport
    00:1c.4 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #5 (rev e3)
    	Kernel driver in use: pcieport
    00:1d.0 USB controller: Intel Corporation Wildcat Point-LP USB EHCI Controller (rev 03)
    	Subsystem: Dell Wildcat Point-LP USB EHCI Controller
    	Kernel driver in use: ehci-pci
    	Kernel modules: ehci_pci
    00:1f.0 ISA bridge: Intel Corporation Wildcat Point-LP LPC Controller (rev 03)
    	Subsystem: Dell Wildcat Point-LP LPC Controller
    	Kernel driver in use: lpc_ich
    	Kernel modules: lpc_ich
    00:1f.2 SATA controller: Intel Corporation Wildcat Point-LP SATA Controller [AHCI Mode] (rev 03)
    	Subsystem: Dell Wildcat Point-LP SATA Controller [AHCI Mode]
    	Kernel driver in use: ahci
    	Kernel modules: ahci
    00:1f.3 SMBus: Intel Corporation Wildcat Point-LP SMBus Controller (rev 03)
    	Subsystem: Dell Wildcat Point-LP SMBus Controller
    	Kernel driver in use: i801_smbus
    	Kernel modules: i2c_i801
    06:00.0 Network controller: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)
    	Subsystem: Dell Wireless 1704 802.11n + BT 4.0
    	Kernel driver in use: wl
    	Kernel modules: bcma, wl
    07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)
    	Subsystem: Dell RTL810xE PCI Express Fast Ethernet controller
    	Kernel driver in use: r8169
    	Kernel modules: r8169
    08:00.0 3D controller: NVIDIA Corporation GK208BM [GeForce 920M] (rev a1)
    	Subsystem: Dell GK208BM [GeForce 920M]
    	Kernel driver in use: nouveau
    	Kernel modules: nouveau
    
    

    Under the Network controller part, I notice that kernel modules bcma and wl are loaded but only wl is being used. Is this extra bcma module causing the problem???

    [[email protected] ~]$ ip link
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    2: enp7s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
        link/ether 20:47:47:3e:ed:99 brd ff:ff:ff:ff:ff:ff
    3: wlp6s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DORMANT group default qlen 1000
        link/ether 18:4f:32:fc:1d:3d brd ff:ff:ff:ff:ff:ff
    

    I also have to mention that I have installed at least around 20 distros on my laptop (bare metal). I have partitioned the same HDD many times i.e.boot,swap,root many many times. Has this screwed my hardware somehow? I am afraid that I have fcked up my hardware because of distrohopping a lot.

    Please help. I don’t want to go back to Ubuntu.

    EDIT: I had installed ArchLabs yesterday before reinstalling Antergos. Even there I had faced the same WiFi problem. So it is not distro specific.

  • @Quantum_Sniper said in WiFi no longer working on freshly installed Antergos:

    BCM43142

    do you try LTS kernel?

    or the b43 driver? https://wiki.archlinux.org/index.php/Broadcom_wireless

    I do not think that distrohopping causes hardware to break.
    But i believe that Broadcom Wifi/BT hybrid chipsets are problematic.

    You can check also if Bluetooth is activated and usable.

  • @joekamprad Hi Joe, thanks for replying :)

    I am pretty sure that broadcom-wl-dkms is the only package for BCM43142. I have researched about this driver and this is the only package. I have used the same package without any problem for the last 3 months. Now with 4.20 Linux kernel there appears to be some problems.

    I checked the WiFi connectivity in LTS kernel. It takes a long time (around 3 minutes to get connected to the network). The probability of getting WiFi is more in LTS kernel for me right now.

    BTW, I have discovered a workaround for now. I just Disable WiFi and Disable Networking and then Enable Networking and Enable WiFi. When I do this, it automatically detects and connects to the WiFi. But it is not like how it was before. Before I could disconnect and connect to any network unlimited times but now it takes a lot of time.

  • https://aur.archlinux.org/packages/bcm43142-firmware/

    Now with 4.20 Linux kernel there appears to be some problems.

    The same thing happens here, with this new kernel there connection problems, at least for Broadcom

  • I have tried everything I possibly could. I have referred to this https://wiki.archlinux.org/index.php/Wireless_network_configuration. I am also facing the same issue with the 4.19 linux-lts kernel. So not sure whether it’s 4.20 kernel’s fault. I am just confused on why it’s not working correctly.

  • With 4.20 I connect faster than with 4.19

     Network controller [0280]: Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    
    

    Hopefully some update …

  • @judd Thanks @judd I will try now and let you know how it goes.

  • @judd It really helps to get connected to WiFi faster (less than 1 min). But that is after rebooting only. It only happens once (the first time). After disconnecting from the network and then trying to reconnect back, it’s the same story.

    BTW, the package is meant for Bluetooth connectivity. Hope this issue gets fixed quickly by the kernel team. I am waiting for the next kernel release now.

  • @Quantum_Sniper said in WiFi no longer working on freshly installed Antergos:

    Estoy esperando el próximo lanzamiento del kernel ahora.

    In that we are …

  • @Quantum_Sniper
    Have you looked at this: https://aur.archlinux.org/packages/bcm43142a0-firmware
    There are some ideas still, like updating your machine’s BIOS/Firmware. Not saying it will help but maybe worth a look.

    Also: https://wiki.archlinux.org/index.php/Broadcom_wireless#Interface_is_showing_but_not_allowing_connections may be worth a try.

  • @Quantum_Sniper

    My friend cim made a script on his machine that doe that work around stil nog figured how to make it stable… he made a script of nmcli but further i dont know…

  • @manuel Yes, I have currently installed the package you mentioned. There were two packages

    • bcm43142-firmware which wasn’t updated/maintained for a long time

    • bcm43142a0-firmware which had more more upvotes and looked more updated/trustworthy. Hence chose this one.

    I don’t want to mess with the system firmware or changing/tuning the kernel parameters because it’s pretty deep and I don’t have much idea about it.

  • @judd Yep, the latter is more recent the former.

  • @ringo32 It’s kinda reassuring to know that I am not the only one who is affected.

  • @Quantum_Sniper

    or changing/tuning the kernel parameters

    It is easy to test. At the Antergos boot menu, press E to edit the selected boot menu entry. Then with the arrow keys move cursor down several lines, to the line starting with ‘linux’ and ending with ‘rw quiet’. In the end of that line simply write a space character and this:

    b43.allhwsupport=1
    

    and boot with Ctrl-x. Now you can test if it works.

    This is a temporary change, it goes away after every reboot. If you want to test it through several reboots, you have to write the thing every time as above.

    If it works, it is easy to add permanently, but better just test it first.

  • @manuel

    I am sending heavy emails now, then I will test your code.
    (I have one more hour of shipping)

    Thank you !

  • @ringo32 said in WiFi no longer working on freshly installed Antergos (BCM43142):

    @Quantum_Sniper

    My friend cim made a script on his machine that doe that work around stil nog figured how to make it stable… he made a script of nmcli but further i dont know…

    Do you have the same Broadcom 43142 ??

  • he have a a macbook with that type of bcm cannot contact him…

    i thought the script looks like

    https://ubuntuforums.org/showthread.php?t=2393902

    but he has in dispatcher.d

    but he set something different i dont know got no feedback of him… he keep struggle with that issue also internet is full of same drop issue on that type…

wifi151 longer18 freshly2 Posts 36Views 746
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.