• Kernel Panic after upgrade, space issue


    I have a kernel panic “not syncing - Requested init failed (error-13)” after pacman upgrade. After the update, I were to fast, it said root has wrong permissions 750 not 755, also it said something about .INSTALL two times. What should I do now, I never had experience with a kernel panic before. I have a backup from two days before, though, so I could just revert.

  • Do know you which updates were performed? Maybe it’s easier to revert back to your backup and start looking at the updates, I know that the last two days, there weren’t really big and many updates for the core system, so it must be relatively easy to find the culprit.

  • still no luck, after chrooting and pacman -Suy same error. I also have a bios from 2015, but this shouldn’t be bad? I think the problem is with Linux 2.4.20 – however, this time the kernel panic message was different. After trying init= it was the same as before. Trying to downgrade linux and nvidia no luck.

    I found the culprit. Seems I am running out of space. However, I do not know where the problem is. I have only 51% used on root.

    “running ‘90-linux.hook’…
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: ‘default’
    -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
    /usr/lib/initcpio/functions: Row 692: printf: Write error: no space left on this device”

    I have mounted boot and it says only 10% used. It also does not seem to be a inode problem. However, I am not sure if df works as intendet on a encrypted disk.

    after downgrading nvidia, upgrading to linux 2.4.20 again and doing a “mkinitcpio -p linux” it boots again, yay. Thanks for your help!

  • this is solved, cannot find how to mark it.

  • @Popkultur it may uses /tmp (tmpfs) to build images?

    it is easy to get into your installed Antergos by using arch-chroot from a live-ISO session…

kernel152 upgrade81 panic10 Posts 8Views 166
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.