• Can Antergos startup as seamlessly as Solus?


    Hi there I’m a Solus user trialing Antergos as I wan’t to trial ZFS (to add SSD caching over some HDD’s)

    One thing that jumps out at me is it’s so slow to start up… Solus booting from SSD can be at the desktop by the time my TV turns on. With Antergos I’ve got the grub screen to get through (I assume I can configure this away?), a warning about no hibernation being setup (this seems to be a ZFS quirk from what the internet is telling me) some status checks then I get to login.

    My setup is for a Linux couch gaming rig / media server so I really want that (almost) as smooth as a console experience of turning my machine on and being in Steam Big Picture mode in seconds… Is this doable in Antergos? (To be fair I’ve done little more than install, boot up and set up ZFS pools… But thought I’d ask before I pour too much time into the setup)

  • IIRC the message regarding no hibernation setup is usually related to lack of a swap partition
    If you do not have one, then setting up a swap partition will make that go away.
    You will need to change /etc/fstab an add a line like
    UUID=xxxxxxxx-xxx-xxxx-xxxx-xxxxxxxxxxxxx swap swap defaults 0 0
    You can find the uuid using lsblk -f, you see a line like
    ├─sda5 swap xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx [SWAP]

    The default timeout for grub, is 5 seconds you can change it by changing the line
    GRUB_TIMEOUT=5
    in /etc/default/grub
    And then doing
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    I’d keep grub timeout as high as acceptable, IMO 0 can be inconvenient cause it means you cannot select another option in the event something goes wrong.

  • @jdoig systemd-analyze blame
    will show what is causing slow boot

  • @joekamprad Wow, thanks, really helpful to find the culprit.

    I have this bluetooth.service which is taking around 3.6s . How to disable it permanently? I don’t use bluetooth and I want to disable it.

  • @Quantum_Sniper I think you can just issue:

    sudo systemctl disable bluetooth.service

  • @inffy okay, I did it and I have screwed my WiFi now. This is not to say that you suggested the wrong thing. But I had no idea that bluetooth.service was related to the WiFi. I have rebooted the system and still the WiFi is not working.

    Even ethernet is not working. This has never happened before.

    Wow, what a way to begin 2019. I am 45 mins into 2019 and a problem to solve now 😂😂

  • you can enable it back to with sudo systemctl enable bluetooth.service

    then do sudo systemctl start bluetooth.service

    It might be because usually those resign in the same actual chip, but I never knew that disabling one thing could bork another one.

startup27 solus1 seemlesly1 Posts 7Views 256
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.