• Antergos does not wake up


    When my computer goes to sleep after a 15 min period of inactivity, and I wake it up, the Antergos screen stays black, no matter what I do.
    So I have to shut down and start up again.

  • Could you give us your hardware info and which Linux kernel are you using?

  • @Bryanpwo 4.19.12-arch1-1-ARCH

  • You can try to use the LTS kernel and could you also give us your hardware info and are you using Nvidia drivers?

  • @Bryanpwo No, I am not using Nvidia drivers.
    Here is what I use:
    Generic PnP Monitor ([email protected])
    Intel HD Graphics 4600 (Lenovo)
    2048MB ATI AMD Radeon HD 8600/8700M (Lenovo)
    CrossFire Disabled

    Please tell me how I can use the LTS kernel, what do I need to do for that?

  • You can open open Pamac and search for linux-lts and linux-lts-headers, select them and install or
    if you want to use the terminal:

    sudo pacman -S linux-lts linux-lts-headers
    

    reboot after install and select the LTS kernel in the Grub menu.

  • @Bryanpwo Thanks, I just took the Terminal root, which went fine, but the last message there is:

    Arming ConditionNeedsUpdate
    

    If there is another step to take, should I:

    • 1st restort Antergo, then
    • take that next step?

    And what is that next step?

  • It’s not an error message, basically it means you’ve installed a package that is essential to the core system. In this case LInux LTS kernel, just reboot and follow the step I gave you earlier.

  • @Bryanpwo I rebooted. I cannot see any other steps you recommended.
    When I start up the computer the Grub offers no option to boot with the LTS kernel, there is just the usual boot menu.
    So, I assume that means the same kernel is used as before, and consequently the sleep/wake issue is still there.

  • You can find the LTS kernel under advanced options in the grub menu. (The screen with the Antergos logo where you’ll have 5 seconds to choose an option)

  • @Bryanpwo I went into the advanced options, there is no mention of the LTS kernel.

  • Then for some reason the LTS kernel didn’t get installed properly, could you check if it is installed? Just use Pamac to see if the boxes are checked, if not try again.

  • @Klaas-Vaak
    Could you show here the output of command:

    pacman -Qs linux kernel  | grep 'local/linux'
    
  • @manuel

    local/linux 4.19.12.arch1-1 (base)
    local/linux-api-headers 4.17.11-1
    local/linux-headers 4.19.12.arch1-1
    local/linux-lts 4.14.90-1
    local/linux-lts-headers 4.14.90-1
    

    BTW, there is a package that needs to be updated: Deepin Anything file search tool. When I apply, this is the what the message box says:

    could not satisfy dependencies:
    unable to satisfy dependency 'linux>=4.20' required by deepin-anything-module
    unable to satisfy dependency 'deepin-anything-module' required by deepin-anything
    

    Could this be related?

  • The Deepin update isn’t related to your problem, in fact you can ignore that package update untill the 4.20 kernel hits the Arch repo and it will be released in a matter of days.

    For the linux kernel and hibernation problem just type in the following command:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Now the system should get all the Linux kernels you’ve installed and put it in the grub menu, reboot after it’s finished and the LTS kernel should be in the menu by then.

  • @Bryanpwo I did that, rebooted but the LTS kernel was not in the Advanced menu.

  • After you’ve entered the command, did it detect the LTS kernel?

  • Try if reinstalling the LTS kernel would change things.

  • @Bryanpwo it took 3 reboots, but the LTS kernel was there, finally. I’ll now see how Sleep performs, and let you know.

  • I just read your other post about shared folders and now I understand why things didn’t work as smooth as it should be. I’m waiting patiently for your results and I do hope you take @manuel 's advice from your other post, just get into Antergos/Arch gradually.😉

wake10 Posts 28Views 419
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.