• Shared folders


    I have decided to eventually ditch Windows and go for Linux. I have been looking at some distros, and came across Antergos 3 days ago. I have not looked at it extensively because I have been trying to configure it, but so far I am impressed with this beginner-friendly face of Arch Linux.
    I have it set up as a guest in VirtualBox on my Windows host, and have set 3 Windows folders to be shared. Those folders show up in Antergos, but the files are not visible even though they are there. The same folders and files show up in other guest distros flawlessly.
    Please advise how I can make the files visible.

    I have installed Antergos with the Deepin DE, VirtualBox is version 6.0.0 r127566 (Qt5.6.2), and the host in Win 8.1/64-bit.

  • This post is deleted!
  • hopefully this helps a bit.

    https://wiki.archlinux.org/index.php/VirtualBox#Enable_shared_folders

    you must be part of a group and also need some mounting in the operating system after you al setup shared folder in virtualbox in windows host.

  • @Klaas-Vaak
    Probably you need to install Virtualbox guest additions into the guest Antergos. Virtualbox in Windows should include them by default, if I recall correctly.

    Antergos also has those additions as packages, but currently Arch/Antergos has virtualbox version 5.2.22, and it also works (meaning packages virtualbox-guest-utils and virtualbox-guest-dkms) if you don’t want to use additions from Windows.
    In the long run it is easier to use Antergos packages in the guest, when Arch/Antergos gets updated to version 6.0.0.

    Also, as the link from @ringo32 mentioned, guest user must be in vboxsf group.

  • Actually, the community-testing repo has virtualbox 6.0.0.
    I’m not recommending using it now, since it is in testing. But if you wish to try it, it should already work, at least for me it does.

    To use it (temporarily), file /etc/pacman.conf needs to be edited: remove the “#” characters from the beginning of the lines, i.e. change lines

    #[community-testing]
    #Include = /etc/pacman.d/mirrorlist
    

    to

    [community-testing]
    Include = /etc/pacman.d/mirrorlist
    

    and update system (only virtualbox related packages):

    sudo pacman -Syyu
    
  • @ringo32 Thanks for your reply. I have set up shared folders in VB, the same ones that work flawlessly in other distros I have in VB, as mentioned above. And they do get mounted when I start up Antergos.

    I am part of the vboxsf group - this is the print-out from the terminal showing the groups I am part of: wheel vboxsf autologin.

  • what is :

    lsmod | grep vboxsf
    

    ?

  • @manuel thanks for your reply. Yes, I had noticed Antergos is still behind with its virtualbox-guest-utils. I have a question regarding your suggestions:

    after removing the # from the 2 lines, you say I should update the virtualbox related packages only, using:

    sudo pacman -Syyu
    

    What is the argument/condition I should add to the end of that line of code? Excuse my ignorance, I am completely new to Linux.

    Oh, another thing is that that pacman.conf file is read only. I have tried a number of times to change ownership of folders via the terminal as follows:

    sudo chown -R $USER:$USER foldername
    

    but Antergos is not accepting it. So that’s another issue that needs to be solved.

    BTW, in a reply to Ringo32 below I have explained that I have set up the shared folders in VB.

  • @ringo32
    vboxsf 32768 3
    vboxguest 40960 5 vboxsf

  • i would not touch pacman.conf for now its for pacman is strange to read only ?

    i got no idea personally how to share , did once my self but is while back i dont remember…

    i gues linux-headers is also there so you have full screen of antergos. virtualbox extention pac also there probably… sorry can not help with it.

  • @Klaas-Vaak
    First a word of warning: using testing packages may cause unexpected results. So if you do not feel comfortable using testing packages, do not do the things below! In my tests the 5.2.22 packages on the guest work OK with 6.0.0 on the host.

    Now, before changing /etc/pacman.conf, update your system and reboot:

    sudo pacman -Syu
    reboot               # recommended though not strictly necessary
    

    For updating virtualbox to 6.0.0, just edit file /etc/pacman.conf using root/sudo permissions and update the system. Do not try to change the ownership of the file!

    So do something like this:

    sudo nano /etc/pacman.conf  # may use your favorite editor instead of nano
    

    and edit as explained in the earlier posting.
    Then you can run

    sudo pacman -Syyu virtualbox-guest-utils virtualbox-guest-dkms
    reboot              # this is needed
    

    Now you can start using the new virtualbox versions.

    And touching /etc/pacman.conf may be a bit dangerous, so now you should revert the changes in that file, again with

    sudo nano /etc/pacman.conf
    

    thus removing the usage of testing repos.

  • @manuel I did go through the steps to install version 6, but now the shared folders are not visible anymore.

  • @Klaas-Vaak
    Have you installed the guest additions?

  • Also, make sure the user in the VM is in group vboxsf. You can see it with command

    id
    

    in the VM.

    And, make sure vboxservice.service is active in the VM:

    systemctl status vboxservice.service
    

    If it is disabled, you can enable it with

    systemctl enable vboxservice.service
    

    in the VM, then reboot.

  • @manuel

    id
    

    returns, among other things,

    109(vboxsf)
    

    Then, typing

    systemctl status vboxservice.service
    

    it seemed to be enabled, but at the end of the list it seemed to say it was not, so I enabled it, rebooted, and rechecked, and here is the print-out (note my real name is peter):

    vboxservice.service - VirtualBox Guest Service
       Loaded: loaded (/usr/lib/systemd/system/vboxservice.service; enabled; vendor preset: disabled)
       Active: failed (Result: exit-code) since Sun 2018-12-30 11:20:08 EET; 4min 4s ago
      Process: 275 ExecStart=/usr/bin/VBoxService -f (code=exited, status=1/FAILURE)
      Process: 274 ExecStartPre=/usr/bin/modprobe vboxsf (code=exited, status=0/SUCCESS)
      Process: 268 ExecStartPre=/usr/bin/modprobe vboxvideo (code=exited, status=0/SUCCESS)
      Process: 257 ExecStartPre=/usr/bin/modprobe vboxguest (code=exited, status=0/SUCCESS)
     Main PID: 275 (code=exited, status=1/FAILURE)
    
    Dec 30 11:20:08 peter-pc VBoxService[275]: 09:20:08.115116 main     6.0.0 r127442 started. Verbose level = 0
    Dec 30 11:20:08 peter-pc VBoxService[275]: 09:20:08.116758 main     vbglR3GuestCtrlDetectPeekGetCancelSupport: Supported (#1)
    Dec 30 11:20:08 peter-pc VBoxService[275]: 09:20:08.117479 main     Error: Failed to become guest control master: VERR_VERSION_MISMATCH
    Dec 30 11:20:08 peter-pc VBoxService[275]: 09:20:08.118044 main     Error: Service 'control' failed to initialize: VERR_VERSION_MISMATCH
    Dec 30 11:20:08 peter-pc VBoxService[275]: 09:20:08.118155 main     Session 0 is about to close ...
    Dec 30 11:20:08 peter-pc VBoxService[275]: 09:20:08.118217 main     Stopping all guest processes ...
    Dec 30 11:20:08 peter-pc VBoxService[275]: 09:20:08.118255 main     Closing all guest files ...
    Dec 30 11:20:08 peter-pc VBoxService[275]: 09:20:08.118293 main     Ended.
    Dec 30 11:20:08 peter-pc systemd[1]: vboxservice.service: Main process exited, code=exited, status=1/FAILURE
    Dec 30 11:20:08 peter-pc systemd[1]: vboxservice.service: Failed with result 'exit-code'.
    

    Same as earlier. Seems to me it starts up, then exits.

  • @manuel I only have the .iso image from which I installed Antergos. After the installation of Antergos the shared folders were visible, after your update to v.6 they weren’t anymore.
    If I now click on the VB menu Devices, Insert GuestAdditions CD image it says:

    Unable to insert the virtual optical disk C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso into the machine Antergos.
    
    
    
    Could not mount the media/drive 'C:\Program Files\Oracle\VirtualBox\VBoxGuestAdditions.iso' (VERR_PDM_MEDIA_LOCKED).
    
    Result Code: E_FAIL (0x80004005)
    Component: ConsoleWrap
    Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
    Callee: IMachine {5047460a-265d-4538-b23e-ddba5fb84976}
    

    but where can it load v.6 that we installed yesterday? Obviously the .iso image on carries the old version.

  • @Klaas-Vaak
    Some kind of version mismatch in the VM, maybe there are now mixed versions 5.2.22 and 6.0.0 inside the VM?

    Well, you can start all over the square one. Remove all virtualbox stuff from the VM, both with pamac GUI and, if you have some virtualbox related folder under /opt, run the uninstall.sh script from there.

    Then you probably should (in the VM) remove the testing repo from /etc/pacman.conf and give commands

    sudo pacman -Syy
    reboot
    

    to make forget that testing repo.
    After VM reboot, it should be clean from any virtualbox stuff.

    Then, in the VM, install packages:

    sudo pacman -S --needed virtualbox-guest-utils virtualbox-guest-dkms linux-headers     # optionally: linux-lts-headers
    

    Install linux headers for the linux kernels you have installed in the VM.

    Now after reboot you should have a working VM. Check that vboxsf group is OK, and the vboxservice is running properly:

    $ systemctl status vboxservice.service
    ● vboxservice.service - VirtualBox Guest Service
       Loaded: loaded (/usr/lib/systemd/system/vboxservice.service; enabled; vendor preset: disabled)
       Active: active (running) since Sun 2018-12-30 12:12:09 EET; 38s ago
      Process: 331 ExecStartPre=/usr/bin/modprobe vboxsf (code=exited, status=0/SUCCESS)
      Process: 330 ExecStartPre=/usr/bin/modprobe vboxvideo (code=exited, status=0/SUCCESS)
      Process: 325 ExecStartPre=/usr/bin/modprobe vboxguest (code=exited, status=0/SUCCESS)
     Main PID: 332 (VBoxService)
        Tasks: 8 (limit: 4915)
       Memory: 2.3M
       CGroup: /system.slice/vboxservice.service
               └─332 /usr/bin/VBoxService -f
    

    It should be active.

  • @manuel said in Shared folders:

    Remove all virtualbox stuff from the VM, both with pamac GUI

    I found out what is the pamac GUI, and “all virtualbox stuff” as far as I can tell from the list consists of virtualbox-guests-dkms and virtualbox-guest-utils, both v. 6.0.0. Is there anything else I should remove?

    The /opt folder is empty.

    Then you probably should (in the VM) remove the testing repo from /etc/pacman.conf

    I did not touch that file at all. If it was changed, however, by the action we took yesterday, then please indicate the steps I should take.

    Install linux headers for the linux kernels you have installed in the VM.

    Is that the same step as we took yesterday?

  • @Klaas-Vaak

    virtualbox-guests-dkms and virtualbox-guest-utils

    sudo pacman -R virtualbox-guests-dkms virtualbox-guest-utils
    

    should be enough.

    In /etc/pacman.conf, edit

    [community-testing]
    Include = /etc/pacman.d/mirrorlist
    

    to

    #[community-testing]
    #Include = /etc/pacman.d/mirrorlist
    

    if it is not already like that.
    Then reboot.

    Then give commands:

    sudo pacman -S linux-lts-headers linux-headers
    

    You are doing the same commands again, but now with version 5.2.22 and not 6.0.0.
    But if in the mean time Arch updates virtualbox to 6.0.0, that’s just great, don’t worry! :)

  • @Klaas-Vaak
    This is becoming a mess. The thing to do is quite simple: install two virtualbox packages into the Antergos guest and reboot. That should have worked right from the start.

shared10 folders8 Posts 24Views 620
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.