• After Fresh installation there is no sound from subwoofer


    i am using Antergos 18.12 Cinnamon
    My motherboard is Asus F2A85-V and has built in Realtek® ALC887 8-Channel High Definition Audio CODEC
    So i click test sound and i get sound for front left and fron right but not from subwoofer
    0_1545994360876_Screenshot from 2018-12-28 12-51-23.png
    Any help would be appreciated.

  • You have to change the output profile to multichannel (5, 7 or 8) sound, now it’s set to analog mono.

  • @Bryanpwo i had changed the profile to 2.1 but when i click Line out
    Built -in-Audio
    it gets reset to Analog Mono Input
    any ideas ?

  • What i have done so far:

    Copy the daemon.conf file.

    cp /etc/pulse/daemon.conf ~/.config/pulse/
    Uncomment ‘enable-lfe-remixing’ and set yes.

    enable-lfe-remixing = yes
    Copy the default.pa file.

    cp /etc/pulse/default.pa ~/.config/pulse/
    Add at the end of the file this load module.

    load-module module-combine channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe

    and

    Install alsa-tools ( pacman -S alsa-tools ).

    Run as root hdajackretask.

    Check “show unconnected pins”.

    Remap 0×1b (“Not connected”, which is the subwoofer) to “Internal speaker (LFE)”.

    Install boot override.

    Reboot.

  • Is Pulse still your default sound handler, because it seems like you’ve tried to use ALSA to acces Pulse, but it has to be the other way around.

  • @Bryanpwo said in After Fresh installation there is no sound from subwoofer:

    Is Pulse still your default sound handler, because it seems like you’ve tried to use ALSA to acces Pulse, but it has to be the other way around.

    well i am formating my drive as we speak just to start from the beginning

  • Then check archwiki pulse audio over here if you’re at it.

  • @Bryanpwo i wish we could use remote desktop, it would be much easier that way.

  • @Bryanpwo Checked the troubleshooting unfortunantly doesnt have my problem listed.

  • This link may shed some more light on your problem. It explains very well how Pulse audio handles ALSA.

  • @dreamtraveler do you try plasma-pa ?

    and do you check alsa-mixer to see what is aviable? (pressing F6 will show aviable sounddevices)

  • @joekamprad no i havent tried plasma-pa alsamixer’s F6 shows
    0_1546012564607_Screenshot from 2018-12-28 17-55-38.png and 0_1546012659062_Screenshot from 2018-12-28 17-57-03.png

  • Here i need to disable HDMI as sounddevice to get my BT Headset working nice… i du that with pavucontrol
    0_1546014894039_Bildschirmfoto vom 2018-12-28 17-34-27.png

    So may disable other devices at yours will help.

  • @joekamprad the thing is that it doesnt recognize my audio device as realtek ALC887 so i think thats my priority.

  • This post is deleted!
  • @joekamprad whats that? mine doesnt say chip: Realtek ALC887
    edit: sorry i missed that.

  • This post is deleted!
  • @joekamprad
    0_1546020377927_Screenshot from 2018-12-28 20-05-15.png
    0_1546020381435_Screenshot from 2018-12-28 20-04-42.png
    Do i have to change something else?

  • @joekamprad When i hit Subwoofer libcanberra is seen at playback but i get no sound and then it vanishes.
    0_1546020888883_Screenshot from 2018-12-28 20-10-46.png

installation321 sound60 fresh43 subwoofer3 Posts 34Views 307
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.