• AMD Catalyst install not working...


    Using the link below and following exactly…
    [url:3j7rpibx]http://wiki.antergos.com/How+to+install+AMD+Catalyst+drivers[/url:3j7rpibx]

    I get this error message:

    [[email protected] ~]$ sudo pacman -Syy  
    error: catalyst: key "ABED422D653C3094" is unknown  
    :: Import PGP key 2048R/, "Vi0L0 <[email protected]\>", created: 2011-11-13? [Y/n] y  
    error: key "Vi0L0 <[email protected]\>" could not be imported  
    :: Synchronizing package databases...  
    testing 39.6 KiB 514K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    core 112.4 KiB 730K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    extra 1769.0 KiB 884K/s 00:02 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community-testing 1964.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2.3 MiB 877K/s 00:03 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib-testing 1160.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib 121.1 KiB 700K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    antergos 272.4 KiB 1905K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    catalyst 11.1 KiB 5.40M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    catalyst.sig 287.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: catalyst: key "ABED422D653C3094" is unknown  
    :: Import PGP key 2048R/, "Vi0L0 <[email protected]\>", created: 2011-11-13? [Y/n] y  
    error: key "Vi0L0 <[email protected]\>" could not be imported  
    error: failed to update catalyst (invalid or corrupted database (PGP signature))  
    error: database 'catalyst' is not valid (invalid or corrupted database (PGP signature))  
    [[email protected] ~]$ 
    
  • Using the link below and following exactly…
    [url:3j7rpibx]http://wiki.antergos.com/How+to+install+AMD+Catalyst+drivers[/url:3j7rpibx]

    I get this error message:

    [[email protected] ~]$ sudo pacman -Syy  
    error: catalyst: key "ABED422D653C3094" is unknown  
    :: Import PGP key 2048R/, "Vi0L0 <[email protected]\>", created: 2011-11-13? [Y/n] y  
    error: key "Vi0L0 <[email protected]\>" could not be imported  
    :: Synchronizing package databases...  
    testing 39.6 KiB 514K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    core 112.4 KiB 730K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    extra 1769.0 KiB 884K/s 00:02 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community-testing 1964.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    community 2.3 MiB 877K/s 00:03 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib-testing 1160.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    multilib 121.1 KiB 700K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    antergos 272.4 KiB 1905K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    catalyst 11.1 KiB 5.40M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    catalyst.sig 287.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    error: catalyst: key "ABED422D653C3094" is unknown  
    :: Import PGP key 2048R/, "Vi0L0 <[email protected]\>", created: 2011-11-13? [Y/n] y  
    error: key "Vi0L0 <[email protected]\>" could not be imported  
    error: failed to update catalyst (invalid or corrupted database (PGP signature))  
    error: database 'catalyst' is not valid (invalid or corrupted database (PGP signature))  
    [[email protected] ~]$ 
    
  • @"Uncle said:

    Using the link below and following exactly…
    [url:23bk2ua3]http://wiki.antergos.com/How+to+install+AMD+Catalyst+drivers[/url:23bk2ua3]

    I get this error message:

    [[email protected] ~]$ sudo pacman -Syy  
    > error: catalyst: key "ABED422D653C3094" is unknown  
    > :: Import PGP key 2048R/, "Vi0L0 <[email protected]\>", created: 2011-11-13? [Y/n] y  
    > error: key "Vi0L0 <[email protected]\>" could not be imported  
    > :: Synchronizing package databases...  
    > testing 39.6 KiB 514K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > core 112.4 KiB 730K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > extra 1769.0 KiB 884K/s 00:02 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > community-testing 1964.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > community 2.3 MiB 877K/s 00:03 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > multilib-testing 1160.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > multilib 121.1 KiB 700K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > antergos 272.4 KiB 1905K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > catalyst 11.1 KiB 5.40M/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > catalyst.sig 287.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    > error: catalyst: key "ABED422D653C3094" is unknown  
    > :: Import PGP key 2048R/, "Vi0L0 <[email protected]\>", created: 2011-11-13? [Y/n] y  
    > error: key "Vi0L0 <[email protected]\>" could not be imported  
    > error: failed to update catalyst (invalid or corrupted database (PGP signature))  
    > error: database 'catalyst' is not valid (invalid or corrupted database (PGP signature))  
    > [[email protected] ~]$ 
    

    your /etc/pacman.conf entry is as follows?

      
    > Server = http://catalyst.wirephire.com/repo/catalyst/$arch  
    > SigLevel = Optional TrustAll  
    > 
    

    just run the command again, somtimes it takes a couple tries.

    also you will need to downgrade xorg to install the latest catalyst.

  • To downgrade add this repo (this should be located before your core repo so it takes priority)

      
    Server = http://catalyst.wirephire.com/repo/xorg115/$arch  
    SigLevel = Optional TrustAll  
    
    

    update a couple times to be sure the key is working

    sudo pacman -Syy
    

    then do the downgrade

    sudo pacman -Syuu
    

    then you can continue with the guide.

    When in doubt, read the Arch Wiki. They give you all the info you need.
    [https://wiki.archlinux.org/index.php/AMD_Catalyst][0]">[https://wiki.archlinux.org/index.php/AMD_Catalyst][1]

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/AMD_Catalyst

  • As I said in my original post, I [i:3ge39ygu]already[/i:3ge39ygu] did that. I followed the directions exactly.

      
    Server = http://catalyst.wirephire.com/repo/catalyst/$arch  
    SigLevel = Optional TrustAll
    

    It seems to have accepted the key. It took a total of 29 times doing [b:3ge39ygu]sudo pacman -Syy[/b:3ge39ygu].

    Now. What do you mean by “then do the downgrade”? According to the Antergos WIKI, the next step is suppose to be:

    sudo pacman -R ati-dri xf86-video-ati glamor-egl
    
  • @"Uncle said:

    As I said in my original post, I [i:3afh2efr]already[/i:3afh2efr] did that. I followed the directions exactly.

      
    > Server = http://catalyst.wirephire.com/repo/catalyst/$arch  
    > SigLevel = Optional TrustAll
    

    It seems to have accepted the key. It took a total of 29 times doing [b:3afh2efr]sudo pacman -Syy[/b:3afh2efr].

    Now. What do you mean by “then do the downgrade”? According to the Antergos WIKI, the next step is suppose to be:

    sudo pacman -R ati-dri xf86-video-ati glamor-egl
    

    read my post above, the Antergos wiki is outdated.

  • also most likely glamor-egl will not be installed on your system. and you will have to add lib32-ati-dri to that list on the remove command.

  • come to think of it, I should go ahead and update the wiki myself

  • Many thanks!

  • Was having some issues with the wiki editor. But all is resolved now. If you are still having issues. Read the updated wiki.
    [http://wiki.antergos.com/How+to+install+AMD+Catalyst+drivers][0]">[http://wiki.antergos.com/How+to+install][1] … st+drivers

    [0]: <a href=
    [1]: http://wiki.antergos.com/How+to+install

Posts 10Views 4014
Log in to reply