• Skipping audio in youtube videos, crackling when nothing playing


    Hi, I’ve just installed Antergos, full install, KDE, no ZFS etc.

    Most is excellent, but when I’m watching videos (I use Vivaldi) the sound stops for a very short time, maybe every 30 seconds? And after playing Civ 5 or 6 (not sure which) I can hear a crackle/click about the same time gaps.

    Is there any known issue before I start delving etc.? I ask this 1st because on Solus and KDE Neon (couple of years on both of these) this never happened.

  • @robgriff444
    pulseaudio -k should restart your sound
    what’s civ 5 or 6 and why would it matter? rename your .config/vivaldi and try with a default profile

  • @trytip I’ve ruled out the Civ games and it also happens independantly of Vivaldi, it’s just that that’s mostly when I’m listening to it. It’s a click / pop at irregular intervals and it happens regardless of what the PC is doing.

    Restarting pulse doesn’t help and I’ve also disabled the GPU’s (1050Ti) onboard sound in KDE system settings so I’m a bit confused where it’s coming from. I had something a bit like this in Win10 and it was due to the sound driver software (MBD: A320M-K) auto-selecting the wrong device on the GPU but was solved by choosing the correct one on the MBD.

    I have tried Pavucontrol which shows my MBD ouput active and the GPU inactive and it looks ok, but I noticed that clicking on the mute button made the same sound that I am complaining about so I tried muting with KDE and that does exactly the same - clicks every time I mute / unmute.

    Edit: I found this:

    https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting#Pops_when_starting_and_stopping_playback

    … and tried it and fingers crossed it seems to be working, I’ll confirm in a few hours…

  • Commenting that line in relevant file fixes that issue. A better solution is to add the following file:

    nano ~/.config/pulse/default.pa

    .include /etc/pulse/default.pa
    unload-module module-suspend-on-idle
    
  • @joekamprad Yeah that’s what I did last night and it seems it’s solved.

audio50 videos11 youtube6 skipping3 Posts 5Views 169
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.