• BCM4360 and broadcom-wl

    So I have a BCM4360 in my desktop computer. I don’t really need it since I use ethernet. However I have a need to use it as an access point to intercept some traffic. But I can’t get it to work.

    I have read that it is not supported by the b43 driver so I need to use either broadcom-wl or broadcom-wl-dkms. I have tried both with no result. The wiki doesn’t seem to indicate if any additional steps are needed after installing it from the repositories but I did try sudo modprobe wl but that spits out an error that wl wasn’t found.

    Based on the output of sudo lspci -vnn -d 14e4:

    0a:00.0 Network controller [0280]: Broadcom Inc. and subsidiaries BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
    	Subsystem: ASUSTeK Computer Inc. BCM4360 802.11ac Wireless Network Adapter [1043:8659]
    	Flags: fast devsel, IRQ 10, NUMA node 0
    	Memory at fb800000 (64-bit, non-prefetchable) [disabled] [size=32K]
    	Memory at fb600000 (64-bit, non-prefetchable) [disabled] [size=2M]
    	Capabilities: [48] Power Management version 3
    	Capabilities: [58] MSI: Enable- Count=1/1 Maskable- 64bit+
    	Capabilities: [68] Vendor Specific Information: Len=44 <?>
    	Capabilities: [ac] Express Endpoint, MSI 00
    	Capabilities: [100] Advanced Error Reporting
    	Capabilities: [13c] Device Serial Number 00-00-00-ff-ff-00-00-01
    	Capabilities: [150] Power Budgeting <?>
    	Capabilities: [160] Virtual Channel
    	Capabilities: [1b0] Latency Tolerance Reporting
    	Capabilities: [220] Resizable BAR <?>
    	Kernel modules: bcma

    It seems the module it is trying to use is bcma. The wiki does say that if you are using b43 that module needs to be blacklisted however it does not seem to specify if it does for broadcom-wl or broadcom-wl-dkms. Doing so however seemed to prevent my computer from booting so I’m guessing not.

    Any help getting this working would be appreciated.

  • Didn’t have linux-headers installed… Seems to be working now. Will mark as solved

broadcom-wl9 bcm43601 Posts 2Views 153
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.