• Incomplete update of linux package - can't boot up now


    I have been using Antergos in a vmware virtual machine on a Windows desktop. Yesterday, I did a system update and I notice that there was a new version of the linux package. I did not realize that the drive containing the Antergos virtual disk was running out of disk space. The update crashed midway with a “disk full” error message.

    After I freed up a lot of space on the drive, I found out I cannot boot up Antergos – there is a missing file in /usr/lib/modules. Sadly, I did not install the LTS kernel. Can I use Rufus to create a boot flash drive to boot up and repair my Antergos system? What do I need to do? Many thanks in advance for your kind and detailed advices.

    Lila Boc Life Is Like A Box Of Chocolate

  • Do you still get into the grub boot menu? And do you still have the old kernel listed there? Did you tried to chose the old kernel to boot?

  • @jshamg Thank you for your reply.

    The menu shows “Antergos Linux” and “Antergos Linux - Fallback”, both choices end up as below:

    Warning: /lib/modules/4.19.9-arch1-1-ARCH/modules.devname not found - ignoring starting version 239
    ERROR: resume: hibernation device 'UUID=38e0ec29-d943-4c0b-8c58-ec3d040625f5' not found
    ERROR: device 'UUID=911a09bb-15bd-4df5-9b58-a019b688bd68' not found. Skipping fsck.
    mount: /new_root: can't find UUID=911a09bb-15bd-4df5-9b58-a019b688bd68.
    You are now being dropped into an emergency shell.
    sh: can't access tty: job control turned off
    [rootfs ]#

    I can’t type anything in that shell.

    However, I can configure vmware to make the latest antergos-18.12-x86_64.iso available during the boot process. I am able to boot up using this and mount the root disk. Please advice on how I can repair my system. Thank you for all your help.

  • hello try this:

    solution that worked was :

    Using Minimal ISO
    (Use CD/DVD at start up)
    Close CNCHI Installer
    Connect to WiFi / Internet
    Wait till CNCHI is updated
    Close CNCHI
    Open Terminal
    Update Mirrorlist

    sudo reflector -l 30 -f 15 --save /etc/pacman.d/mirrorlist

    use command “cnchi” to open cnchi from the terminal
    Follow the instructions

  • @ljdj89 is this your solution for every problem here now?

  • @lilaboc you will need to chroot into antergos from booting with liveISO.

    Boot up with our LiveIso.

    mount System to /mnt

    You need to know which device is the right one check with sudo fdisk -l

    sudo su

    /dev/sdXn should be replaced with the right device information, and depending on your installation you may have or have not a seperate /boot partition. If not /boot is a folder under / on the same partition as the filesystem root.

    mount /dev/sdXn /mnt >> / root partition

    mount /dev/sdXn /mnt/boot >>> /boot partition --> without extra /boot partition you do not need this step!

    mount /dev/sdXn /mnt/boot/efi >>>>> the EFI-boot (fat) partition

    arch-chroot /mnt

    then fullfill the failed update pacman -Syyu
    and for failsavety rebuild kernel images mkinitcpio -P

  • @joekamprad Thank you for your detailed instructions, even including steps for separate boot and EFI partitions. Everything went so smoothly, it’s like you had VNC in and fixed my system yourself. Thanks again.

  • @lilaboc said in Incomplete update of linux package - can't boot up now:

    it’s like you had VNC in and fixed my system yourself.


    It is a very common problem after not completed kernel updates…

boot320 incomplete2 Posts 8Views 339
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.