• Decrypting HDD in file manager


    I have an encrypted HDD which, in other distros, can easily be decrypted using the file manager. Just click on the drive and input the encryption password. However, in antergos (i3 version), I am getting the following error, after typing the password:

    “Not authorized to perform operation”

    Any idea how to fix this? I can decrypt it just fine using cryptsetup in the terminal, but I’d like to be able to use the gui. I’ve tried both thunar and pcmanfm and none of them work.

  • @markoff I have the same issue with antergos KDE. When I insert encrypted external HDD, it asks me to enter LUKS password. After entering it, it asks to enter root password to mount drive. After root password is entered, I get the same error like you, but drive actually gets mounted. It’s not displayed in file manager (Dolphin) for some reasons, but if I manually change path in Dolphin’s address bar to /path/to/external/hdd I can see all the files.

manager80 hdd13 decrypting2 Posts 3Views 91
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.