• Unable to boot in graphical mode


    Hello, I’ve got a strange problem.

    My sister’s computer running Antergos by itself is unable to graphically boot. When I tried to boot it before today, the computer seemed to go into a lower power state, and the backlight flickered very subtly on a blank screen. After a few minutes, it stabilized and there was a terminal cursor in the upper left. While the screen was flickering, I was unable to switch TTYs, and pressing Ctrl+Alt+F1 to go to tty1 brought up the initial boot message stating that the root was clean, and nothing after that.

    Today, when I started up the computer, the boot messages said that it was unable to start LightDM, so it might be related to that. After trying to start LightDM, the boot hangs.

    I can switch TTYs once it’s stabilized, and I can boot into multi-user.target no problem. I can also boot into the rescue shell.

    The computer is an HP All-In-One 24-f0047c with AMD Radeon R5 graphics. KDE Plasma is the DE if it’s important.

    I’ve already tried the fix here, as suggested in IRC. No change in ability to graphically boot. I have also tried to switch to the LTS kernel, also no change. Force updating all packages also didn’t work.

    According to Tiedemann in IRC there doesn’t seem to be any driver issues.

    Here are my logs, with commands used to get them:

    journalctl -b -0
    journalctl -b -1
    journalctl -b -2

    Couldn’t find Xsession logs, unfortunately. Maybe I’m looking in the wrong spots.

    dmesg -rl warn,err,crit

    cat /var/log/Xorg.0.log
    cat /var/log/Xorg.0.log.old

    cat /var/log/lightdm/lightdm.log
    cat /var/log/lightdm/lightdm.log.old

    No x-0-greeter.log, so I’ll post the rest that are in that directory.

    cat /var/log/lightdm/seat0-greeter.log
    seat0-greeter.log.old is the same.

    cat /var/log/lightdm/x-0.log
    cat /var/log/lightdm/x-0.log.old

    If you can tell me where to look for them, I can paste additional logs. Thank you for your assistance!

  • Dec 18 13:59:43 Karalin-PC kernel: [drm:construct [amdgpu]] *ERROR* construct: Invalid Connector ObjectID from Adapter Service for connector index:2! type 0 expected 3
    ***
    Dec 18 13:59:51 Karalin-PC lvm[281]:   /dev/sdb: open failed: No medium found
    

    i do not see something failing on boot journal, only lightdm is failing to start up…

    /usr/bin/lightdm-webkit2-greeter: error while loading shared libraries: libicuuc.so.62: cannot open shared object file: No such file or directory
    

    check if icu is installed and system is up to date:
    sudo pacman -Syyu
    pacman -Qs icu

    If this is not the issue:

    i would try a different DM to see if it is (most luckily it is lightdm failing as itself) DM take sddm for KDE (qt) or GDM for GNOME (gtk):

    installing-display-managers

  • @joekamprad System was up to date and icu was installed. I forced updated it just in case.

    I switched to SDDM for my display manager, but I have another problem now. I can get to the graphical login prompt and everything seems to be okay at first. However, when I attempt to enter the password to log in, the KDE mouse cursor shows up before the screen glitches, then takes me back to the initial boot messages saying that the root is clean, then kicks me back to the graphical login. As it stands, I still can’t log in the way I need to.

    If you can point me in the direction of the SDDM logs I can post them.

    In the meantime, I’m going to try to switch to XFCE to see if KDE itself is the problem.

    EDIT: After switching to XFCE, I can boot graphically, but I still have a problem. Windows are transparent and are not able to be used, along with the menu in the lower left. I installed everything in xfce4 and xfce4-goodies. I’m unable to use the terminal unless I switch TTYs.

    EDIT 2: More specifically, it seems that the screen does not update when I click on something in a window or open a window, and I need to switch to another TTY and back for it to update.

  • @Pirotika strange behavior…

    i am clueless at the moment…

    may try to create a new testuser, may it is related to some configs…

  • It may be worthwhile verifying that packages are installed correctly?
    In a terminal do sudo pacman -Qk and check output has 0 missing files for all packages,
    and also pacman -Dk
    output should be No database errors have been found!

  • @Pirotika said in Unable to boot in graphical mode:

    I switched to SDDM for my display manager, but I have another problem now. I can get to the graphical login prompt and everything seems to be okay at first. However, when I attempt to enter the password to log in, the KDE mouse cursor shows up before the screen glitches, then takes me back to the initial boot messages saying that the root is clean, then kicks me back to the graphical login. As it stands, I still can’t log in the way I need to.

    This is exactly what one of my systems does after recent updates - https://forum.antergos.com/topic/11090/kde-fully-broken-after-today-s-update/10

    Unfortunately, no solution so far…

  • Sorry about the late response, haven’t had an opportunity to work on the computer a whole lot.

    @joekamprad I created a new test user, and the problem persists with both KDE and XFCE.

    @BlaiseD kcodecs seems to be missing. I tried fixing that package before, but it didn’t seem to stick between boots. How would I go about fixing this package and making sure that the fix persists?

  • On a whim, I decided to switch back to the LTS kernel, and I am able to graphically boot into XFCE now with my sister’s main user! However, graphical pacman says there are a bunch of available updates, so for some reason it seems that using pacman to update packages in the terminal didn’t work, and I suspect that kcodecs being corrupted is the culprit, as I did check its dependents and KDE is part of them.

    How do I fix kcodecs, so pacman can stop complaining about a corrupted package and my sister can use KDE again?

  • @Pirotika
    You could try to reinstall all packages:

    sudo pacman -S $(pacman -Qqn)
    

    Note that installing takes time, several minutes to tens of minutes, depending on the speed of your disk.

    If there are problems installing some packages, you could use force:

    sudo pacman -S --force "list-of-problematic-packages-here"
    

    or even install all using force:

    sudo pacman -S --force $(pacman -Qqn)
    

    And if you happen to have corrupted packages (there should be warning if there are), do this first:

    sudo pacman -Scc
    

    It deletes the package cache, so later you need to download all packages while installing them.

    EDIT: you should instruct your sister to update system about once a week. Waiting too long between system updates may sometimes cause strange behavior.

    What is the exact error while trying to update those codecs? And exactly what command did you use for updating?

  • @manuel The exact error was that it was unable to fully load the metadata for the package (kcodecs). It was pointing to a /files/ directory in the kcodecs lib directory that didn’t exist.

    The exact command to update previously was this:

    sudo pacman -Syyu
    

    I took a step to fix /files/ being nonexistent, by creating that blank directory using touch and forcing an installation of kcodecs through pacman via the terminal.

    pacman is no longer complaining of a invalid or corrupted package, and I am currently updating the system through graphical pacman. Fingers crossed.

    In case that fix doesn’t persist I’ll use the command to clear the package cache.

  • Okay, everything seems to be working so far! KDE is working now, and I’ve switched back to the regular kernel. My sister is using the computer without any problems. I’m going to keep the DM as SDDM for right now.

    I’m going to condense what I did and mark this post as the correct answer so others after me can follow along, hopefully setting them on the track to fixing their problem.

    The problem was that most likely an update on the 10th of December broke my system, as well as a small number of other people. I believe that the kcodecs package was the reason I was not able to graphically boot with KDE, due to being corrupted. pacman also did not update the system as expected due to that corrupted package, so the system was very behind on updates.

    First, as suggested by @joekamprad, I switched the display manager to SDDM. That allowed me to get to the login screen for the DM, but I was still having problems, as KDE would fail to load and kick me back to the login, and XFCE wouldn’t update the screen if I opened a window unless I switched TTYs and back again. I believe that this was due to the update on the 10th. Unfortunately, creating a new user didn’t fix the problem

    Next, on a whim, I decided to switch to the LTS kernel and boot with XFCE. That seemed to work, and I got to work updating the system. Unfortunately, pacman was still complaining about a corrupted package.

    Next, as suggested by @BlaiseD, I verified the integrity of the database using this command:

    pacman -Dk
    

    It told me that kcodecs was corrupted, and that it could not fully load the metadata for the package, while also pointing to a nonexistent directory in the lib folder. I used touch to create that empty directory. @manuel suggested that I force update the package in the terminal, which it did without any problems.

    From then on, pacman did not complain about a corrupted package, and I was able to update normally and boot back into KDE using the regular kernel.

    Thank you all for helping me with this problem, and thank you @Tiedemann for initially helping me in IRC. @toxpal your solution didn’t apply to me, but thank you for linking me your thread anyway.

  • @Pirotika glad to see systems work again, and thank you for detailed review of your solution!

boot303 lightdm136 unable76 graphical14 Posts 12Views 317
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.