• kernel updates kill display port monitor connection


    Seems like everytime there is a major kernel update, my monitor stops working, or rather I can’t boot because it shuts off. this is a new 32 in curved monitor connected with display port 1.4 cable.

    I can’t use a different kernel that I currently have because the LTS kernels always give me a blinking cursor and don’t boot. my current fall back kernel gives a bunch of fail messages and doesn’t boot either.

    My rig is a desktop with AMD Vega 64 GPU. I’m pretty sure I have the amdgpu driver, but, it happens with both it and the ati driver. I don’t have a HDMI cable to test if I can access the system connected with HDMI, but, I imagine so. I use dp because it is a new gaming monitor with freesync and you must use dp 1.4 for freesync to work.

    I need to find a way to downgrade my kernel to the last one from a live USB and a fix for the display port problem for future kernel updates.

  • This is the first time I have had black screen on boot. I believe the kernel he is referencing was fine for me, though one of the 4.19’s I had screen abnormalities on my monitor at it’s native resolution of 1440p. Going back to a previous kernel using the GUI program arch kernel manager fixed that issue.

  • Problem persists on HDMI as well.

  • I tried downgrading my kernel and headers following this Link’s instructions, wiki.archlinux.org/index.php/downgrading_packages but on reboot I enter emergency mode. mounting my /boot/efi and /var fails and systemctl status says vfat and reiserfs are unknown filesystems respectfully. if you were wondering I have separate boot, var, home, and,data partitions. I wasn’t sure what the kernel number was that last worked, so I just subtracted 1 from the end. any suggestions?

  • @michaelnothing must be this one:

      1. linux-4.19.8.arch1-1-x86_64.pkg.tar.xz (remote)

    and do not forget to downgrade headers and may GPU drivers too

  • I had the same problem using an rx vega 56. There was an issue with amdgpu powerplay from the kernel logs. I got my system working by
    downgrading linux-firmware. I also downgraded the kernel but it might not be necessary.

    linux-firmware (20181216.211de16-1 -> 20181026.1cb4e51-1)
    
  • @joekamprad that is the kernel and headers I downgraded to, but, now the system won’t boot because it can’t mount boot or var. Systemctl status boot-efi.mount comes back with can’t read filesystem vfat, and, var with can’t read reiserfs.

  • @michaelnothing rebuild kernelimages may help…

    sudo mkinitcpio -P
    

    After chrooting into system from liveISO

  • Still the same issue.

  • @joekamprad
    Okay i upgraded back to 4.19.9 and I was seeing the boot messages before the monitor turned off. I thendowngraded to 4.19.8 again and now I no longer get the file system errors, but, there is no change between 4.19.9 and 4.19.8. Both turn the monitor off after boot messages.

  • I should also note when the update that triggered this behavior was the Linux package and the Linux headers package. No graphic drivers were updated.

  • I just looked at the boot messages before it shuts off the display and see I am still getting the boot efi failed to mount error.

  • can you give:

    lsblk -o NAME,FSTYPE,UUID,RO,RM,SIZE,STATE,OWNER,GROUP,MODE,TYPE,MOUNTPOINT,LABEL,MODEL
    cat /etc/fstab

    or:

    the urls this ones gives out:

    lsblk -o NAME,FSTYPE,UUID,RO,RM,SIZE,STATE,OWNER,GROUP,MODE,TYPE,MOUNTPOINT,LABEL,MODEL | curl -F [email protected] https://ptpb.pw/?u=1
    
    cat /etc/fstab | curl -F [email protected] https://ptpb.pw/?u=1
    
  • /var reiserfs ?

  • @joekamprad
    Yes. I set it up long ago following Arch instructions. I set up LVM2 partitions and just install over top of them keeping my separate /data partition for my media between installs, and, /home for my settings… Something I read while setting it up suggested reiserfs for /var because it handles small files well.

    https://bbs.archlinux.org/viewtopic.php?id=65196
    here is a debate over ext4 versus reiserfs from arch forums.

  • sda                        0  0 931.5G running             brw-rw---- disk                  Samsung SSD 850 
    ├─sda1                     0  0     1G                     brw-rw---- part /boot/efi        
    ├─sda2                     0  0   700G                     brw-rw---- part                  
    │ ├─long-dora              0  0   3.2T running             brw-rw---- lvm                   
    │ ├─long-swop              0  0    12G running             brw-rw---- lvm                   
    │ ├─long-ruut              0  0    50G running             brw-rw---- lvm  /                
    │ ├─long-var               0  0    24G running             brw-rw---- lvm  /var             
    │ └─long-hoem              0  0   100G running             brw-rw---- lvm                   
    ├─sda3                     0  0    16M                     brw-rw---- part                  
    ├─sda4                     0  0    48G                     brw-rw---- part                  
    ├─sda5                     0  0   863M                     brw-rw---- part                  
    └─sda6                     0  0 157.2G                     brw-rw---- part
    

    /home is not mounted?

    /etc/fstab:

    UUID=XXXXXXXX /home ext4 defaults,relatime,data=ordered 0 0
    
  • @joekamprad That’s from the live usb. I have no access to the system otherwise. When trying to boot, home gets mounted along with data

kernel148 updates71 display59 kill1 Posts 25Views 332
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.