• Upgrade broke my system

    Today’s update of kernel and nvidia driver gave an unexpected result.


    I booted from an USB drive and tried to downgrade the suspected packages, but no luck so far.
    Any suggestions or a reinstall?

  • @surullsokk
    You used the ‘downgrade’ program for downgrading, or how did you try that?

  • @manuel No, never heard of a downgrade program. Used pacman -U

  • @surullsokk
    Did you arch-chroot first to the installed system?

    Downgrade is a simple program to use. Something like:

    sudo downgrade "program-name"

    and it gives you a list of versions you may downgrade to.

    But a reinstall is also a sensible option. Often it is faster than digging deep for the reason of the defect.

  • @manuel Yes, I did chroot. I will try the downgrade program and see if I can find a kernel that boots, if that’s the problem. It probably isn’t or others would have this too.

  • @surullsokk
    Ok. You might also want to try another kernel if it is somehow a kernel related issue.

  • encrypted install also ?

  • @joekamprad Nothing is encrypted on my installation.

  • @surullsokk but LVM 😉

    I would reinstall kernel and headers and regenerate kernel images and grub from chroot, and also install lts kernel and its headers.
    sudo pacman -Syyu
    sudo pacman -S linux linux-headers linux-lts linux-lts-headers
    sudo mkinitcpio -P
    sudo grub-mkconfig -o /boot/grub/grub.cfg (only if grub is used)

  • @joekamprad

    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Can be replaced with

    sudo update-grub

    But it actually doesn’t matter. It just looks nice :)

  • @jshamg
    Antergos and Arch do not have command update-grub. That command can be found e.g. in Manjaro and Ubuntu. All in all, it does the same as that grub-mkconfig stuff Joe mentioned.

  • Re: Upgrade broke my system

    I finally fixed my problems after 2 days of googling and swearing. From what I could see the HOOKS in /etc/mkinitcpio.conf was missing lvm2 (I’m not sure if that was the initial problem or if it happened during my attempts to fix things).

    However, the problem was greatly exacerbated by grub-mkconfig not being able to run well in a chroot environment. It took hours and I’m not even sure the final /boot/grub/grub.conf was correct. This was solved by adding a /run/lvm to the chroot:

    mkdir /mnt/hostlvm
    mount --bind /run/lvm /mnt/hostlvm
    arch-chroot /mnt
    ln -s /hostlvm /run/lvm

    With this grub-mkconfig runs properly and finishes in 2 secs.

system145 upgrade81 broke25 Posts 12Views 270
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.