• Gnome Control Center / Samba Problem

    I went through the Antergos Samba guide - twice, actually, on 2 different Antergos machines. One one, it worked perfectly! The shares are up and available. On the second one, however, something’s gone wrong.

    I went through the entire guide, and everything should work, but when I go to Nautilus and right click > “Sharing Options” > “Share this Folder” it gives me an error, telling me I need to enable Sharing in the System Settings.

    So I go to Gnome Control Center, to this section:

    alt text

    I can select Require Password, and I can add a password, but the top left “OFF” button - when I click it to turn it ON, it just immediately turns off again. (That bottom button will change from gray to blue, but I can’t make any selections or anything with it.)

    I’ve restarted repeatedly, updated everything - I even tried to start Gnome Control Center as root (sudo gnome-control-center failed without launching) and I can’t figure out how to fix it.

    Any thoughts?


  • i can see a dav:// url …

  • @joekamprad said in Gnome Control Center / Samba Problem:

    i can see a dav:// url …

    Does that mean something? That path gives an error message (“Oops, something went wrong” etc) when I paste it into Nautilus.

  • you want to connect via samba protocol and not dav as far as i understand…

  • Hm. I’m not sure what that means. The only way I’ve worked with sharing is mounting the foreign folder like

    mount -t cifs // /mnt/shares/

    How do switch from dav to samba?

    (Why is dav the default? Should I be using dav instead?)

  • I do not have dav nor samba shown inside gnome-control-center i do only have VNC there, as i do configure it. so there is may something needed to install to show samba inside sharings at gnome-control-center… but i do not think it is needed to work with samba shares inside nautilus.
    But the Wiki say:

    "Under GNOME you need to put off sharing personal files like this:
    switch OFF Sharing Personal Files on Sharing under System Settings…
    System Settings --> Sharing --> Sharing Personal Files --> OFF"

    samba nautilus-share gnome-user-share gvfs-smb must be installed and make sure to configure a maybe present firewall (personal or network based) to let samba passing.

gnome361 samba37 control17 center7 Posts 6Views 135
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.