• VMWare Player


    Hi, I’m new to Antergos, I used Ubuntu for many years and is the first time I see this error running VMwarePlayer.
    “Could not open /dev/vmmon: No such file or directory.
    Please make sure that the kernel module `vmmon’ is loaded.”
    I installed VMPlayer as I used to do , download it form VMWare server and run the Bash installer.
    I found I can overcame the error running
    "sudo vmware-modconfig --console --install-all "
    but I have to do it every time i start the computer.
    i installed “open-vm-tools” but still get the error.
    Any suggestion is welcome
    Thanks ☺

  • @saulosw
    There are a couple of alternatives:

    • install vmware-workstation from AUR
    • install virtualbox

    AUR is a user supported repository of packages, i.e. the packages are not officially supported, but supported by any user.

    For AUR, you need to enable AUR support in Pamac package manager. Then just search for vmware-workstation and install it.

    An alternative virtual machine manager is virtualbox. It can be installed directly with Pamac package manager, as it is not in AUR.

    I know virtualbox much better than vmware. In host, virtualbox needs the following packages: virtualbox, virtualbox-host-modules-arch (alternatively virtualbox-host-dkms). And optionally, packages virtualbox-ext-oracle and virtualbox-guest-iso may come handy, depending on what you want to do.

  • @manuel said in VMWare Player:

    vmware-workstation

    Thanks Manuel,
    but i get this error
    Verifying source file signatures with gpg…
    ncurses-6.1.tar.gz … FAILED (unknown public key 702353E0F7E48EDB)
    ==> ERROR: One or more PGP signatures could not be verified!
    I have to use VMware because I share the VM with my other computer and transfering all my VMs to Virtualbox is painfull and require contact MS for reactivate the license ☹
    Ok error solved :)

  • OK all working now.
    I had to uninstall /delete some VMWare folder .
    then install VMWare 15 from AUR
    Reboot
    And now also the VMwarePlayer is working fine.
    Thnaks a lot.
    ☺

vmware19 player17 Posts 5Views 177
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.