• Ignore kernel update


    Hello guys,

    my pc has a kernel issue. If I use a kernel above 4.14.74-lts, my PC doesnt shut down properly. Therefore I have installed kernel 4.14.74, but the system wants to upgrade it always to 4.14.88.

    How do I ignore that?
    Its possible to set this kernel as default at the grub menu?

    lg mak

  • @makarch
    You might want to try kernel package ‘linux’. It has version 4.19.8 now.

    sudo pacman -S linux linux-headers
    

    I really recommend against using such old kernel versions like 4.14.74.

    It is possible to ignore kernel updates, but doing that involves real security risks.
    To ignore updates, see

    man pacman.conf
    

    and look for option IgnorePkg.

  • The problem is that every kernel above 4.14.74 doesnt work properly. That includes 4.19.8 as well.

    After month of trying to figure out why the pc doesnt power off, this is the only solution I have. And I really got bored pressing the reboot button several times to power it off after that.

  • https://www.asrock.com/mb/AMD/FM2A78M Pro4+/#BIOS

    may you can give boot log:

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1
    
  • You can open this?

    Kernel 4.14.74-1-lts

  • @makarch
    As Joe implied, BIOS update might help. But be sure to have the exactly correct BIOS update, not just something close to the right one.

  • @makarch
    It opens OK. But for comparison, can you give the same with a failing kernel version?
    Note that you may use the downgrade package to install any kernel.

  • Oh, sry I didnt get that.

    Well, I bought it in 2017 and made an update back then and have searched for new firmware now. Those firmwares at the asrock page are from 2016. Therefore I think I have the newest one already.

  • FM2A78M Pro4+, BIOS P2.40 02/05/2016

    there is no update for your Bios…

  • @makarch said in Ignore kernel update:

    Oh, sry I didnt get that.

    If you meant the downgrade, there is a package called ‘downgrade’ that lets you install any version of any package, including the kernel.

    For example, to downgrade linux-lts to an earlier version, you may use command

    sudo downgrade linux-lts
    

    and select the version you want.

kernel148 ignore2 Posts 11Views 174
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.