• Software using QT don't use the system font


    Hello,

    I’m in front of quite a strange issue. I know I don’t come here often because I know my way around Linux and the ArchWiki but this time I am stuck.

    I use 3 softwares build with QT and these 3 use an other font that the system defined one, and know you’re thking yah and what the problam you can still read? No I can’t because they have “choosed” a non latin font. the 3 softwares are VLC, OBS, Shotcut, and the other commpon thing they share is hat they are multimedia softwares.

    Here is an exemple of what happen with vlc :

    http://image.noelshack.com/fichiers/2018/50/6/1544842063-capture-d-ecran-du-2018-12-15-03-46-57.png

    I’m sorry I don’t know how to post an image and can just put a link, I hate markdown.

    I have strictly no idea how and why this is hapenning. And what to do to reverse it.

  • qt5ct is your friend, as qt handeling theme and font setting on its own, under GTK DE Antergos recomment qt5ct.

    https://wiki.archlinux.org/index.php/Uniform_look_for_Qt_and_GTK_applications

    https://wiki.archlinux.org/index.php/Qt#GTK+_and_Qt

  • Thank you it worked. But I had to modify the config file itself first because QT5CT was also plagued by that problem.
    And in the config file the font section was empty so once I wrote the police in it everything got back to normal. But I still have no clue why it sudenly changed font.

  • qt5ct was updated yesterday 14.12.2018

  • It may be the environment variable QT_QPA_PLATFORMTHEME.
    AFAIK, the value of that variable should be qt5ct.

    See the value using terminal command

    echo $QT_QPA_PLATFORMTHEME
    
  • @joekamprad said in Software using QT don't use the system font:

    qt5ct was updated yesterday 14.12.2018

    Is has been like that since at least 3 weeks I didn’t had time to look into is the past 2 weeks.

    @manuel said in Software using QT don't use the system font:

    It may be the environment variable QT_QPA_PLATFORMTHEME.
    AFAIK, the value of that variable should be qt5ct.

    See the value using terminal command

    echo $QT_QPA_PLATFORMTHEME
    

    The value is set to qt5ct but now QT5CT guive me an error. It says that QT_STYLE_OVERRIDE is set to GTK but I cna’t found it anywhere in the usual suspect env files.

    But after stopping being dumb and drank some coffee, its the morning for me I thought “unset you twat” and unset the env var. Why it was set that way and what it had to do with my font problem may still be an unknown thing. QT5CT still shows the error after my next reboot I’ll know if that has been corrected.

  • what if you start qt5ct with:

    LANG=C qt5ct
    
  • So after a reboot.

    qt5ct still gives the same error. Same as starting it with LANG=C.

  • @nekosan
    On Xfce the only active environment variable starting with QT_ is that QT_QPA_PLATFORMTHEME. I don’t have QT_STYLE_OVERRIDE active at all.

  • http://image.noelshack.com/fichiers/2018/50/7/1544962859-capture-d-ecran-du-2018-12-16-13-20-10.png

    I dn’t have this variable enabled either but the message is still there. that doesn’t make any sense to me.

  • @nekosan
    Before finding the reason why the variable exists (maybe some Cinnamon setting?), as a workaround, you could unset the variable before starting affected programs, e.g.

    unset QT_STYLE_OVERRIDE ; qt5ct
    
system143 font34 Posts 11Views 195
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.