• NetworkManager continuously asking for authentication (eduroam)


    I can use Networkmanager to connect to my home wifi (wpa/wpa2) aswell as my smartphone hotspot (wpa2) without any problems.
    Whenever I try to connect to my universitiy’s wifi, NetworkManager repeatedly asks for authentication.
    My username & password are definetely correct and I configured NetworkManager accordingly to this guide.

    NetworkManager log:

    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9683] Config: added 'ssid' value 'eduroam'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9683] Config: added 'scan_ssid' value '1'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9683] Config: added 'bgscan' value 'simple:30:-65:300'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9683] Config: added 'key_mgmt' value 'WPA-EAP'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9683] Config: added 'password' value '<hidden>'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9683] Config: added 'eap' value 'PEAP'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9683] Config: added 'fragment_size' value '1266'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9684] Config: added 'phase2' value 'auth=MSCHAPV2'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9684] Config: added 'identity' value '**edited**@th-nuernberg.de'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9684] Config: added 'anonymous_identity' value '[email protected]'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9684] Config: added 'proactive_key_caching' value '1'
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9911] device (wlp2s0): supplicant interface state: disabled -> inactive
    Dez 14 12:01:16 NBChristian NetworkManager[373]: <info>  [1544785276.9989] device (wlp2s0): supplicant interface state: inactive -> scanning
    Dez 14 12:01:17 NBChristian NetworkManager[373]: <info>  [1544785277.9942] device (wlp2s0): supplicant interface state: scanning -> authenticating
    Dez 14 12:01:18 NBChristian NetworkManager[373]: <info>  [1544785278.0092] device (wlp2s0): supplicant interface state: authenticating -> associating
    Dez 14 12:01:18 NBChristian NetworkManager[373]: <info>  [1544785278.0180] device (wlp2s0): supplicant interface state: associating -> associated
    Dez 14 12:01:42 NBChristian NetworkManager[373]: <warn>  [1544785302.5561] device (wlp2s0): Activation: (wifi) association took too long
    Dez 14 12:01:42 NBChristian NetworkManager[373]: <info>  [1544785302.5562] device (wlp2s0): state change: config -> need-auth (reason 'none', sys-iface-state: 'managed')
    Dez 14 12:01:42 NBChristian NetworkManager[373]: <warn>  [1544785302.5603] device (wlp2s0): Activation: (wifi) asking for new secrets
    Dez 14 12:01:42 NBChristian NetworkManager[373]: <warn>  [1544785302.9710] sup-iface[0x559f435344f0,wlp2s0]: connection disconnected (reason -3)
    Dez 14 12:01:42 NBChristian NetworkManager[373]: <info>  [1544785302.9714] device (wlp2s0): supplicant interface state: associated -> disconnected
    Dez 14 12:01:44 NBChristian NetworkManager[373]: <info>  [1544785304.9976] settings-connection[0x559f4353f2a0,a18a1fb1-7170-4c11-ae6a-e88314ab3d39]: write: successfully commited (keyfile: update /etc/NetworkManager/system-connections/eduroam.nmconnection (a18a1fb1-7170-4c11-ae6a-e88314ab3d39,"eduroam"))
    Dez 14 12:01:44 NBChristian NetworkManager[373]: <info>  [1544785304.9978] device (wlp2s0): state change: need-auth -> prepare (reason 'none', sys-iface-state: 'managed')
    Dez 14 12:01:44 NBChristian NetworkManager[373]: <info>  [1544785304.9983] device (wlp2s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
    Dez 14 12:01:44 NBChristian NetworkManager[373]: <info>  [1544785304.9985] device (wlp2s0): Activation: (wifi) connection 'eduroam' has security, and secrets exist.  No new secrets needed.
    

    Active services:

    UNIT FILE                                   STATE  
    org.cups.cupsd.path                         enabled
    [email protected]                             enabled
    avahi-daemon.service                        enabled
    bluetooth.service                           enabled
    dbus-org.bluez.service                      enabled
    dbus-org.freedesktop.Avahi.service          enabled
    dbus-org.freedesktop.ModemManager1.service  enabled
    dbus-org.freedesktop.NetworkManager.service enabled
    dbus-org.freedesktop.nm-dispatcher.service  enabled
    dbus-org.freedesktop.timesync1.service      enabled
    display-manager.service                     enabled
    [email protected]                              enabled
    haveged.service                             enabled
    lightdm.service                             enabled
    ModemManager.service                        enabled
    NetworkManager-dispatcher.service           enabled
    NetworkManager-wait-online.service          enabled
    NetworkManager.service                      enabled
    org.cups.cupsd.service                      enabled
    systemd-timesyncd.service                   enabled
    avahi-daemon.socket                         enabled
    org.cups.cupsd.socket                       enabled
    remote-fs.target                            enabled
    pamac-cleancache.timer                      enabled
    

    Thanks in advance

  • Just a thought, but does the security protocol (WPA2, WEP …) match?

  • Security WPA & WPA2-Enterprise
    Authentication Protected EAP (PEAP)
    Anonymous identity anonymou’at’th-nuernberg.de
    CA certificate T-TeleSec GlobalRoot Class 2
    PEAP version Automatic
    Inner authentication MSCHAPv2
    Username students email

    Do you have choosen certificate inside config?

    What backend you are using to configure?

    i would take nm-connection-editor

  • Hey @joekamprad, thanks for your answer.
    Sorry for my late response, antergos’ auth0 is really giving me a headache logging in…

    Yes, I’ve chosen the correct certificate

    • The one provided (pdf)
    • The system certificate from
    /etc/ca-certificates/extracted/cadir/T-TeleSec_GlobalRoot_Class_2.pem
    

    neither of those is working.

    I’ve used both nm-connection-editor and gnome settings to configure the connection.

  • Hi,
    I honestly can understand you. We here in Berlin have eduraom, too. It always getting on my nerves. For now everything works for me. A friend of mines iphone is not able to connect to the network and we think its because of some defect in his 5ghz reciever in the phone… But we dont know we didnt managed to get it to work. Maybe you try our guide (obviously its very similar and you have to use your university account) and use our telekom certificate, because its working for me, maybe its the same as yours and maybe its working for you, too.
    Good luck!
    https://www.tubit.tu-berlin.de/menue/dienste/kommunikation_internet/wlan/zugang_und_anleitungen/eduroam_mit_linux_gnome/

    Greetings from Berlin :D

  • It’s not working unfortunately…
    But the problem might be the certificate.
    Is it correct to just choose the certificate file from /etc/ca-certificates/… or do I need to import/install/trust it?

  • in my case i leave my cetificate right in my documents folder (or download or whatever) maybe thats the problem because etc is not accessible for you nm, but i dont actually think thats the reason…

networkmanager21 authentication13 asking7 continuously1 Posts 7Views 122
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.