• Audio pop on resume from sleep


    I recently installed a second soundcard because the original onboard one has a bad connection in the jack. Everything works fine, except, with the speakers plugged into the new sound card, I get a loud pop every time the computer resumes from sleep. Never had a pop before, and didn’t change any configuration with the new install. On googling I found this https://bbs.archlinux.org/viewtopic.php?id=168920, which seems relevant, but may be outdated – it refers to /etc/pm/sleep.d/90alsa, which doesn’t seem to exist anymore (the post was from 2011). Is there an equivalent place where a soundcard script would be hiding in the Antergos setup?

    System details: DE is XFCE

    lspci | grep udio 
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    06:00.0 Multimedia audio controller: C-Media Electronics Inc CMI8738/CMI8768 PCI Audio (rev 10)
    

    The C-Media one is the one with the pop.
    Any help would be appreciated.
    Thanks!

  • This might have nothing to do with software or configuration. I assume your externtal sound card is USB connected, and that your PC powers down all USB devices during S3 (suspend). In that case the pop is just a result of power coming back to the electronics in your USB device.
    You can test this by changing a BIOS setting to keep USB devices powered up. Many recent motherboards support that option.
    Alternatively, you might try another sound card which handles power transients better. I have an Asus Xonar U3 and the pop is barely noticeable.

  • Thanks for replying!
    The sound card is actually PCIe, not usb. But I’m sure you are right, it’s power being restored that makes the pop. It is a cheap sound card (about $11 noname from China).
    I’m wondering though if there is a way to mute the speaker just before sleep and then unmute about 1 sec after wake. There must be a place to put such scripts so that they run automatically. I’m hoping someone can point me to the right location…

  • It could be the op-amp on the cheap soundcard when it resumes from sleep it pops as the op-amp is reinitialised.

  • Well I think I am going to have to live with it or get another sound card. I did an experiment and muted sound before putting the computer to sleep. It still popped when it woke up. So running a script on going to sleep probably won’t help. As brianhedley798 says, it’s probably in the electronics of the soundcard and completely unrelated to the OS and what the driver is doing. Thanks to joekamprad though for pointing me to how to create such a script. That may come in useful in the future.

  • OK now I feel dumb. A very simple test: powered off the computer, then powered on again. The pop happened immediately, before even the BIOS started. So nothing to be done, it’s the electronics.

audio50 sleep18 resume8 pop3 Posts 7Views 164
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.