• KDE fully broken after today's update

    Thanks for the suggestion. However, I’m not sure how could it help? Even in a theory?

  • Laptop now works after the latest upgrades… Both desktop systems still get screwed after applying updates.

  • @toxpal I was hypothesising that the particular user config was “corrupted” and that is why when logged in as that user there were issues.
    I solved at least one weird problem by ditching all config files and starting from scratch.
    I did this when I realised that my son could log in without seeing the weird issues.

  • That makes sense, will try…

  • Had similar issues in the past, seems some updates corrupt some files in the ~/.config folder and this keeps the system from booting into graphical mode.
    Since this has happened several times to me, I have begun to make a backup of my .config folder once a week so I can simpy throw it in and replace the existing, corrupted .config folder. This even works from within a terminal.
    If you simply delete/rename the .config folder, and have the system create a new one, you’ll use all the modifications you made to your desktop,

  • @Jeannie____ said in KDE fully broken after today's update:

    you’ll loose all the modifications you made to your desktop


  • Pardon, mais l’anglais n’est pas ma langue autochtone, et le systeme semi rompu du forum ne permet pas de faire des corrections ulterieures.

  • @Jeannie____ Vi rajtas korekti viajn afiŝojn.

  • My KDE is also borked, I seem to have a problem with compositing and vsync with full screen repaints.
    Whenever I move the mouse or click on something the screen starts blinking.
    As far as I remember, the issue persists since the update to KDE Frameworks 5.53.0 and the 4.19.x kernel.
    I have an nVidia card, which I’m using with the open source nouveau/mesa drivers.

    Could you help me out, please?

    Edit: With vsync turned off, the issue disappears, however I can’t stand tearing. 😋 After a few minutes of waiting I can safely turn on vsync; still, this is not normal behaviour.

  • No issues here with KDE, using the proprietary driver with my GTX 1060, maybe the feature incomplete nouveau driver simply is not doing it’s job properly?

  • @hordosikrisztian If this happens for all users, then the issue you have is system wide, so the suggestion I made will not help.
    Check that first. The simplest way would be to create a new user, logout, then login as the new user and see if the compositing issues exist or not.
    For the record, I use a fairly ancient nvidia card, GT 630 with nvidia driver (dkms version) without issues.

  • Thank you for the suggestions, I decided to switch to the official nVidia drivers, now everything is fine. :)

    You call that an ancient card?!
    I’m a proud owner of a GTS 250. 😋

  • Did more search on Arch forums, and found some suggestion to disable Compositor. So performed a full upgrade again, and everything seems to work well.

    Not 100% sure if it’s related to disabled Compositor, or maybe some packages got bug fixes recently, and they just work now… Any command line to enable/disable KDE compositor? So I could try enable it now (to see if it works) and then disable it via command line again (in case my desktop becomes useless again after Compositor is activated).

kde206 broken38 todays7 fully3 Posts 33Views 1820
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.