• Blank screen after log-in (Nvidia issue?)


    Hi folks,

    First post here.

    I was happily running Antergos on Gnome Wayland for several months until a recent update left me unable to log in via my display manager. (I provide more details below, but I’ve tried both GDM and LightDM.) In short, I am presented with the DM log-in screen, but after entering my credentials I am taken to a blank screen where my only option is to reboot manually.

    Some quick details about my system. I’m running Antergos on a Dell Precision 5530 (same basic build as the XPS 15 9570), with Linux kernel 4.19.4. This laptop has hybrid graphics with two cards: 1) an integrated Intel GPU (UHD 630) and 2) an NVIDIA Quadro P2000.

    I suspect that the root of my problems are tied to the Nvida card. I first encountered a post-login blank screen after installing the nvidia and nvidia-utils packages a few months ago. (I quickly learned that getting Nvidia cards to play nice on a Linux laptop is no cakewalk.) However, I was able to unistall these packages via TTY1 – see also below – and revert to the Nouveau driver. My system quickly went back to normal… That is, until this recent update :(

    I’m wondering if some orphaned Nvidia dependency remains “un-removed” and is interfering with my setup? (I remember running sudo pacman -Rs rather than sudo pacman -Rns, so maybe?)

    FWIW, here’s my output from pacman -Qs nvidia:

    local/libvdpau 1.1.1+3+ga21bf7a-1
        Nvidia VDPAU library
    local/xf86-video-nouveau 1.0.15-3 (xorg-drivers)
        Open Source 2D acceleration driver for nVidia cards
    

    And here’s my output from lspci -k | grep -A 2 -E "(VGA|3D)":

    00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
    	DeviceName:  Onboard IGD
    	Subsystem: Dell Device 087d
    --
    01:00.0 3D controller: NVIDIA Corporation GP107GLM [Quadro P2000 Mobile] (rev a1)
    	Kernel driver in use: nouveau
    	Kernel modules: nouveau
    

    Some additional information that may be helpful:

    My current workaround is to log in via TTY1 (i.e. by hitting “e” during the GRUB boot screen and appending “3” to the line beginning with “linux”). Interestingly enough, I am able to get into my Gnome Wayland environment by launching it directly (i.e. $ sudo XDG_SESSION_TYPE=wayland dbus-run-session gnome-session)… or by first starting GDM from TTY1 (i.e. sudo systemctl start gdm). Logging in via GDM from TTY1 like this works perfectly. No more blank screen problems and I am even able to log out and switch back in without issues. Everything else works as expected too: programs, pacman, etc.[1] So it really does some like something specific to the initial boot load.

    I should add that logging in to Gnome Xorg doesn’t work either. In fact, here’s something else that may be of use in trying to solve my problem. When I try to log in the normal (non-TTY1) way, GDM only presents me with three desktop environment options: “Gnome”, “Gnome Classic”, and “Plasma”. However, when I launch GDM from TTY1, I can choose from five options: The three I’ve just listed and now also “Gnome on Xorg” and another “Plasma” option (presumably on Xorg too).

    Any ideas? Many thanks in advance.

    [1] Well, with the exception of coming out of suspend/hibernate. If that happens, then I’m again forced to reboot manually.

    UPDATE: I added “nouveau.modeset=0” to GRUB’s kernel parameters as per various online suggestions. This appears to solve the log-in and hibernate problem… but only for Xorg session. In other words, now my Wayland session(s) have completely disappeared! (This thread seems related, but the given solution – reinstalling GDM and rebooting – didn’t work for me.) I’d really prefer to run Wayland because of HiDPI issues…

    UPDATE 2: Problem solved! I needed to enable early KMS start as detailed in this Reddit thread: https://redd.it/9wycf1 In case any one else runs into this issue, here is the full solution:

    • Disable Nouveau, by adding “nouveau.modeset=0” to the GRUB kernel parameters (i.e. edit /etc/default/grub):
    /etc/default/grub
    ----
    GRUB_CMDLINE_LINUX_DEFAULT= ... nouveau.modeset=0"
    
    • Regenerate the grub.cfg file:
    sudo grub-mkconfig -o /boot/grub/grub.cfg 
    
    • Enable early KMS start for the Dell’s integrated GPU, by adding the Intel modules to /etc/mkinitcpio.conf:
    /etc/mkinitcpio.conf
    ----
    MODULES=(intel_agp i915)
    
    • Finally, regenerate initramfs:
    sudo mkinitcpio -p linux
    

    After rebooting I can now log directly into Gnome Wayland from GDM. What’s more, my suspend/hibernate problems have also been be solved. WInning.

  • It sounds like Wayland sessions is turned off in GDM, just check if usewayland=false in /etc/gdm/custom.conf
    if so change it into true.

  • @grantm said in Blank screen after log-in (Nvidia issue?):

    “Gnome”, “Gnome Classic”, and “Plasma”.

    running GNOME and Plasma/KDE onto same install, is known as problematic too.

    Same for optimus/Bumblebee (hybrid GPU Systems) if they are unconfigured (uncontrolled).
    Black screen can be a confusion on what GPU should be used…

  • @Bryanpwo Thanks for the suggestion. However, I checked and “WaylandEnable=false” is commented out. I also tried uncommenting and setting to “true”, but that didn’t work either.

    @joekamprad That’s interesting. I guess my next step will be to remove KDE/Plasma and see if that solves the problem.

    I should also perhaps also just bite the bullet and try to re-install the Nvidia packages and manage the GPU in my hybrid setup via Bumblebee. I know that @just and others have written a nice tutorial on it. (Although, to be honest, I’m still a little confused about this option since the Bumblebee project appears to be stasis – does it support the latest cards? – and every tutorial I’ve seen appears to be aimed at Xorg rather than Wayland.)

    Thanks again for the all the suggestions. I’ll report back in a day or two, since I’m heading away for the weekend. Bad timing on my part; I forgot how quickly people on this forum are to respond and help out!

  • @grantm using bumblebee will only work with nvidia properitary driver and will make wayland more hard to work (or it will be impossible) …

    Only solution to get wayland back working will be disable the intel GPU and use only Nvidia GPU with nouveau driver… (or vv will say disable nvidia (discrete) GPU and use intel only)

  • Problem solved!

    After trying various workarounds, it turns out that the problem was related to GDM loading before KMS could be started. If this Reddit thread is to be believed, my laptop is too fast :)
    https://www.reddit.com/r/archlinux/comments/9wycf1/wayland_option_gone_from_login_screen_gnomegdm/e9ofoit/

    I’ll mark this thread as solved and also add the full solution in my original post in case anyone else runs into the same problem.

gdm44 nouveau18 gnome wayland3 nvida3 Posts 6Views 122
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.